Wyze Services login

Hi, is everyone able to login on the Wyze Services page?

I was trying to login this morning, and 5 minutes ago. On both trials, the Login button is greyed out and I am not able to login after entering my id and password. I wonder if it is just me…

I am able to login from my Chromebook. I go to the Wyze Site, click on My Account and log into that, then I Click on My Services and am able to get in.

I use 2 Factor Authorization, the login button stays grayed out until you put your 2FA in.

Was just about to post about this…trying to login to manage cam subscription, but unable to login.
Clicking login button does nothing.
Tried different browsers, in private mode, nothing.
The account i am trying to loginto, does NOT use 2fa.

i tried the method mentioned above, and the My Services link just loads the same inoperable Wyze Services web page.
No capatacha or anything shows.

I just clicked the link in your post. You should see a reCAPTCHA check box to proceed. I don’t see it on yours. Have you tied clearing the Cache on the Browser you are using? I am using a Chromebook and Google Chrome as my Browser

Here is what I get:

Initial Login Page

Next Screen is 2FA - Clicked Next

Then it asks for the Code

I enter the code and am at the Service Page.

Nope that does not show up at all either on a mobile browser on different internet connection. I don’t recall there ever been one of those checks on there anyway.

I am at a loss here. Have you tried contacting support:

By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

Or online: Wyze.com/support

phone support is typically faster however this isn’t always true due to fluctuation in the amount of calls.

Why? THIS is a form of contacting support.
You are WYZE company.
Why not you fix the issue.

I would love to fix the issue, but I don’t work for Wyze. These forums are supported by the general community. Some Wyze Employees go through the forums and will chime in at times. This is why I am recommending you to contact support and actually get in touch with individuals who can actually update the form.

However, I and others are not experiencing the issue. Could be you have some type of blocker installed which could be preventing the reCAPTCHA from working properly.

I have custom DNS sever yes, have for years,but no so on external internet connections outside my home, like at a friends or work, or LTE on my phone. Does not work anywhere, even on a VPN, even at a family members house in their computer.
I can log into the app and normal website store etc fine, only the Services page area is not working. So, I can not manage any WYZe services.
I don’t do phone support…its not 1995.
And its always useless and a waste of time, to be told the same scripted troubleshooting steps, that i have already tried.

What services are you trying to work with? I only have CamPlus in my list. That is there so I can add, renew, or remove licenses.

As for not calling, you can always go to the support link I provided. They offer Chat sessions as well.

But not sure how you are going to get this resolved if you don’t reach out to Wyze in some fashion. Maybe someone else will see this thread and respond as well. I am not sure why you don’t see the reCAPTCHA, but if you get this resolved, it would be great to hear back and get the resolution.

Its working now. I haven’t done or changed anything…

1 Like

I had this problem and fixed it by disabling my adblock on the wyze page. I guess the adblock was prevent the captcha from displaying.

1 Like