Wyze Scale S only display in Kg after update

Tried all suggestions and it still reverts to kg. There is one anomaly though. My app has the switch in settings to select either lbs or kg. My wife’s, who also uses the scale, app doesn’t have that switch. I have to switch the scale to lbs for her to use it.


I removed the batteries from the scale for a minute and reinstalled them. This reboot seems to have solved the issue for me.

You didn’t mention using the button on the back of the scale labeled “UNIT/RESET”…Wyze said that was necessary to resolve the issue.

please check the button on the back labeled UNIT/RESET to make sure it’s on the correct setting. The app will then sync when connected

Try using that button and see if that helps, then report back again.

Mine also shows only kg and a weight of 0 regardless of what’s on it. It also doesn’t seem to be connected to my phone anymore. I removed the batteries many times for a hard reset but nothing changes. It’s about to go in the garbage. I love the Wyze cameras, but this scale and the watch seem to be a lesser quality.

Still not working correctly. Randomly switches to kg.

I guess Wyze isn’t interested.


1 Like

I have the model with the 4 circular disks, one in each corner. I was able to ‘fix’ this by letting scale power off, turn it on then hold the reset button. The screen should display Clr. Start the scale by touch with two feet and it should restart in Lb.

How long has it stayed in lbs for you though? I can get mine to reset to lbs, but then it keeps switching back to kg again, sometimes weeks later, sometimes only a day or so.

1 Like

So far it hasnt reset to kg but it has only been a few days. The other thing i did prior was delete the device and re add it, then do the reset. Some have taken the batteries out as a way to reset.