Wyze Robot Vacuum Recharge

Good to know, I did update my firmware on the bot as part of the initial setup. I’m currently running firmware version 1.6.75 so check yours through the app and see if it might need an update.

Shawn Baker

I’m running 1.6.75 as well.

It’s good to know that it apparently will return home to charge below 8%…which makes sense!

Well, I don’t know if it would have completed the survey of the house. Instead of taking my own advice and just leave the thing alone I decided that I should empty the bin while it was stopped. That would have been fine but I managed to wiggle it and disconnect it from the charger briefly. That had the unintended consequence of aborting the existing cleaning cycle. I did run it again in that area and the lidar picked up areas that it hadn’t scanned yet but since it didn’t assign those areas a room number I’m unable to send the vacuum over to clean those new areas. Looks like Wyze still has some features they need to add to their app. Specifically I REALLY want to be able to adjust what the software thinks is a single room, basically be able to edit the map. I’d love to be able to rename the rooms that are automatically created after the scan. And somehow my vacuum managed to map my entire house where the map is actually twisted slightly, this means that “straight lines” are actually angles and require many stop and starts around the edge of the room. Being able to “twist” the entire map so the the walls align with horizontal and vertical would be very useful. I know the device is new and there will be many changes and tweaks coming so I’m willing to give it some time to mature. But overall the bot is doing pretty good, it completely filled its bin with dirt and had only covered about 2/3 of the house.

I think that I might clear my map and let it rescan the entire house tomorrow. I’ll probably put it on quiet mode so it has more battery power to get to the end on hopefully one charge.

Good luck!


Vacuum seems to work fine; took 3 runs (recharges) to complete scan (and cleaning)of floor plan. However. it seemed to designate “rooms” randomly, with one of our “rooms” consisting of over 75% of the floor plan. When we tried to clean just one part of the big “room” (the kitchen), we could not find a way to limit the space to be vacuumed without creating virtual walls. This worked well until we found that the virtual walls appear to be permanent, which means you apparently need to start the whole floor scan over in order to vacuum anything other than, in our case, the kitchen. If we cannot adjust the scan to create useful rooms, is there a way to at least add a way to remove virtual walls? Thanks.

I have seen the same problems in the last 5 days of testing out my new unit and the mapping, resetting of mapping constantly, lack of being able to create areas, etc. is basically a joke at this stage of robot vacuum development software. If other brands have this capability and ALL of these vacuums are designed and manufactured in China, having basic and similar features should be a slam dunk, especially on the software end.

Yeah, room breaks appear to be completely random. It probably has something to do with how much area their software can consistently generate a cleaning route for in one go. I have one large “room” which was the first area scanned and all the other rooms were areas that were outside the main room but not touching. The virtual walls are not permanent in my app, I’m using iOS so there could be a difference if you use Android. But for me I can click the little button for virtual walls and in there each wall (red box) has two icons, one for resize and the other is a trashcan to delete it. Some I had made real small so I had to make them bigger before I could click on the trashcan icon.

There is another post on the forum that we have going about requesting features for the vacuum app, I’ll post the link here for anyone to check out, add their 2 cents, and help upvote stuff.

Thanks for the info. I remapped without the virtual walls so I cannot see what you are talking about, but I do not remember seeing the two icons (I do use Android). I have quite a few other Wyze products (indoor and outdoor cameras, scale, headphones and even masks), all of which are very reasonably priced and work great. The vacuuming action seems to work well with this product, Surprisingly to me its the software that seems not quite ready for prime time.

What i found on the initial mapping is you have to set it to clean then LEAVE IT ALONE. Leave the suction on quiet and let it do its mapping if it runs low on battery it will return to the base then resume again after charging back to 100% (Im pretty sure about that but didnt keep a super close eye on it.) After the initial map and scan you can create virtual walls that are permanent. There WAS a way to edit the maps which hopefully will return, If it doesnt I cannot recommend this thing,

This is the map it generated for me after i reset and the editing was removed

Mine didn’t map the whole house. Then it ran low on battery before finishing the cleaning. Returned to charger and never resumed.
Doing a rescan.
Certainly needs some improvements.

Mine loses all nav logic when it needs to return to charge. It finds an obstacle and runs into it until the battery drains. Last run it did this before hitting 8%. There needs to be an ability to manually continue a clean until this gets sorted out or i will never be able to complete the initial map.

1 Like

Mine just lost it’s mind.

It was returning to charge and went into a corner of the room that it couldn’t figure it’s way out of. I finally had to pick it up (it was obviously concerned about it’s wheels not touching the ground) and manually return it.

The bot had no idea of what it was doing after that. It had forgotten that it was in the middle of cleaning and had forgotten that it’s current mission was to return to charge.

I manually backed it into the charging station. The only icon on the app is the grayed out “clean” icon. Which means, when it recharges, it will have no option to resume cleaning.

It’s a pretty cool bot, but the firmware and hardware don’t seem to be ready for primetime.

1 Like

BTW, before today’s episode, my bot could easily find it’s way home to recharge.

I think my bot had a stroke today.

Same. Just did a second remap and it returned to charger. It didn’t make it before going dead. Now at 100% and not continuing.

I think this is probably some type of bug because I had the same issue when I was initially mapping as well. It ran low on juice and decided to head back to charge and it was doing a good job navigating out of the back bedroom and then was in the last hall before making the turn to get to its charger and for some reason it decided that the wall didn’t exist anymore and tried to drive straight to the charger. Luckily for me it bumped its way down the wall till it hit the end and swung around and found the charger.

I do believe that if its busy working that it can’t tolerate being picked up, at least not at this point in time. They may get this fixed eventually but for now I’d suggest that if the bot is stuck or unable to find its path home to just scoot it in the right direction without picking it up. When the wheels come off the ground it seems to completely give up on life at that point. And this goes double if you’re doing an initial scan to create the map because if you freak it out the only way to continue right now is to delete the map and start over. But hey, just think how clean the floor will be! :sweat_smile:

Interesting. I must have mapped after the editing was removed because I never saw an option to name rooms or change the boundaries of the rooms. My map looks about like your second one. We moved it down to the basement where the one gigantic room mapping is not as big of a problem. I will admit that we liked the concept so much we went out and bought a Roomba for the main floor. Software seems much better (can easily designate rooms and can use it on multiple floors with different maps) and will empty itself, but vacuuming action seems better with the Wyze. Cost of the Wyze is much less though.

My vacuum isn’t able to get itself totally backed up to the charger when the battery is low or it’s done cleaning. It gets close, but usually doesn’t connect. A couple times it has connected and the vacuum says “starting to charge” but then it goes right back to its charger search mode again. The battery even completely died once while trying to find the charger. Don’t even get me started on how it can never remember what it’s already mapped.


Same exact problem. Touches the charging bars. Then pulls away sounds around and just keeps on doing it. I have to physically hold the docking station with one hand and press robot against it. For it to start charging. Then I have to go back a few times and keep pushing them together for the charge to continue. Terrible designs . I’m About one day away from returning it .

My vacuum also got to 8% went to charger, touches bars says starting to charge and then pulls away. It continued this until the vacuum died. :frowning: bummed.


Noticed if I have the app open the vacuum struggles to return. If I completely close the app(make sure its not running in the background) the vacuum doesn’t get stuck and can properly return to its base. Hope that helps some people.

If you pause cleaning on the app you can tell it to charge from there. Other wise wait once it hits 7% it will go charge itself