Wyze Gun Safe Battery Eject Doesn’t Work

So have had my gun safe over a year (aka out of warranty) have never had to charge it until recently. Went to eject the battery case and the button is faulty and won’t eject. Essentially it’s stuck in place no matter how hard i press on the internal button. Wyze was no help because I was out of warranty and literally the first time I went to eject it (aside from initial opening) and it doesn’t work. Anyone have any ideas on how to pry it out or other methods so I can keep the fingerprint and app unlock alive? Otherwise I’m down to manual key entry like every other basic safe out there. Severely disappointed in this after having about 10 other Wyze devices.

I just messed with mine to see if I could see an issue. There are 2 springs under the battery holder that make contact with the battery pack to power the safe. I did have to press fairly hard to release it and found it a bit easier if I was pressing closer to the bottom of the button. I do not visibly see anything it could catch on. The button is connected to a small tab that moves to allow the springs to push the battery pack up. Unless that tab is released I do not see a way to pry it out without damaging it.

Not sure Wyze wouldn’t help because being out of warranty has nothing to do with explaining how to pop up the battery holder. But just press the battery release harder. Mine was a bit hard too but got it released.

Yeah I tried pressing that button a million times on the inside. I’ve pressed it as hard as I can and it’s not budging.

Sorry for the late response. I tried pressing every which way I could and every location on or around the button and it just seems to me like the tab is either stuck or broken but it wouldn’t explain why the pack isn’t coming up if it’s spring loaded as you say. I’m at a loss here.

Try this, when you push in the release button push down on the battery pack and release it, see if that unblocks it. If not you could try carefully prying out the battery pack as you keep the release button pressed. It really shouldn’t be stuck. Have to wonder if you jammed the battery pack in backwards, but I believe it only goes in one way. Here is another thought, if the batteries leaked then the corrosion could have make it stuck in there.

1 Like

I had the same issue with 1 of my 2 safes. For the one that would not eject, i held the safe upside down while pushing the button then hit the safe a few times and it came out. I agree the springs failed. Hope this helps.

1 Like

Yeah I will admit I haven’t had the time to try and mess with it until today. So the spring failed and that may have worked for me. What I did was press real hard on it and take a pocket knife and it pried out pretty easily. Swapped the batteries and put it back in and it still doesn’t eject but knowing this I’m fine with it. It lasted well over a year for me so I won’t have to do it again for a while. It’s a shame it failed the first time I tried to eject it but don’t need to get a whole new one. Word of caution to new safe owners. Give it a check before the warranty expires.

1 Like

Yeah that’s what I did and it seemed to work. Pressed it to “eject” it and pried it out with a pocket knife. No it wasn’t backwards and no the batteries didn’t leak, just a fault spring is my guess. Thanks!

1 Like