Wyze Finally Works With Google Assistant!

There have been repeated instances of the Community Guidelines not having been followed recently on this topic.


In this situation, the moderators’ instructions are to temporarily close the comments and to call in a Wyze employee. The Wyze employee may open comments again after they have a chance to review this thread.


Moderator Note:

Regarding the above discussion of the Ignore User forum feature: This feature is hard coded into the forum software to only be available to Trust Level 2 (Member) users. Bumping up a user’s trust level to allow this is not something we would typically do.

However, our forum provider (Discourse) has decided to parametrize this setting so that we will be able to allow TL1 (Basic) users to set other users to Ignored. We expect this to be deployed in about a week or so. Once deployed, we will change the Wyze forum site to allow Ignore User for TL1 users.

Keep an eye out for this change in the next week or two (if you don’t achieve TL2 in the meantime). Once implemented, you should see all three options when clicking on the “Normal” button in another user’s profile:



The forum setting for trust level required to use the Ignore User feature has been modified. Trust Level 1 (Basic) users may now ignore other users. As noted above, if you ignore another user, you will not receive notifications concerning the user and all of their topics and replies will be hidden.


Dear Google Home Streamers,
As you know, we have been experiencing some difficulty in streaming your Wyze Cam feed to Google Nest Hubs, Chromecasts, and other compatible devices.
We need your point of view on the next step.

We have identified that the problem is linked to cold start and the audio part of the stream. For some reason, still unknown, the length of an audio segment is marked as being 24 hours long instead of a few seconds causing the players to think they have enough to render when they do not.
A cold start is defined as asking to stream when the last request to stream was more than 4 minutes ago. If it is within 4 minutes, it is considered a hot start. Hot starts do not show the audio issue and should have a high level of success.
Practically, it means: ask for the camera to be streamed, wait a few seconds and then ask again.

We have one opportunity in front of us, we should be able to remove the audio altogether from the stream making a cold start more likely to succeed.
The help that I need from you is to know if we should:
a) - Remove the audio from streaming to restore the cold start success
b) - Maintain it the way it is because the hot start is working well enough

Whatever the choice is, we have two lines of work that we are currently and will continue working on.
1 - We are continuing to troubleshoot where this audio segment length is coming from.
2 - We are working very closely with Google on the implementation of WebRTC. We have been working on it for multiple months so far and made great progress.

I can’t communicate an ETA, but we are hoping (i.e. not ready to make a commitment yet) that by Q1 2021 at the latest we should have a permanent solution to the problem. The audio will be part of the permanent solution.

  • Maintain the way it is because the Hot Start is working well enough,
  • Remove the audio from streaming to restore the Cold Start success

0 voters


is there a known problem streaming to the Lenovo clock. when i ask to stream the it says OK but nothing is displayed.

1 Like

I did some research into this as I was having issues also. There was a forum post on the Lenovo site that I can’t find again saying they only officially support a couple doorbell/security video feeds. What I found was that the clock will reply as if it’s going to do something and then fail and go back to the photo frame/clock. If start with my phone however and say “show the on ” it will show but choppily with 5 second jumps and repeated rebuffering. I’ve been tempted to buy a Nest Home to see if that improves performance as the doorbells I pre-ordered will to be useless if I can’t show the video but based on the thread above I’m not hopeful.

Actually, after seeing Frederick’s reply I thought I’d try again. Now when I tell the clock to show a camera it does try but largely fails with the buffering and huge gaps noted above. If I give it a few seconds however and tell it to who the same camera again it actually shows live! Every 10-15 seconds I’m seeing a brief black buffer but it’s generally working.

Haha, while typing I tried a second camera and now the Lenovo clock is doing what I’ve seen previously where it acknowledges the request and does nothing. Too much inconsistency!

I still don’t see ignore option yet. Not yet implemented?

@organistman Sorry about that. This was supposed to have been implemented several days ago. The site setting has been changed accordingly, but it appears that it’s not working correctly. I will have to pass this on to the forum dev team to look into. Please stand by.

@Frederik Thanks for the update. After years of hoping this would work, I sincerely hope your team can sort this out so faith can be restored in the company and the support of its products.

I was excited when you posted the workaround for a “hot start”, but that doesn’t work for me. I’ve tried about 20x over the past few days.

It looks like the majority of people have voted for removing audio to allow “cold start” success. I recall that being a topic a year or so ago as a potential workaround. What is the ETA on that update going out?


I recently got a little Lenovo smart clock and I was delighted to realize it technically CAN show my wyzecam, which I use as a baby monitor. Now I am REALLY looking forward to having a stable stream so that I can keep it running on my desk and have it act like a proper baby monitor screen, instead of my phone or a tablet.
Keep up the great work, @Frederik , and for what it’s worth I would much prefer no audio with a stable video feed any day. I voted for that in your poll too of course.

What’s the point with out the audio you can’t here no body trying to break into your home or parcels wyze shouldn’t say on the product they work with google they don’t half of the time I will get rid off my google assistant hub and stick with Amazon I never have any problems viewing the cameras


@organistman, The forum team has fixed the bug. You should be able to add other users to your ignore list now. Please DM me if you still have problems with this.


Done. Thanks.

I’m disappointed that the hot start is not working for you. It was very promising and worked systematically for us.

We are in the middle of a migration of the wowza server since Wowza made some changes to have a better support of Dash in the latest version. Unfortunately, the result is an even lower level of successful streaming so we have to troubleshoot what is happening. Once this migration is done, removing the audio is going to be the next task. Hopefully that should be mid next week but I’m not 100% sure just yet.

In regards to WebRTC, we have one more problem to solve and we should be able to start the heavy testing for the validation and acceptance. This is in line with the estimate of shipping the WebRTC support by Q1 2021.


thanks for the update

The Hot Start method doesn’t work at all for me.

The Hot Start method doesn’t work for me either.