Wyze Finally Works With Google Assistant!

After the voice command, the screen will go black. Counting from here is ~20secs, then some reverse progress bar appears along with a loading spinner, then it’s about another 30-40secs.

1 Like

Do you have any delay opening your live stream in the Wyze app? About 10 seconds is the minimum expected delay for Google Assistant.

So, before today, I’d never succesfully gotten the stream working on Chromecast. I had the same issue @louie1487 reports. I just tried it again and it DID finally show me the camera stream, but only after waiting more than 2 minutes. (It may just be that I never waited long enough before.) The stream only worked for about 90 seconds before it went back to the buffering screen like before (except with a frozen video instead of the black screen)

1 Like

Same issue with nest hub as the others. Ask for my wyze camera, screen turns black, does some negative time/bar countdown, and takes 2 minutes or so to display. It will also once it finally comes up, repeatedly show the “Playing Smart Home Camera” status bar on the screen like it is trying to load. This of course doesn’t allow you to see much because the screen goes dark.

I will say it works 100% fine with Alexa. I have a Show and Nest Hub in the kitchen, and Alexa displays my camera in 7 or so seconds. Both of my nest hubs have this issue.

1 Like

true never works with google assistant /chromecast

Alright, could folks running into this please message me your Wyze account email, the MAC address of the Wyze Cam, the last date, time, and time zone that you tried to use the integration, and what happened when you tried? I want to get this info over to the team so we can see if we can figure out what’s going on from our end.

I would love to send you my info, unfortunately I can’t find how to message you on the mobile site of this forum.

Your forum account was pretty new. I just increased the permission level. Are you able to see the option when poking on my name/face now?

Yes. Thank you. I looked everywhere. Message on the way.

1 Like

@nerdland @WyzeGwendolyn … Decided to share my recent experience with Google Assistant integration. First, my equipment:

multiple v2 Wyze cameras
original Google Home smart speaker
2nd generation Chromecast dongle
iPad Pro with Google Assistant app

v2 camera named Bedroom Window
Chromecast named Sony Bravia
Chromecast located in room Mancave

All 6 of my v2 cams, the smart speaker, and the dongle are all linked to Assistant. When I issue the command “Show Bedroom Window on Sony Bravia”, either by speaking directly to the smart speaker or to the Google Assistant app, the first thing I notice is that my TV screen goes blank and the words “Smart Home Camera” appear momentarily in white, then a red/white progress bar shows up at the bottom. Within 20-30 seconds the live stream from the Bedroom Window camera appears. All seems fine (red progress bar gone and time counter is moving on the Wyze camera stream), but then the red/white progress bar appears again after about 30 seconds and the stream freezes. I then must say “Stop” to end things or wait 15 minutes until “Smart Home Camera” once again appears on my TV screen (because of the time limit I suppose). Seems repeatable as I’ve tried this with multiple cams this morning. For what it’s worth, when I first set this up a couple weeks ago everything worked fine for all cameras. It’s only recently that this behavior started.

I just tried it again now, at about 11:44am, (EST) and it took about 60 seconds to connect. It connected just after 11:45am. Better than the two minutes it took last time, but not great. After connecting, it remained connected for a little over 2 minutes before it disconnected at 11:47:19, at which point it just continued to try to refresh unsuccessfully.

It might be relevant that a motion event started at 11:46:54. I received a CMC video that lasted from 11:46:54 to 11:47:13. Given that timing, it seemed to disconnect right around the same time it was uploading the video. But I’ll run another test to see if this is reproducible.

Tried again at 11:55am. Initial connection took 46 seconds, so the video started just after 11:56am. (Slight improvement over the last test) I let it run as long as it could, and there were no motion events. This time, it disconnected at 11:57:15. So just over a minute of video time.

I immediately tried to load it again at 11:58am, and the video appeared almost immediately, (So quickly that I heard the echo of myself telling Google to show the camera, in fact) but only lasted for 15 seconds before disconnecting.

Tried it again at 11:59, and it loaded within about 15-20 seconds or so. Not bad. Disconnected after about a minute.

Tried again at 12:01, and it loaded almost immediately. (Again so quickly that I heard my own echo) This time, it stayed connected for about a minute and 50 seconds or so, disconnecting at 12:03:00

I could keep doing it, but the results are pretty inconsistent, so I’m not sure if I’m generating useful information really. Haha.

I didn’t test to see whether motion event disconnect is reproducible, but in general, it stays connected for such a short period of time that I don’t think it would give me useful information anyway. If it were staying connected for 10 minutes on average and it disconnected immediately after a motion event every time, it might mean something. But when it’s only staying connected for a minute and it disconnects, it’s kind of meaningless

No delay in the app. It runs through the 3 steps fairly quickly

Likewise for me. And tends to stay connected

Sent the DM last night. Also offered to send a video of what is happening, but I would need an email address of a wyze rep to send it.

Works with Wyze app.

Works with Alexa on Show 1st gen, 2nd gen, Show 5, and echo Spot.

Doesn’t work with Google on my Nest Hub or Nest Hub Max.

1 Like

Thanks for the additional testing. Except for a slight variance here or there, we’re pretty much seeing the same thing - after the initial connection, which can take 30+ seconds, the live stream is displayed successfully, but for less than a minute, then it freezes (with the red progress bar at the bottom continually trying to reconnect). As I mentioned above, this started misbehaving within the past week or so. p.s. all 6 of my v2 cams work just fine within the iPadOS app, etc. and I rarely ever have a disconnect while viewing the stream this way


Same here! My Hub says currently unavailable… It showed once months ago… after that never again!!!

It doesn’t work!!!

Done this a few days ago. I even offered to send a video of what is happening but I need an email to send it to.