Wyze Cam V3 keeps disconnecting (with error code 90)

If you search in support topics it will give you step by step instructions along with link to download software need for your camera

I had thst happen to me i tryed to add 1 camera useing my android and no go got out my old iPhone and it worked first time out

That’s great. I’ve tried my iPad and iPhone no luck. I get cannot connect to network. Which is odd because I connected a light bulb right afterwards. And I’ve connected several other devices from wyze right afterwards and no issues. It’s just been the wyze cameras that seem to have this issue.

1 Like

What did you use to search because I’ve searched about everything I can think of with no luck finding this. Can you post a link or what you searched or the title of it?

I installed two new floodlight cams (with the Wyze Cam v3) and they both went to Error Code 90 within a day of installation. I have two existing V3 cams in the same location, same WiFi setup, and these have been working fine for nearly a year…

Will see how frequently they die, but apparently the only way to get them back up is to power cycle them. Which is not something I can do remotely… Sounds like I should open a support ticket to deal with this… In the meantime I will monitor this thread to see if anyone has a confirmed fix.

I had four wye v3 cameras on a Ubiquiti wifi system and was having a terrible time with dropped connection. I use rtsp to connect to blue iris. Dropped connections happened even if the Wyze app showed cloud-connected, but sometimes the wyze app would also lose the connection, too. There just isn’t a bandwidth problem - the cameras call for about 20GB per day or less, easily within the scope of the Ubiquiti Nanos, especially because most other things are ethernet-connected. Sometimes the Ubiquiti app would show quality of service problems (showing the connection at 60-70%, though I’m not sure what the percentage actually measures), but other times Ubiquiti would show a 98-100% connection and still have a lost connection.

After months of dropped connections, I tried downgrading the cameras to 720p from the native 1080p connection. At first, I didn’t see any change – I think I had to reboot the cameras to enforce the setting change. But I’ve had almost no disconnections since then – two weeks with stability, which is far and away longer than any time in the past.

If you are having trouble, I recommend at least trying to reduce the quality. 720p cut the bandwidth use in half, from an average of 17-20GB/day to 7-9. The quality setting is visible in the wyze app when you click on a camera – you don’t need to go to settings to change the quality.

I still have one camera that occasionally disconnects but it is the furthest from an access point, and is exposed to many access points of my neighbors, and it reconnects in a few minutes, as opposed to before the downgrade, when it would go off for days. I tried downgrading that one to 360p, which while it cuts the bandwidth still further, didn’t make a difference in the stability of the connection.

Update on my error code 90 issue. I had the two new floodlight cams for over 2 weeks now, and both have dropped connection about 6 times so far. Meanwhile, the two v3 cams I had since last year did not have any issues. The two new floodlight cams are on the same WiFi as my v3 cams, one of the new floodlight cams is 8 feet away from the WiFi access point, full signal strength. And all cams are on the latest and the same firmware version.

I contacted Wyze support and they are processing a warranty replacement for me. They also suggested I delete and re-add them on the app - that did not cure the problem. I wonder if the replacement cameras will be any better? When I get them, I will post an update.


Yay - I have an update. But not quite a fix yet.

To reap, I have two Wyze Cam v3 and two Floodlight cams installed, all running the latest firmware. The floodlight cams are frequently losing connection (error code 90) and the only way to bring them back online is to power cycle them. On the other hand, the standalone cams work perfectly - they pretty much never experience this issue. I had the standalone cams for over a year, and the floodlight cams for 2 months. I received a replacement for the floodlight cams, installed one of the replacement cams, and the replacement also has the same issue.

What I noticed while doing some troubleshooting is that the floodlight cams appear to lose the connection when my WiFi router (and/or access point) is restarted. I restart both the router and the access point on a daily schedule, so if the floodlight cams are prone to lose connection as a result of the WiFi restart, that would explain why mine don’t stay up long. On Friday I performed a test when I restarted both my router and access point and one of the two floodlight cams lost connection after that test was completed. This suggests that the floodlight cams are not robust to WiFi restarts. I have now temporarily disabled the scheduled WiFi restarts, and so far (one night only) the floodlight cams remain connected.

So the question is: why are the floodlight cams not reconnecting following a WiFi restart? Once they lose connection - they don’t reconnect at all: I was away from my house for 6 weeks, and the floodlight cams remained disconnected the entire time. The standalone cams handle WiFi restarts just fine (the standalone cams are also a year older, in case that matters).

Unfortunately, I have to restart my WiFi on schedule - so that when I have an internet outage when I am away, the router will be able to reconnect to the Internet… I need to have a reliable system that would work when I am away from the house for long periods of time.

Spunds like a compount failure

it is Wyze server issue.

when your device boot up, they send a signal to server saying ready to join.
but server either time out too fast or saying your device is already connected. denying your entry. ir server is simply overloaded, wyze sold too many devices.

submit your Log (S). and post it in Fix it Friday.

Hi, thanks for the info. Could you please provide me your logID if you submitted any. Or the mac address for that camera that keeps get error code. As for your home WiFi, may I know if your SSID is shared with both 2.4GHz and 5GHz?
Thank you!

A recent log ID is 575610. This was submitted while the connection was down.

I am using the same SSID for a 5 GHz network as well as 2.4 GHz. But why would that matter? If the cameras don’t have a 5 GHz radio, it should not matter what are the SSIDs of 5 GHz networks.

I paused my nightly restarts for 5 days and the floodlight cams stayed connected the entire time. Yesterday, I resumed the scheduled nightly restarts for my network. One of the two floodlight cams lost the connection overnight. And the two standalone v3 cams have remained connected (as they have been connected for several months with the scheduled restarts taking place).

It looks like I should be able to reliably reproduce the floodlight cam losing the connection by restarting my router. I would be curious to hear if you can reproduce this at Wyze? If I can help with additional diagnostics on the repro, let me know.

Thanks for the reply. I will try to reproduce the same scene to test here. Just out of curiosity, While it shows -90 error on camera page, are you able to go to the settings page on top right corner to check device info or other things. And if you are able to click on the “Restart Camera” and see what will happen.

You never want them the same,thats your issue you need to have 2 different SSID set up

I am able to go to the device settings of a cam that has the error code -90. When I click “Restart Camera” I immediately get a message “Failed” (just “Failed” - no additional message).

And to rule out the possibility that same SSID for the 5 GHz network could be contributing to the issue, I changed the 5 GHz SSID name, and I am still able to reproduce the dropped connection for the floodlight cams when rebooting the router.

One more thing I noticed: the MAC addresses for the floodlight cams start with D0-3F, whereas the MAC addresses for the older standalone v3 cams start with 7C-78. These standalone cams are functioning correctly across router reboots, so maybe the different MAC address indicates that their networking module is different?

1 Like

I beg to differ with this assessment. First, having same SSID for different access points is a legitimate configuration, so in general you cannot say that you “never want them the same”. I don’t want to discuss pros/cons of this setup, this is not the place for such a discussion. Second - this is not triggering my issue. I just changed the SSID name for the 5 GHz network, and I can still reproduce the issue.


We have been doing this for years,all older wifi equipment does not understand what is correct thank’s Julie service manager.

Indeed, older WiFi equipment may have trouble with same SSID on different bands. What if I have newer WiFi equipment on my network and I want that to roam automatically between bands? And where do Wyze cams on this older/newer spectrum? The device we are talking about here was just released in 2021. And Wyze cams do not even have a 5 GHz radio, so regardless of being older/newer - how could they be impacted by running same SSID?

You are quoting a rule of catering to the lowest common denominator, but it does not apply in this situation. Claiming that “this is your issue” is just not correct.

1 Like

What happened to “BACKWARD COMPATIBILITY”? I am sure this had to be considered, or it was ignored. I see this issue as a no-brainer.
Please acknowledge the omission and FIX THE PROBLEM.