Wyze cam V3. IR lights not turning off

Setting Night vision mode to ON forces night vision to always be on and the image will be in black and white. Setting it to AUTO will allow the camera to switch to color in the daytime. Setting night vision to OFF will keep the camera in color mode day and night, but if there isn’t enough light during the night the image will be black and too dark to see any detail

1 Like

In your test, you stated you set the IR NV to ON. In this scenario, you are manually forcing the cam to activate the IR filter (making the video black and white) and activate the IR emitters depending on the settings (2 red dots on the cam face = near, 4 dots = far… Can only be seen in very dark conditions). In this scenario, there should have been NO color vision at all.

The ONLY time the cam will automatically switch based on ambient light is in AUTO mode.

What this tells me is that the app settings are not being translated to the cam immediately. The circumstances you describe happened to me in the past but we’re rectified by an app update.

What I found was that the green moon icon in the top right of the live view screen is much more responsive to changing the cam settings than the settings in the menus.

  1. Test the cam at night in a dark room.
  2. Set the cam up with the lights on and toggle the green moon (IR NV) to OFF.
  3. Turn lights off and watch the video, should be a black pic with the lights off.
  4. Keep lights off an tap the green moon 1 time to switch to Auto. Listen for the cam to click the filter in place and watch the front of the cam to see if red dots appear.
  5. Turn the lights on and watch and listen for the cam to switch to daylight mode.
  6. Tap the green moon again to turn the IR NV to ON. Should be black and white with lights on and off.

When the IR NV is on, go into the settings and make sure the settings are where you want:

IR Near : low IR NV illumination
IR Far: high IR NV illumination

Dusk: Auto Switch in low light
Dark: Auto Switch in total darkness

Then, go back to the live view and toggle the IR NV moon again to make sure the settings stuck.

If it still doesn’t come out of IR NV in Auto when the lights are on, the cam needs replaced under warranty.

Thanks for the suggestion.

I tried cycling from NV OFF to Auto (menu or moon button) and it worked fine on the camera activating color NV.


What I am seeing now is this scenario:

NV mode: Auto
IR Night Conditions: Dusk or Dark

Camera Target: points toward garage ground location (e.g. concrete ground).

Change: Ambient light level rises from very low-light condition to daytime indoor light level (e.g. light coming thru’ from frosted glass paneling of garage door)

Problem: Camera stays in IR night mode (B/W) and does not switch back to color NV

Manual Fix:
If I switch NV mode to OFF and back to Auto mode manually thru’ the settings menu or the green moon button, the camera immediately switches to Color mode.

Thanks.

Exactly the same situation I have with my WCPv1 which is indoors and my V3 in my garage.

Daytime light levels are not enough to kick the NV mode back off so it stays in b\w all day until I turn the lights on when I get home.

I just did a test on both cams. The WCPv1 was in Auto-NV on, manually toggled thru to off, went to color, toggled back to Auto, reverted to NV

V3 - same process but it stayed in daylight NV off mode when back to Auto as you indicated.

What this tells me is that the Firmware settings for Light Level NV ON are not the same as Light Level NV OFF.

Thanks. This confirms the problem here.

A fix should be done in the firmware I believe -

as in NV Auto mode,

color NV kicks in properly from daylight color, when ambient light is lowering,

Color NV doesn’t kick in properly only when ambient light is increasing from night IR.

It should not be a difficult fix.

I’m returning the camera until the fix comes in, as the color NV feature is what I look for in this camera.

Those two things are the same. There is the traditional night vision (black and white) where you can use the IR illuminators to light your scene if they are enabled or there is when night vision is off, and the view is in color. There is no “color night vision” and “regular color vision”.

The starlight sensor is the sensor within the camera and helps in all low light level situations, either the traditional night vision (b/w) and color are in use.

Same as above. There is no difference between color night vision and daylight color. The modes are:

Night Vision ON (black and white view where the IRs can be used to illuminate your scene)
Night Vision OFF (color view)
Night Vision AUTO (camera switches between night vision on and off on its own depending on your dusk or dawn settings)

Can you provide screenshots of your different lighting scenarios and note when you think the night vision mode should be on or off? I just want to clean up some terminology that’s being used to better help troubleshoot.

Here are the 2 photos:

Location: Garage
Lighting: indoor, lighting from garage frosted panels and through one window blind. Sunny day outside.
Time: Around 3:18pm (daytime indoor).

Night Vision Mode: Auto
IR Night Conditions: Dusk or Dark (doesn’t seem to matter which selected)

App Version : 2.32.0(154)
Firmware version : 4.36.9.139
Plugin Version : 2.32.0.15

  1. Color Vision working:

  2. Actions:
    Move camera to totally dark area to trigger IR (to simulate midnight condition where there’s very little light from around),

Move camera back to original spot in garage.

(NO change in any settings)

  1. Result: IR vision stays. Does not switch back to color vision.

Thanks.

2 Likes

Here are my shots which illustrate the issue:

I have my Garage cam set to Night Vision Auto, Dusk, Far.

At night, the NV activates. However, in the morning when the light levels return, it does not shut off the IR mode. If the IR mode is manually shut off, and then Auto is turned back on, it will stay in daylight IR off color mode until the light levels lower to the threshold to turn them back on.

Today at 2:17pm, my IR mode was still on.

Using the live screen toggle button, I toggled it to on, then to off (color returned) then to Auto. Color stayed for the remainder of the day.

Tonight, at 8:32 pm, my full color vision was still on in much lower light conditions than at 2:17 pm when it wouldn’t shut off NV.

Then, seconds before 8:33 pm, the night vision activated.

So, as you can see, the threshold to switch the cam out of NV is not the same as that which puts it into NV.

Edit: I just scrubbed uSD video from yesterday. It never came out of NV the entire day in similar light conditions.

It is dark here now (9:30pm). Garage cam is in NV mode. I just flipped the garage lights on and it did shut off NV and switch to full color mode. When the lights went off, it went back to NV mode.

What this tells me is that the light sensor is working, but it takes the presence of exponentially more light to turn off the NV mode as it does to turn it on.

Yes looks like there’s an obvious bug… .

It’s frustrating as the CV stops working overnight. Should be able to switch back to CV for daytime indoor condition.

Fixing Camera NV setting manually each day is impractical.

Cycling thru’ the NV setting re-activates CV. That tells me this is a bug in some logic and it is totally fixable (in App and/or firmware).

Being only a shade tree tech user, I would agree that this is a firmware issue. The coding has to get a light level reading from the cam sensor in order to trigger the mode switch. Theoretically, the on and off should be at the same light level or slightly overlapping so that it doesn’t sit there and constantly toggle in variable light conditions.

But, this is an extreme variance. You shouldn’t have to toggle it to get color.

Push a log on your cam and post it here so that it is available if the devs need it.

My log: 648660

2 Likes

I just ran thru’ 2 tests in NV Auto mode, and submitted my diagnostic logs.

Logs:
658158 (IR Night conditions: dusk)
658189 (IR Night conditions: dark)

Both logs show same problem:
Camera does not change from IR mode back to color vision when lighting improves.

Manually switch NV mode to ‘Off’ then to ‘Auto’ will get back color vision.

2 Likes

I just checked the cam that was giving me these issues. This morning, it automatically switched itself out of IR NV into Color @ 7:08 am which it wasn’t doing previously.

The only change made to this cam was that I introduced a nightly power cycle on the smart plug with an Alexa routine.

Will continue to monitor.

1 Like

Thanks for the info. Any chance you could submit another log right after you perform the test (where you let camera go b/w mode first and move back to daylight) and noticed that it doesn’t switch back to color mode? Previous log only has 7/24 log.

1 Like

False alarm. Still not fixed.

V3 stayed in IRNV all day today. Thru some very bright conditions far brighter than current conditions (18:35 ET).

Toggled from Auto to On, then to Off, Color returned. Then back to Auto. Color remained and is still on 15+ min later.

13:30 ET - IRNV AUTO FAR DUSK (bright)


18:35 ET - STILL IN IRNV AUTO FAR DUSK (not so bright)

18:35 ET - IRNV AUTO FAR DUSK (immediately after toggling On\Off\Auto)

18:55 ET - IRNV AUTO FAR DUSK (still in color mode… 15 minutes later)

Log 660552

1 Like

Hi,

I submitted new log 662116. Hope this helps.

NV: Auto mode
Location: Garage interior.

Steps:

  1. interior daylight: Color vision
  2. Change to very dark (IR kicks in),
  3. Return back to interior daylight (IR stays ON, color vision does not kick in).
2 Likes

@Kev455 , I have posted the issue with the IR NV Auto switching to this month’s Fix-it Friday thread.

If you are still experiencing this issue, feel free to follow the link, like the post with a heart coin, and add your experience in a reply post (if you are so inclined).

Hi,

Thx for mentioning the problem in the other thread. I tried it this morning and things haven’t changed. The problem is still the same.

I tried to upload a new log file, but I kept getting “upload failure”, so I wasn’t able to provide the latest log.

I restarted the Android App and it didn’t help.

If I ever get to submit a new log later I’ll do it.

If someone made a ‘fix’ recently.

It probably wasn’t a fix, but a quick workaround to keep IR night vision threshold lower, so it won’t kick off IR unless in very low lighting condition.

If IR is ever triggered, the problem will still show up.

Thanks.

Nothing new to report. My V3 is still doing it.

Same thing happened to my few new V3s and pan V2s recently set up. I had to cycle through Auto On Off Auto to turn off the IR lights even the ambient is bright.

1 Like

I have since upgraded my cam V3 exhibiting this behavior to the Beta Firmware for testing. It is better, but not optimal.

There are some days that it will automatically come out of IR with enough light. There are others when it won’t.

It appears that Wyze has made the decision to set the light threshold required to exit IRNV extremely high; and extremely low to enter. The delta is far too wide.

1 Like