Wyze Cam Pan Firmware

Hi there, Blizzard.

Here are some troubleshooting steps:

  1. While it may seem like a dumb step, ensure your Wyze Camera is is Wyze Cam Pan not a Wyze Cam.
  2. Make sure you have the latest version of the Wyze app, beaware some updates are only available to Beta Testers.
  3. Force restart the Wyze app.
  4. If none of this helps, please contact Wyze Support @ hello@wyzecam.com.

Good luck,


Need more info.
What is your current firmware version ?
Are you currently Enrolled in the beta program ?

Your link does not work

Hi HDRock,

I posted the Wyze Support email address, not a link. Haha. Sorry if you got confused.

Thanks , got it

I’m not in the beta program. My camera is a Wyze Cam Pan, which I’ve had for three days.

The first time I accessed my camera through the app (ver 2.3.16) on my Moto G3 (Android 5.1.1), I got a new firmware available message, but the upgrade button in the app didn’t do anything.

I followed the procedure here and updated it to version which I downloaded from here. This eliminated the new firmware message until the following day when was announced and I started getting the firmware available messages again.

The firmware download page lists, but unlike the previous versions it doesn’t provide a download link. I tried using the same download URL as the previous versions, replacing the filename with demo_4.10.3.60.zip but that just returned a 404 error.

If I tap the upgrade message that comes up in the app after I tap my camera, my screen blanks for a second, then it returns to the app home screen. If I tap account on the home screen, then go to firmware upgrade, then tap the upgrade button next to my camera, it sits there saying upgrading for several minutes then says upgrade failed.

Force close the app, and then re-open it and go to that camera’s firmware upgrade page to see if the upgrade was actually successful. Sometimes the app will timeout waiting for the upgrade to complete, even though the upgrade is still finishing up on the camera.

I force stopped the app and retried the upgrade, force stopped again and checked the version, still at For good measure, I powered off my phone and restarted it then repeated the process. Same results. I’ve also powered the camera on and off multiple times with no change.

If I tap upgrade in the firmware available popup, the camera is available again immediately when the app goes back to the app screen. If I try to upgrade from the account menu, the camera remains inaccessible for several minutes while it’s saying upgrading, which suggests that something is happening differently from the other method. I assume that once I initiate the upgrade, the camera is talking directly with Wyze and the phone is out of the picture, but that’s just a guess.

And none of this explains why there’s no download link on the firmware page.

This upgrade to .60 is a bit wonky, I have 2 pancams (purchased At Amazon) at .50 that won’t upgrade to.60. I have done everything factory reset, reverted to .40 flashed .50 all successfully but .60 fails…
I need the upgrade as without the working detection zone the cam loves to track my cieling fan :face_with_symbols_over_mouth:.
Seems a bunch of us need some help.

Our upgrade to .60 went ok and we now get notification recordings BUT we are not getting push notifications on the phone, either audible or visual. The only way to see the alerts is to go to the app, then notifications , open it and see if there are any alerts. In my case, yes, there were alerts from motion but I didn’t see them until I actually went to the app to look.

Now, where do you go on the website to see a copy of the alert notification ? I logged in and I see “downloads” and there is nothing stored there. When an alert is recorded, it is suppose to be store on the wyze site for 14 days… That is the whole purpose of this cam thing for us…intrusion notification.

Am I doing something wrong ? Any advice would be appreciated.
Perdido Beach

You can see all of your event clips for 2 weeks Through the app , There Is no access to event clips on the Website

I had to revert to flashing .40 from a clean formatted sd card. Then I upgraded .60 and it worked. I checked and downgraded to .50 and tried to upgrade to .60. Did not work. So I flashed .40 from a clean formatted sc card then upgraded to .60 and it worked. Tried to install it without formatting the sd card and coping the .40 file and then upgrading it to .60. It did not work. Try on a clean formatted sd card with .40 copied to it then try the upgrade to .60. If that works let me know.


Thanks, that worked but in a strange way. After flashing .40 I allowed app to update the cam but it said update failed. Well I looked at cam info and it showed .60 installed, checking for an update said it was up to date. Strange stuff going on…

I think once they get the small things figured out it will get better. Glad it works for you.

Hi @Blizzard, we usually update the link few days after releasing the full release. Please expect it to come out next week.

For your upgrade failure, it sounds to be a consistent issue. Is your camera at a place that network is not stable? Likely we couldn’t download the upgrade package from the web. Can you consistently view live stream of the camera? When upgrade failed, did you see your camera reboot itself?

Can you try following?

  • Try to download and fail one more time with upgrade
  • After you fail the upgrade, go to Account → Help & Troubleshoot → Report an Issue and submit a log to us
  • You should receive a ticket # from our Support system. Please let us know your support ticket # here. We will take a look at the log (the log may or may not be helpful since we don’t always connect to the camera during upgrade)
  • After you are done above, you can give another try to go to Account → Bulk Firmware Upgrade and manually upgrade your Pan camera. The upgrade process is a little different from the camera setting page. You may have better luck there.


Our app is not 100% correct for upgrade status. There is a period of time the app is not connected to the camera (a reboot in between). The app has to keep polling the camera status. We have a timeout in our app (~5 minutes I think) for this polling method. Once we hit timeout, we call upgrade failed. However if the upgrade takes a little longer to succeed, you will see ‘upgrade failed’ in the app but the camera actually got upgraded fine. That is likely your case. Hope it explains.

1 Like

With current version (.60) should configured detection zone ignore any movement outside the outlined box? I have a cieling fan that is not in the box but I find the pancams tracking it with the lens looking up at the cieling in some sorta mumble mode.

My live video stream is steady, but just in case, I moved my camera to the same room as my wifi access point and tried the upgrade again. No change, upgrade still fails. I do see the camera reboot when Account->Firmware Upgrade fails. I see no change in the indicator light when I tap upgrade on the firmware available popup.

My ticket number is 227062.

We didn’t change anything for detection zone in 3.60 version. The logic is that only motion inside detection zone can trigger an event or tracking. Once tracking is triggered, we will track the full screen. We are aiming at this case - you set detection zone towards your door. Once someone comes in from your monitored area, your Pan starts to track. Tracking can go easily off the monitored area but we think you want to follow the person everywhere until motion stops.

Ok, thanks for the update, one question, should motion tagging be active outside the selected box?