Wyze Cam Pan Update

I received another WyzeCamPan camera today and got a failed message when trying to update the firmware via the app. After that fail was unable to reconnect to the camera to try again and was forced to resort to “Plan B”— downloading the firmware to a micro SD card, which was successful.


jmarkcobb, thanks for letting me know! Sorry we weren’t able to get your Wyze Cam Pan working properly.

@TeddyCavachon, thanks for telling me! Sorry for the trouble but we’re happy to hear that you got it working. :slight_smile:

I just bought a Pan. It did one update to
It is prompting for this update to…but it keeps failing.
What do?
I have power cycled the cam.
Has no sd card in it yet, as i just got it and am tyring to setup.

Edit: After a few tries…it worked.

Check the device info to See if it did In fact update to 60

agreed with HDRock, lots of people are getting failed messages but if you look again it really did upgrade.
BUT, if you are still having problems you can flash to the .60 firmware or you can ask support or Gwen to push it out to you which is my preferred option if a cam is being sassy.

Here is a link to the firmware upgrades:

1 Like

Sassy cam :grinning::+1:

1 Like

Actually, a couple of Pan testers said the cameras were sassy. That’s why I initially named mine, “KungFu PanCam”.


No it did not update. I verified that.
After a few power cycles, it finaly succeeded.

1 Like

I forgot about that! They are quite sassy. :slight_smile:

@SpeedingCheetah, glad it finally worked! Sorry for the trouble with this.

1 Like

Did someone say SASSY?

1 Like

lol, It was me :grin:

1 Like

Haha that was me, I started the “sassy” talk :rofl::innocent:


How do you people have this update working? I have tried a few times and consistently lose access to the camera.

Brand new (received on Monday 15th), I proceeded with the upgrade during the setup procedure (which means connectivity was working) and then no way to get beyond setup after the upgrade making the cam pan unusable.

I had to learn how to do manual firmware downgrade which worked fine but it seems does not help in any way.

I am currently on and it works fine.

As I can consistently reproduce the problem after upgrade to, I am curious to see if I am the only hitting the issue.
I have a ticket with support and sent the logs.

You’re not crazy nor are you alone. After months of problems with my jerky campan and door sensors showing open when closed and closed when open, Wyze sent me a new canpan. After following instructions to the letter, I got the “Update Failed” message when trying to update to This is exactly what happened to my first canpan. After 4 attempts, I was finally able to update the firmware. How is this even possible that Wyze can release products knowing full well how buggy they are. I remind you, this was a replacement. Why didn’t anyone say at Wyze say to themselves,

“Geeez we need to send this guy a canpan that works. I’m going to grab one off the shelf that I know already has the latest firmware and I’m going to test it before we send it off.”

My conclusion is that they keep releasing untested products and we in turn end up with buggy cams, sensors and bridges. Looking back, I wish I had read any of the threads in these forums before making my purchase,

@CheckSixPilot, most people do not want a product that has already been opened. In the future, please feel welcome to request one from the team. Are you still having trouble with your contact sensors?


Hi Gwendolyn,

After the many many hours I’ve invested including sending support a 20 min+ video of all the problems - yes, I’m still having problems with my sensors giving false information. They show open on the app but door is closed. Or closed on the app when door is open. Or if the door sensor is behaving correctly and showing the correct status, then notifications stop. I have tried 2 bridges, two cam pans and a multitude of sensors. The part that pisses me off the most is getting the reply of. “Have you tried this or that?”. Especially after I’ve submitted a video of everything I’ve tried and how the sensors don’t work consistently. So let me put it to you this way… think of every single thing you could recommend and add about 10 more. That’s how many things I’ve tried. I’m an IT guy so I know how to troubleshoot. Now I have two cam pans, two bridges, about 6 door sensors and none of the sensors work consistently. The other thing that bugs me is that I’m not alone. Go look at how many others are complaining about the same issue. Why is it so difficult for Wyze to step up to the plate and just admit that these sensors and bridge, app or firmware were released with bugs? If that were the case, I wouldn’t have spent ours troubleshooting. Send me a private message with your email and I’ll send you the link to the video so you can see for yourself.

Lastly, I could care less if the new bridge, cam pans or any product was open. That would have been very nice to get an email saying, “we apologize for 3 week delay in responding to your support ticket. We’re sending you an open product because we wanted to triple check and make sure it’s working as advertised before sending you a replacment.”. I would have been delighted to get an email like that. It would have shown that someone at Wyze really cared about taking care of a customer who has already been through the ringer, Wouldn’t you agree?

In regards to this thread, have you, you yourself pulled a Wyze cam pan off the shelf recently and performed an Update to the firmware? If so, you’ll find that we’re not crazy. Your updates fail and have to try 3 to 4 times before success. As I’ve said before on other posts, before asking someone to do something, try it yourself. It’s called eating your own dog food. Get back to us.

I generally try to complete the action that someone is reporting isn’t working (I eat my dog food!). For issues that are intermittent or don’t affect everyone, it can be difficult to reproduce a problem. Though I suppose I don’t have to explain that to you given that you’re in IT. I didn’t have trouble with the upgrade but I still believe that you have been.

In support of our team, there is a process that we need to follow in order to make sure that we don’t miss any steps and if people send a replacement without confirming that the steps have been followed it can lead to a recurring problem where not only do we not receive information that could clue us into a bigger issue, we could be sending products to people where it would be a faster resolution for them if we just went through troubleshooting. Sending replacement products also doesn’t rule out environmental issues.

Would you like to give me your support ticket number? I can view your video through there. I can also make a note about you wanting an open box product to ensure functionality.


Honestly, I don’t recommend firmware beyond v4.10.3.40 for the Cam Pan at all. It supports WyzeSense perfectly. Next, you just have to ask yourself how important is person detection in the scheme of things?

It also seems like once you go to .60, .65, or beyond there’s no reverting due to some structural level change. The app revert feature was actually removed so that folks don’t brick their cameras. Unfortunately, recent firmware levels are roughly the equivalent to bricking imo. Agreed they need to slow down and stop breaking bread & butter features. All of this person detection and $lickie new features can be at a more moderate pace that doesn’t come at the expense of core functionality.

Can you share the level of signal strength you observe on the problematic sensors?

I’ve deployed (2) bridges at my parents’ place to be in proximity to (2) sets of sensors in different areas of the house. Oddly, (2) of the sensors I have in their kitchen are within 8’ of their bridge. However, they always show 1 (sometimes 2) bars’ worth of signal strength. I attribute this to them not being quite line-of-sight even though they’re in the same room with no walls/doors intervening. I surmise that this has something to do with the right-angle radio geometry between these sensors and the bridge and/or the sideways mounting angles I’ve used since they’re actually on windows.

Long & the short is these sensors are ridiculously close to their bridge, yet they go offline weekly or every few days. Normally, my folks resolve the issue by opening/closing the window in question - causing it to phone home. Every so often, however, these sensors do what you’ve described; they show the opposite state of the physical reality.

Bottom line things I’d verify are 1) proximity to sensor bridge, and 2) sensor placement angle.

1 Like


I’d be curious to know from which firmware level you upgraded to .60?

Something they did tying the local storage to precisely mirror cloud storage after v4.10.3.40 pretty much broke recording & playback for me.

Documented several series of findings back in this thread and several support tickets.

Haven’t heard anything beyond platitudes in response.


Firmwares beyond v4.10.3.40 have been nothing but grief to me. Past that version, they synchronized local to cloud recording, which meant a huge reduction in what got recorded locally when using motion-based recording… and as im sure you’re aware, cloud recording (like the Internet) can be fluky.

Documented my findings here… no meaningful response as yet.

1 Like