Wyze Cam Outdoor Firmware Beta Test 3/16/2022


What’s New:

  • Fixed an issue that caused delays when loading live stream video

Update applied to 3 WCO cams… 2 with Cam Plus applied and 1 with Cam Plus Lite.

Wow! Much better!!! thankssign

Will keep a close eye on these looking for issues…

1 Like

Updated mine while out. Getting ready to test.


Just did my testing of the Camera Update and it is loading faster. Seems to function as expected with the minimal testing I performed. Kudo’s.

1 Like

Firmware installed fine but still have issue stated here

on 2.29

Rolling back to 2.28.2 again

@ mike1nyny
Still have issue on latest WCO firmware today as well?

Have you tried clearing cache and restarting the device as well? That seems to clear things up. More curious as I will be testing mine soon.

Yeah… I tried that but no change. I have Cam Plus on everything and 3 WCO on one base and 4 WCO on the other.

Curious if other user still has issue as well. That odd behavior where stream thumbnails for the wrong cameras show up as well. Same as in that other thread.

What device are you using? I am sure you indicated in the past, but easier to ask here. :slight_smile:

I have iOS and Android and will test in both. My Android Device has no issues. I did install the latest App and then installed the updated FW.

I will test iOS next, after I get back home.

One of 2 updated for now, the other is ladder worthy, I’ll give number 1 some time to bake first.
Much faster, very nice!

A couple IOS devices. I’ll try on one of my Android devices this evening.

Looks pretty good to me. Also resolved a bug I had with recording length while subscribing to cam plus.

Only bug I currently see is related to cooldown timer for Wyze Cam Outdoor. I can set the timer to 1,3,5 min, but since I subscribe to cam plus I should have a 0 min option. Not currently available for me. Log ID 505271 submitted if it helps.

Wyze App Ver: 2.82.2 (a24)

WCO Firmware Version:
WCO Plugin Version

Wyze Base Station Firmware:
Wyze Base Station Plugin Version:

If I understand correctly, the notice under 'Back up to Base Station" where it says “This feature is not compatible with Cam Plus.” is an accurate statement, but why is the next line telling me to “Get Cam Plus for premium features” ?

I have Cam Plus on all my camera’s, so why am I being prompted to sign up for it?


I am in the beta program from Wyze and have the Wyze app from test machine. How do.i get this latest beta firmware for.Wyze Cam.Outdoor. Live stream is stuck on all my cams and want to see if this firmware fixes it. Thanks!

I didn’t get a chance to test with Android but one thing is clear with IOS on mine is that on latest IOS app beta is that my WCOs will not work in a camera group. Delete group and WCO cameras work fine just being in root listing. Newly recreated groups do not fix either.

1 Like

5 WCOs split between two (2) base stations. All Plus licensed and deployed outside.
Update was successful and quick.
Went through basic settings without incident on each WTO. Can confirm noticable improvement on the length of time between requesting feed and displaying feed.

I haven’t tested configuration changes, camera specific or app related items like grouping,. Nor my (sadly unsupported) third party integrations,. But plan to late tonight as well as some RTSP tinkering.


I’m having the same problems. I downloaded the beta update on my ios but then the base station lost Wi-Fi. Checked the connections & all are good; did all the suggested steps but no go. App indicates a Wi-Fi signal so I’m still waiting for Wyze to fix this bug.

Is there any way I can go back to earlier version? TIA

Same here. Opened a case with support 3 days ago. I have two sites, all at same firmware. Site 2 is fine. One WCO with one base. It’s all fine.

Site 1, 3 WCO, 1 base. Two of the three cams hang at 3/3. The other now works after shutting off overnight. One of the two that won’t connect also had a power drain and went from full/100% (brought in for recharge) to 0 in about 48 hours.

Is rolling these back to an earlier firmware an option? Is so, where do I get it and how do I roll it back?

Make sure they are on the current firmware, they hay have addressed this issue. If not, try ungrouping them.

Nope. They are all on the latest firmware (see above) and I just created a new group for them. No diff. Apparently this is a known, non-totally-resolved bug?

If it matters, they do continue to record events. I just can’t view a live view in the app.

The previous problem was having them in a group, so try not having them in a group.