Wyze Bulbs taking time to turn on and off

I am noticing that when I turn on my lights via Alexa or the app, it takes about 7 to 10 seconds to actually turn on or even off. Sometimes one will go on and then the other a little bit afterwards.

Is anyone else experiencing this? Is this an issue with the Wyze Servrer?

A test of one of mine thru the app & Alexa showed it is working normally ATM. About a second delay, maybe. Nothing approaching 7-10. I’ve seen slight delays between 2 ganged bulbs before. So long as it is slight, I’m thinking it is normal.


My color bulbs are fine. The white or original bulbs are delayed. I will check again. Maybe it was the time.

My test was on a original white Bulb.

1 Like

I have noticed a slight delay using color bulbs (not using alexa) but when I noticed these delays it was correlated with high bandwidth demand times in my city so I shrugged it off to that. I run a program on my computer for days at a time which gives me measurements on bandwidth speed throughout the day and only on low times have I noted delays ( maybe estimated 2-12 seconds)

1 Like

@Bam @Newshound

Seems a little better now. Not sure what was causing the delay. Thanks for checking.

Will monitor it.


I’ve seen a similar issue but it is intermittent. Assume it is probably an issue with my internet connection which can be fickle. I only have color bulbs.

1 Like

Yup. Big delays sometimes. I have an array of lights in one room and it can take up to 5 minutes for them to come on. Sometimes in different orders. Now, I am controlling through Alexa so it may be on that end.

I noticed a big issue with this yesterday with my Alexa person detection announcements…they were delayed several minutes for at least part of the day.

1 Like

Been monitoring all day. It seems to be more consistent over the last couple of days where one of the lights in a group takes longer to go on. I am also noticing that the bulb does talk longer than normal to come on. But it is sporadic.

If I turn the power off and let them reconnect, they will work faster for a bit. In addition, the primary issue seems to be only with my older white bulbs. Not sure why.

Will do more experimenting. Not a huge issue, but something to keep an eye on.

1 Like

I have been noticing this delay with lights lately also and my three lights on my pole lamp don’t turn on at the same time like they used to , that has different kinds of wyze bulbs in it

1 Like

I have seen some delays lately on my white bulbs. Also I don’t really like the new interface for the bulbs. I have my bulbs in 3 groups of 2 and with the new interface, it’s hard to control individual bulbs. Just seems to be more complicated. Maybe it’s just me.

It may have nothing to do with Wyze. I have Wyze bulbs and other lights controlled by a Hubitat hub and Z-wave switches. I have a single Alexa command that turns off all lights when I go to bed and have long noticed that it takes 5-10 seconds at times for all of the lights to go off. They also seem to turn off in a different order each night. I would put the blame on the Alexa app since it depends on Wi-Fi and a server somewhere in the cloud.

I’ve had the problem using the Wyze app…not Alexa. Seems to be random but would agree it is probably a cloud issue.

Yea, my issue is with both, Wyze and Alexa. Like you, I believe it is a cloud issue. Which is why I was wondering if thee was a server issue.

I did find that unplugging the lamp or removing the power to the bulb for a few seconds and then restoring it, seems to allow the to work faster. But not 100% of the time.

I also understand that Wyze is working on a FW update to the bulbs which will alleviate some of these issues.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.