Wyze and Mesh Router (Google) not working well

I have installed a Nest WiFi Mesh router system. I did this because of issues with Wyze products losing connection. I installed a Point from the Mesh system in the room with the most trouble. I constantly lose the connection with two plugs in that room that are only a few feet from the Point. When it does connect, it properly connects to the point which is closest. Just below the point in is a Wyze Cam that also constantly loses the connection. Same issues here. I have tested at different times and different products and the Mesh system is performing properly. I have concluded the issue is with the Wyze products. I have all the latest updates for the Wyze products. I have converted my entire home to Wyze and am disappointed in this issue. We travel quite a bit and this is not something that is acceptable. If someone has a suggestion on how to maintain the connection I would very much appreciate it.

I’m not familiar with the Nest mesh system, but is there some way you could configure it to select only the 2.4 G signal for the Wyze devices, since that is the only one they will work on.
My Eero system does this automatically, but as I said I don’t know the nest system and it may require separate configuration.


thank you. I’ll check to see

@nyrnd99 I’m thinking of buying a Nest Wifi with the same exact reason. My current setup leaves a dead spot in my house where my Wyze Base is sitting so I need to upgrade my network. Were you able to resolve your connectivity issue?

So I just wasted the last 3.5hrs of my life with this exact issue.

We have a Google Wi-Fi router/mesh network – initially, we were able to run the setup for the Wyze Cam Pan, but then when we’d attempt to access the feed, it would just continue to connect/reconnect with zero result. We tried everything – disconnecting/reconnecting the camera, adding/deleting it, then finally decided to call Wyze.

I spent 3.5hrs on the phone with two different representatives (both very nice, but both had to spend quite a bit of time asking others for help with this particular issue, so neither seemed too knowledgeable). Basically, the connectivity in relation to the Google Wi-Fi/Mesh router is this – the router itself broadcasts simultaneously in 5G/2.4ghz. The Cam Pan needs to access the 2.4ghz signal so that it can connect to the least ‘traffick-y’ channel (1 or 11, etc). On a traditional router, you could do this, however on a mesh router – in particular, the Google Wi-Fi ones – the channel the device is assigned to isn’t able to be manually designated. Both Wyze reps thought that this would somehow be magically solved by my ISP – which wasn’t the case (after another painfully long hold and the usual rigamarole).

Since I can’t seem to get the camera connected to the right signal, every firmware update fails. So now I’m out $30 and about 5hrs of my time only to find out that I can’t use this with a Google Wi-Fi router.

1 Like

The Wyze products only connect on the 2.4GHz WiFi, channel 11, probably the most ‘traffick-y’ frequency in the Internet of Things. If you can give a different SSIDs to the 5Ghz and 2.4Ghz it should work.
To be honest don’t know all that much about the Google WiFi Mesh Router to understand why it would ignore +/or not respond to a BOOTP request from a device on channel 11.

You indicated the CAM PAN device device connected but then you can’t access it? Your phone has to be on the same IP sub-net as the Wyze cam. The phone can be on the 5Ghz network with a different SSID as long as the subnet is the same as the Cam. Running my V2 that way.

You might also try the Google Nest Wifi Help Community

I continue to work through this problem. I find that when i lose the connection i can open the Google Home app and go to devices. This seems to reconnect the products that have lost the connection.
I also noticed that over time for some reason the issue still exists but much less. For instance it was that when i got up in the morning lights were still on because it lost connection over night and one of my cameras wasn’t connected. Now i find this happens a couple of times per day but not over and over.
I also find this only happens with the Point. The router for the mesh unit has never had this issue.
Don’t know if any of this helps, but that is where i am currently.

1 Like

I have an Eero mesh system with 3 V2 cams attached and they will not update the firmware … all looks good until the very last step then they fail. Thankfully they continue to work using the old firmware. I would like to upgrade to CAM Plus, presume that would be a wasted effort if I cannot get the latest firmware updates. Comments / thoughts are welcomed

I have the same system and I’ve had no problems. Just updated 22 without issue. That’s of no help to you, I know! But-it’s a great system.

You don’t say if you are upgrading one cam at a time or via the each cam option. I would suggest doing it one at a time via each cams Settings/Device Info/Firmware Version path. There have been problems occasionally with batch update.

If that doesn’t work, you can try Manually Flashing the Firmware.

Another thing you can try is temporarily pausing your 5.0g broadcast since Wyze is 2.4 only.
Eero does hide this ability a bit. Go to The Eero app, Home Screen/Settings/Troubleshooting/My Device Won’t Connect. At the bottom of that screen you will see an option to temporarily stop broadcasting your 5.0 wifi. This will make the Eero broadcast 2.4 only for, I think, about 10 minutes.

Also you can check what channels are most heavily congested around you from neighboring Wifi’s. There are numerous apps available in both Google Play and IOS app Stores. If Eero offers a way to lock into one channel I don’t know it, but I found their tech support to be both knowledgeable and fast. I wouldn’t hesitate to contact them.
Hope all this helps! Feel free to post back with comments or questions!


1 Like

I never do a batch update. But I will use your suggested path for the single update. If that does not work I will use your suggestion on temporally stopping the Eero 5 broadcast. That is a great solution to a very troubling Eero problem. I have had lots of issues with the August products not connecting to the Eero because of 5 overpowers the 2.4 most times. Wonder why Eero doesn’t offer that solution on their support page??? Thanks @tomp for the help

It has now been several months an all is working well. I noticed that over time the individual devices worked fine one by one. Now every Wyze device works fine with my Nest Mesh System. I didn’t really do anything special, just watched it daily.

1 Like

So after several attempts over the last few months we finally got the camera up and running (after several firmware updates). We have the original Google Wi-Fi (non/pre-Nest system), so each point is set up as a router, and I think that may have been part of the issue. Suffice to say, it’s been relatively smooth sailing so far (with the exception of one camera always resetting itself to a strange angle).

I’ve spent 2 weeks with this issue and wyze team. IMHO Wyze is behind and unfortunately to stay cheap they will stay that way for a while. Even when I switch my mesh off and go with just 2.4 they still dont connect however 24 other devices do. I’m switching 7 cameras after 3 years to ones that will connect properly.