Widget issues on V3 Wyze 2.34

So. tried out the Widgets on my Samsung Galaxy S10e.
I have 2 x V2 Wireless Outdoors and 3x V3 Wired Outdoor.

The V2s work without issue. But all 3 of the V3s when opened sit at “Connecting camera by secure channel 1/3” and never connect.
Go back to the actual app and launch, no issues what so ever.

You would think this would have been tested before it was released. I am also not the only one, I posted this on Reddit and others have the same issues.

Just tested on IOS, no issues. Could be an android issue. Can you test this @carverofchoice

1 Like

Very possible. I am waiting to hear back on reddit for those that also have the issue, to see if they are Android and if so what make, model and OS they are running.
Not sure how this was even released if this is affecting all android users. Seems like a simple catch in testing.


I am using the latest production app on Android 13 (Google Pixel 5) with the latest V3 Beta firmware.

So, the first time I tried with a V3 starting with D0:3F:27xxxxxxx it functioned as described by OP…it would not connect. I then opened the cam in the normal app, and the live stream worked fine. I then viewed and saved an event.

I then tried a widget with another V3 with a MAC starting with 7C:78:B2xxxxxxxx and it loaded right up, functioning fine.

So I clicked back on the original Widget with a MAC starting with D0:3F:27xxxxxxx that failed the previous time, and this time it loaded.

I don’t know what the difference is or why it failed the first time then loaded fine the second time, but I confirm both that I experienced an issue AND also that I got it to work. It may be that when I streamed it from the app and then tried it again a second time that this stimulus made the widget able to work as if the connection was hot instead of a cold start. I don’t really know…but either way it should be looked into and fixed. Sounds like a GREAT thing to report for #fix-it-friday on September 2nd!


I just tried the same.
If you stream from the actual app, and leave it OPEN in the background, you can use the widget and it will load the V3. The moment you actual exit the regular app, it will no longer load from the widget just as before. This is the case with all 3 of my V3s. Defiantly and over looked issue.

@carverofchoice Was your Wyze app open in the background when it worked? If you close it and try again wonder if you will get the same results.

1 Like

I just tried again right now with no apps open in the background at all and they both loaded right up again.

I wonder if you have to load the app up AFTER or during the time you create the widget and after that it is fine? This will take some more experimenting.

I wonder if it will stop working again if I powercycle my phone, and try the widget before I’ve loaded up the Wyze App since the powercycle. I am thinking there is some kind of link that the widget needs to make the right connection, we just don’t know what that limitation is but we’re making some progress on figuring it out.


The moment my App is closed they won’t load for me. I also just tried adding the widget while the app was open, Loaded right up again. Didn’t even have to load it first in the App. The moment the app is closed, and I try and use the widget, does not load.

Yet the V2’s work without issue all the time…

I would like to hear your report back after your power cycle @carverofchoice
I am betting it won’t work :slight_smile:

1 Like

Alright, so I rebooted my phone to get a fresh start, and I went straight to the widgets and now neither cam would load up from using either widget.

I closed the widget app, loaded the Wyze app, swiped down to refresh, closed the app and tried the widgets again, and still a no-go.

Loaded the app, streamed a DIFFERENT camera, then closed the app and tried the widgets, still a no-go.

Loaded the app, left it in the background, then tried widget 2 = it streamed.

Opened and then Closed the app, tried widget 1, it wouldn’t stream. Closed it and tried Widget 2 again, and widget 2 wouldn’t work

Opened app, went to account tab and app settings, enabled “Running in the Background” toggle. Closed the app. Opened Widget 1 = success. Closed the App. Opened Widget 2 = success again.

I toggled “Running in the background” back off then closed the app again. I immediately tried Widget 1 which Loaded again. Tried Widget 2, and it loaded again.

So apparently the answer has to do with whether there is some part of the app still loaded in the memory, even if the app is not open. Having the app open ensures it is in the memory and thus it will always work. Having it set to running in the background also ensures it will always work. If you’ve recently used the app or maybe even if there are notifications active or something, then something like that may make it so it can possibly work. But it seems that the widget will not load if something related to the app is not somehow in the memory/RAM.

I hope that helps.

@WyzeDesmond @WyzeBaohua do you guys know what is going here? Can you clarify more on this? Is there any way to get the Device Widget to always load the live stream without having the app in the recent memory of the phone? Or does is the device widget to load a camera right into live stream intentionally programmed in such a way that we are required to leave the app open or use the setting “Running in the background”? Can this be fixed?

LOG 696226

Thanks for reporting this @mhinc , and @IEatBeans for the callout (I know you mostly called me because you knew I was still awake) I enjoyed the testing to learn something new here. Back to work for me for now! :slight_smile:


Toggling ““Running in the background”” did the job for me as well. Mystery solved! Thanks @carverofchoice
Unfortunately, I won’t be leaving the toggle on, so I would like to see this resolved without the need of the toggle being on in the future! Thanks again
PS I work midnight’s so I am up at this time all the time as well :slight_smile:


@carverofchoice @mhinc @IEatBeans Thank you all for reporting this. I will take a look.


FYI to those following this thread. I sent a screen-recording video of this to WyzeDesmond in a DM so he could see an example of what I was explaining above. Hopefully it helps.


Thank you @WyzeDesmond !

1 Like

Hi, we do find the issue on Android app and will fix this in the next release. It will be fixed on 2.35 offical . Thanks!


Great work! I love how reliable you are to check into things like this that get reported to you, and then follow-up with us. You are sincerely very appreciated for your part in this. Thanks to the rest of the team that helped.


Awesome! Thanks for the update! Looking forward to the 2.35 Official Release


@carverofchoice @mhinc @IEatBeans Thank you all for your help and reporting on this. 2.35 should be released shortly and please let me know if it works on your end. From the internal testing result with my Android 12 so far. I am not seeing that issue anymore.


I have 2.35.0.b80 (beta) and still have the issue on that version.

I deleted all widgets and set them back up from scratch, then rebooted my phone to have a clear/fresh RAM/Memory. Then after giving the phone a few minutes to finish booting and loading thumbnails and whatever else it does, I tried the widget, and it still stayed locked on connecting 1/3 without any progression. I left it for over a minute. I duplicated this test multiple times. It continues to fail as long as the memory is fresh. I can get the widget to load if I freshly create the widget and try loading it, but if I reboot my phone for a fresh and clear RAM then it won’t load.

In case it helps:
Log 716294
App Version: 2.35.0.b80 (beta)
Android 13
Google Pixel 5


The internal version I am using just got released to me two days ago. So I would say should be on next beta release


Makes sense. That’s why I wanted to give you the exact version I had. I will test again with the next beta release. :slight_smile:


Thank you @WyzeDesmond. Looking forward to the release!