Why was Android hardware decoding removed?

They are currently working on a solution, it is a top priority and they want to be sure it’s going to work when released.


Yes, thanks. I’ve been following the topic, but just thought it might help with a solution by indicating the types of devices that have the issue without hardware acceleration enabled.

I’ve been told that we’re getting close to beta testing a different library and that it’s looking promising that it will help. We apologize for the wait and we’re working to get improvements to you as soon as we can.


Gwen, thanks for the update. This helps keep supporters engaged.


You’re welcome! This is a super important issue and we don’t want to leave you in the dark. :slight_smile:


That reminds me…
I would love to be left in the dark.
Just sayin’…


I see that there is a firmware update out for the Wyze Cam. Does anyone know if it’s safe to install if you are running the older version of the cell phone app that supports hardware acceleration? Or, should I stick with the old version of the firmware as well?

I’ve had no problems with the new firmware running the 2.4.82 version of the app.

1 Like

Thank you for the update.


@angus.black, we have a dark mode in the plan! :slight_smile:

@jemiller, I think that you’ll be fine if you upgrade the firmware.

@Acalade, you’re welcome for the update.


I understand that the problem is that the new libraries should have automatically enabled hardware acceleration if required.

I don’t suppose there is a way to go into the Developer Options on my old Note 4 to permanently enable hardware acceleration so that I can use the current version of the app is there?

What about compiling an updated app with the old libraries for the people affected so I can use my new Wyze plugs with the app too? I don’t care if I have to download and install the app outside Google Play.

1 Like

Woohoo! :smile:


I don’t think that’s the case. I’m under the impression that the new Android OS required 64-bit libraries, and the one that Wyze chose, didn’t support hardware video decoding at all.

They are, I believe, now testing another library that does.

These things happen. The only thing I find that should have happened is that, someone should have found this during testing, and put out a notice that older Android devices are adversely affected. Gives people a chance not to update.

1 Like

Still not a viable option for those (like me) who need the new version of the app in order to use their otherwise useless (as mine are) new Wyze plugs.


The new version is in beta from what I understand, have a little patience. Like I stated, these things happen, and to every company in the software business.

I seriously hope that someone in Wyze has tested this scenario. Until the latest app is fixed this is a way too common use case. So please “I think” is not very reassuring statement :wink:

These things happen, but invariably as a result of improper/inadequate testing. Having spent 35+/- years developing software I can unequivocally say it does not happen to every company. It’s a rarity for a company to release software that effectively renders useless the bulk of their products.

Yes, happens to every software company. You don’t hear some of it because they have good test procedures. Didn’t you read about Boeing’s tests on 737-Max?

Think about this. Had Wyze not released the problem version, would you have an issue?

Yes? No? If no, then just revert to that version.

You may have tried these already, but just some ideas to maybe help until its fixed.

If you have another device (like a backup or older phone that didnt get traded in), you can install the new app in one and the version with hardware decoding in the other

Some users have installed the new app to set up their plugs, then rolled back to the older version…then used alexa or google home to operate their plugs


I guess I can do that will my old S4. I was hoping for a sooner fix.