Vacuum - Can the charging station be moved? And Virtual Walls

In the app, go to account, about, beta program and you can join. Also go to Google play store listing for the app and join there. After a few hours you’ll be able to update to the beta app.

Although, my beta app seems to be exactly the same as the non beta that i had with the exception of a button to submit a log.

Quick map only shows up in the beta app once you reset the map. It’s a clickable option on the blank map screen


If you are on IOS you’ll need to also install TestFlight from the App Store in addition to the steps mentioned above to get beta versions of the app.

There was a delay between updating the app and getting the firmware update. Once the firmware updated this morning, I now have the new Quick Map and map edit features.

These features are great! The mapping is sp much better and faster. Created the entire map in 10 minutes. Yesterday before the update it took an hour, then messed up at the very end.

It would be nice to have the ability to edit the walls.


I’m having issues with it detecting all the rooms in the house. It doesn’t really want to go down the hallway and hit the other bedrooms and such. I’ve reset the map and tried with same outcome. Basically only cleaning part of the house. No virtual walls are setup.

That would be an amazing addition as well as being able to “green light” a virtual wall temporarily… I’ve spent some time getting my virtual walls/areas just right so it would be nice to be able to temporarily let the vacuum pass through it instead of having to delete it and re-add it each time :slight_smile:


Same here re: not detecting all the rooms. It doesn’t want to map a particular hallway where the laundry room exists. Not sure what it is about the hallway that stops it from fully mapping that room.

It looks like you used quick map, when the laundry room didn’t map all the way? Try cleaning just that room and it will probably improve on the map and finish it.

Other things to consider… are there reflective surfaces that it’s not picking up? The lidar laser will just reflect off mirror surfaces, confusing the map. Is there something obstructing the vacuum, such as a rug it gets stuck on?

I’m not using quick maps, I’m currently on firmware 1.6.97 and app v2.16.55 and I don’t think it has Quick Maps yet.

No rugs in the room. I did wonder if the shiny surface of the washer and dryer interfered w the lidar but I tried covering the vertical surface of the appliances with bath towels… still no luck.

For now it’s not a show stopper. I’m still impressed I’m able to get most of my house vacuumed. Scheduled at night! With records of it dong so!

It’s has always been exterior walls anchor points. I can’t square off the bottom right area as a room.

1 Like

Update your firmware and software…

Do you have any “black” areas or lines in the hallway. The “Cliff Sensors” treat these as drop-offs, like a step. Only solution is to cover the sensors and use the virtual wall feature to block off drop downs.
This is covered under another discussion topic in the Community forums.

That seems to be my problem. For whatever reason it thinks there is a cliff, and so remains in a small spot. I will research the other thread on cliff sensors. Thanks!

First map, vacuum just wanders from room to room doesn’t really do anything but mapping. Then I labeled each room and split the one big room. I then spot cleaned each room, in the dining room they got stuck under the dining room table, I moved one chair to let it out, next time I cleaned the dining room it stayed clear of under the dining room table. Also find each time it cleans the room the map improves, I do not see it bumping into stuff like I do on some peoples videos. Very smart little machine.
For new people, map before you do your first cleaning.

I’ve moved my charging station 3X’s no problems - recommend a hard surface, and putting a weight on top of the station (small rock, pc of metal) I’m using a large metal tape measure - helps ensure charging line-up / connection.