V3 camera - allow continuous recording more than 9 days

@scott14719 are you sure that it stops recording entirely?
Mine keeps recording, but it seems to only use around 90GB for its video ring buffer, resulting in a much shorter coverage period than the card can support. For instance, on my Pan Cam v2 with a 256 GB exFAT-formatted card, my recordings only go back to May 17 2022 at 8PM. The current time is around 9Pm on May 25.

…and STILL we wait. No response from Wyze since the original report in March, other than @WyzeJasonJ’s claim that this trivially diagnosable bug is “being looked into”.

I stopped recommending Wyze a month ago. I’ll soon start actively discouraging friends and others from purchasing Wyze products…

One of my cameras stopped recording using a 256GB Samsung card. I replaced the card with a 32GB and it is working fine. 2 other cams with 128GB and 256GB cards do like you say and record to around 87 to 90 GB before looping back…but they do record within those parameters. I have 2 more cams with 32GB cards that seem to work fine. Clearly, anything above 64GB isn’t working correctly and the people at Wyze don’t seem very motivated to fix it.

1 Like

We tryed the biger sd cards but issues come with them went back to the 32GB and no issues

It is so strange that the quirks arent the same even on a different brand card that is the same size. I 1st tried a 512gb Nuflash. It would not go past 32 gb and it would stop recording period. No erasing and recording over old footage.
I took it out and put a Samsung Evo 512gb in. It is recording up to 43gb and erasing back to 38gb automatically and keeps doing that over and over, but at least it doesnt stop recording.

exFAT formatted 256GB cards are now working in my v2 cams. I’m going to assume it’s related to beta firmware I can view continuous SD recording back to April 18.

1 Like

Well that is good news Seapup, how about V3 cams where the latest Beta FW is 2.32.0 (7) released yesterday?

My V3’s with ExFat 256 Gig cards are still holding at 85 Gig (ish) and overwriting. I can only see back 9 days, So it appears absolutely nothing has changed from my point of view.

I hate to say it, but if Wyze fixed this for V2’s then what’s the hold up for V3’s :slight_smile:


1 Like

I haven’t tested v3 with 256-512G exFAT cards other than to confirm an issue exists for cards larger than 128GB. v3 with 256GB FAT32 card works but we shouldn’t have to use that old formatting standard.

I haven’t heard anything from Wyze other than what WyzeJasonJ has posted in this topic. I have endless cams, but only so many 256-512GB cards to play with. If I remove a large card to test the latest beta firmware for v3 cams, by the time the card fills up to >128GB, a new firmware version will have released. :confused: It would be a lot easier if Wyze would confirm problems/fixes in beta release notes to save time & headache.

Would you like me to kill my ongoing v2 test with 256GB exFAT card, reformat and start a v3 test using the latest beta firmware? It will take about 3-4 weeks to confirm writing past 128GB.

1 Like

Nope,I wouldn’t want you to change your testing regimen. I am after all also testing but on V3’s, so I will continue doing so until a new FW appears.

I agree with with all you have pointed out, especially with Wyze confirming fixes/problems in Beta release notes. I won’t be holding my breath though :slight_smile:

Additionally, testing in HD shouldn’t take more than 10 days or so as this will take the recording on the 256 Gig card above 100 Gig :smiling_imp:


1 Like

And another week goes by without a response…

I am also affected by this issue which is a major problem for my use case.

As a software engineer, the only rationale explanation for the time it is taking to solve this issue is that Wyze is not looking into it, which is unfortunate. It should not be that hard to fix.

Wyze, please, just put someone on this for a few days

My rather cynical take on this is not that Wyze has overlooked the issue, but instead, they have intentionally de-prioritized the issue because they perceive large SD cards as cannibalizing their CamPlus subscription revenue.


Exactly! The same reason why they won’t let “shared” users view SD card playback from the app.

I’ve been wanting to upgrade the SD cards on all my cameras 9 and buy additional cameras for my other properties but have been waiting for a fix for this first before I spend the extra time, effort, and money. I use 32 gig cards right now and 3 days of HD recordings is just not enough. And if their reasoning for deprioritizing this fix is CamPlus, well Cam Plus is actually a detriment for me. I’m on a limited data plan with my internet provider so uploading constant streams of HD videos uses too much data, I’m guessing that others in remote locations have the same issue. Please get this corrected. I’d like at least 2 weeks of HD video playback for better security at my properties.

1 Like

Stating that the reason for this problem not being fixed is because of it cutting into camplus is merely speculation, nothing more. Just because Wyze have not refuted this does not make it true. We all wish they would acknowledge the problem and where they are on fixing it, wishfull thinking and all that :slight_smile:

tacomaguy20 the best you we can get at the moment is about 11-12 days of HD using 128Gig cards in V3 cams, but more in V2’s using beta firmware.


@Slammer99uk good to know but upgrading 9 cameras to 128gig cards when it still wouldn’t get me to 14 days (as well as possible fix being released for 256gig cards at anytime), has me hesitant to move forward. Knowing my luck I’d upgrade all my SD cards and then the fix would come out right after and I’d have spent all that money only to have to upgrade again. It would be nice if there was a time frame so I could decide if it would be worth spending the money now. And I’m not going to spend the money or effort to switch back to the worse quality V.2 Cameras. I guess I’ll just keep waiting.

Agreed, you are in the same position as many others with having to wait for a resolution


So here we are. ANOTHER week has gone by with neither a resolution nor even an acknowledgement of the problem.

I have acknowledged the issue and brought it up to the team. They have not found the cause yet.

1 Like

Strange they cant find the problem when they solved it on the V2 cams using new beta SW.

Still we wait…