Setting up Wyze cam on community wifi

Hi all,
I am currently in an apartment complex that uses Spectrum Community Wifi. I managed to request for a unique SSID, and am able to connect my google smart home devices with no problem, but I just can’t seem to connect my Wyze cam to any network.

I have whitelisted the MAC address for my camera, and have also ensured that my phone was connected to the 2.4ghz band during set up.

Does anyone have any idea what the problem might be and what possible solutions there are?


Hey JPH,

First off, welcome to the Wyze Forums and I hope you accept a late response, after all this is a community forum.

Here are some possible issues:

  • The network your trying to connect your Wyze Cam to is not on the 2.4GHZ band.
  • Your Wyze Cam may be having issues, you should try to connect it to your phone’s hotspot, if that works, then there is something wrong with the network your trying to connect it to, otherwise, your unit may be defective. You should contact Wyze Support at

Let us know how it goes,


1 Like

Hopefully you aren’t depending on whitelisting MAC addresses for your security. The problem with that is these cameras have an issue where they aren’t necessarily the address you see on the bottom of the camera. There is a bug that may make them revert to the network card’s MAC address on occasion. There is also an issue of quality control – I have one cam that isn’t reverting to the network card’s address, it simply is on a different Wyze address than they put on the bottom of the camera.

I turned my MAC filtering off years ago. Too much of a pain for the return.

As you know, you will need a 2.4 GHz network. That network must have with WPA or WPA2 encryption and a password. The network cannot have a landing page. Hopefully no ports are being filtered by your router. There are some possible issues with ASUS routers, but most everything above can be corrected if you encounter it.

Even though they tell you to put your phone on the same network as the camera during setup, it really doesn’t matter as long as you enter the correct info in the setup forms that come up. That’s the only reason they do that. Too many people blindly hit enter on the forms. So if you are on a different network you need to correct the form to show the SSID of the 2.4 GHz network during setup.

Best thing you can do up front is turn off MAC filtering, and make sure you have a WPA or WPA2 password.

1 Like

Thanks for the response!
I managed to connect it to my phone’s hotspot. Any suggestions on further troubleshooting?

Unfortunately with Spectrum community wifi, I have zero access and control over the router/network settings.
The network has WPA2 encryption with a password and no landing page. The 2.4ghz and the 5ghz network share the same SSID, so I am wondering if that might be the problem. I have no control over the SSID, so if this is the problem, then I guess it’s just not gonna work for me.

I’ve seen people here with routers that try to steer connections to the 5 GHz band when the names are the same. The way they get around it is to shut down the 5 GHz band long enough to set up the cam. Do you have that much control?

Thanks again for the response! And nope…no control at all. What I have tried so far (in an extremely crude…low tech manner) is to set up the camera at a location within my apartment where the phone connects to the 2.4ghz instead of the 5ghz.

Did you ever get your cams working? I’m in the same boat

Same here… I just reached out to wyze customer support so hopefully they have some sort of solution.

Anyone find a workaround for this? My community just got Spectrum and I don’t see a 2.4 or 5 Ghz network, just one for my apartment and I can’t get my camera to connect.

+1 to this issue as well

Hi Everyone,
Just some input for what I experienced with my girlfriends apartment. They also use spectrum community wifi and the only way the allow access is by entering the mac address. So I’ve been tryign to figure this out by using wifi repeaters also and its interesting. Using a tplink wireless extender when I connect my phone or PC via the extender it still ask me to login on a Spectrum homepage before getting access to the internet. After that it is good. So I’m assuming the cameras cannot get past this login page (obviously it cant type a un & pw) and therefore can never get to the internet to connect.
I’ve tried this with both Wyze and other brand Geeni cams and same problem.

For some back ground info: I used a RE305 connected on 5ghz and repeating only 2.4ghz.