SD Card showing 0GB Memory Available when New

I put a brand new 32GB mirco SD card into my camera. It is showing that I have 0.0GB available when that is not the case. The format of the card is FAT32 and I can copy files to the card on my computer so the card is not an issue. If I remove the card, the camera recognizes that it is out so it is picking it up. Thoughts? Thanks.

The beta version of the app currently has an option to format the SD card for you. If you’re interested in joining the Beta, you can check this out:

@Butakis, did you find a solution for your issue?

I have the same issue with my 32GB (Class 10) micro SD card. My camera is running the latest firmware version. I tried format option on the app but without success. After formatting the SD card, it shows no SD card installed. I tried restart the camera but problem persists. I also tried to format my SD card on my windows and Mac to FAT32 and exFAT but still having issue. Most of the time, SD card would show up as “Less than 100 MB” size or no card installed. I’ve verified my SD card is working correctly both on PC and Mac. I also used the SD card on my GoPro 6 without problem. I also tried format using Rufus USB creation tool but problem persist. I have emailed support 3 days ago but haven’t heard back. I think I might return the camera to Amazon if I can’t get the SD card to work.

Not sure if you are using Android or iOS but if Android, try to force stop and restart the app after you installed the card.

I gave up and just bought a Sandisk mico SD since that brand worked in my other camera. The original 32GB works in everything else minus my camera so it must be a spec or something on the card. I even formatted all the FAT32 types to no avail. The Sandisk one worked immediately. They should just say - Sandisk Brand…

I have the same sd card and my camera still does not recognize the 32gb sd card.