Robot vacuum not returning to charge

Since the last update, my vacuum won’t return to charge. She used to complete her job, say “returning to charge” and head home. Now she gets almost done and just turns off. Plenty of battery left. I have to return it to home and wait for it to turn itself back on. I’ve “chatted” with Wyze support and they gave me a few things to try. Nothing worked so they said to submit a log. After submitting a log, I was told there’s nothing else they can do and wait to hear something.
Anyone else have this problem and able to fix it?

In the cleaning history for the vacuum, how much time does it have?

Have you tried setting the suction level to quiet? That will help reduce the load on the battery and may keep it from cutting-out early.

Some people have recorded their experience replacing the battery, I kept a list of links…

The whole run is less than 40 minutes. There’s plenty of battery left. I really think it has something to do with the last update. And when chatting with them, they said they are aware of the issue. But thanks for the parts link maybe I’ll try something.