Problems Displaying Continuous Camera Feed on Google Nest/Home Hub

Anyone else having problems where the camera feed cuts out after 10 min or so? I can’t get a continuous feed on my Google Nest/Home Hub without it going black after this period of time and displaying the text “Smart Home Camera” on the Hub display. I’m using both V2 and Pan cams. Same issue on both.

The camera’s live stream will be displayed on your device for 10 minutes before it automatically stops. To continue streaming, repeat the voice command.


Thanks Rick!

Any chance this could just be updated to live stream to the google home hub indefinitely? My wife and I would like to use our wyze cam as a baby monitor and we need the audio/video feed to be going all night. Is this something that would be possible?


The stream on the Google Home Hub is limited on Googles side, Wyze cannot do anything about it.

Welcome to the community, @wiseguy87. This #wishlist topic may interest you.

Just noticed that my Nest Hub is not responding to my Wyze Cam v2 livestream. A few weeks ago it worked, but now it says it is not connected. I wonder what has changed??

The livestream works ok on the app on my phone and tablet.

1 Like

I have had issues at one time or another with all services that I have connected to Google Home/Nest/Assistant. What has usually fixed any of them them in the past has been disabling and re-enabling the service/integration in the Google Home app.

Yep, I unlinked it and re=linked and it shows, but now it’s a black screen on the livestream.


Does it eventually timeout and go to the default screen for the Google device? Did you try it just once, or several times?

After like 2 minutes or so, the livestream shows up…
Thanks for your help!

Great to hear! If you keep having issues with it, you could submit a Support Request. Depending on the nature of the problem, rather than use the website link, sometimes it is helpful to submit an App Log and/or a Firmware Log. Good luck! :slight_smile:

I have 4 Wyze V2s and none them can be displayed on nest hub. All I see is a black screen on the livestream. I linked and unlinked several times but no luck. Any help will be appreciated


Welcome to the community, @brsubedi69. Have you seen this article on the Wyze support site? Please keep in mind that sometimes you might have to wait a while for the stream to feed through Google devices. I have had to wait over a minute sometimes. :slight_smile:

Me too, it’s the same, always a blank screem, It’s stay more than two minutes and nothin any help? Thanks


Hi @gugusouza, and welcome to the community. I have updated the support link for my post above. Let us know if it doesn’t help with your situation.

What works for me is changing the resolution in the app. This triggers something to get the stream back. Annoying but it works.

Interesting. Which resolution works best for you? I haven’t really tried anything beyond SD for mine. I might have to experiment tonight.

I go from 360 to SD, or SD to 360. HD doesn’t work for me.

Me too. I’m using the Pan Cam and a small Nest Hub over a Google WiFi LAN. The stream runs for 5 to 10 minutes then drops out. Is this a camera, networking or smart display problem?