Constant buffering with camera (Google Nest (Home) and Echo (Alexa))

I just got the black camera (black friday special at Home Depot). The issue I’m having is that it is CONSTANTLY buffering on my Google Home Hub. It’ll take up to a minute to finally connect, then it will have good connectivity for a just a couple minutes (far less than the 10 minute shut-off time), and then be buffering the feed forever after that. Has anyone else had this issue?


Hello @nephi_05 and welcome to the community.

There are actually many experiencing this issue, it is currently unknown if the problem is on the WYZE end or the Google end. WYZE however is looking into the issue and would like some info from people who have this problem. I am posting a link to a post from @WyzeGwendolyn who asks for some info to be sent to them. If you could do that it may help in figuring the issue out.


I will note that the 10 minute streaming limit is by design to balance cost and use case. But if it takes more than 10-20 seconds to load your stream, please send me that info!

I just got the Wyze v2 and also the Pan Cam along with the Exho Show 2. When trying to watch the live video on the Show I’m getting a buffering ALL the time!! I thought it was due to a weak WiFi signal in the front room, so I bought a WiFi extender… and that still didn’t help! :rage:

I noticed from reading on Wyze forum that I’m not the only one with the issue. So is Wyze working in a solution? Or should I return the product and try a different brand?

Thank you for your help.



@WyzeGwendolyn, I can’t seem to send you a message with my email address.

But the other info you asked for from users that had this issue:

Last try → 12/2/2019, 6:30 p.m., CST

My Home Hub said it was showing the camera view, but all I saw was a black screen with a buffer bar that kept recycling for well over a minute. This time, it never brought up the room it was looking at. Other times I’ve done it, it would bring up the camera view for a couple minutes, and then start buffering for the rest of the streaming time.


1 Like

Same issue here. Multiple v2 cams and multiple google hubs (regular and Max) all have the same issue. Wifi signal is very strong and no issues streaming Wyze cameras or anything else on the Hubs themselves.

Feed will buffer and jump around for ~1 minute, you’ll get a second or two of the Wyze cam feed, and then it will go back to buffering for a few second, show a quick snap of the camera feed and go right back to buffering.


When viewing on my TV via fire stick, I also get video for 1 or 2 seconds then it buffers. Repeat. Everything else is okay.

Jumping in on this thread to report buffering problem with two Pam Cams on Echo Show 8. Constant buffering with seldom more than five seconds of video from cam. Home network is pretty fast and showing no problems otherwise. Thanks for looking into this!

Hi Gwendolyn

I have same buffering issue. It takes a long time to load the stream and constantly keeps buffering.

Buffering occurs whether I use Google Assistant or Amazon Echo.

I’m in FL Easter Time zone.

I have the exact same problem as described. I have an echo show 5 and the stream constantly buffers. I have an old iPad (still with dock connector) where the app runs flawlessly,

Sorry to hear about this! Could people experiencing this buffering issue please send me a message with the date, time, and time zone from when you tried to use the integration, which integration you were trying to use at the time, your camera’s MAC address, and the Wyze account email? I would like to get this over to the team.

1 Like


I can’t seem to find a way to send you a message with requested information directly. Am I missing something on the Forums Site?

I also can’t find a way to send you this info directly. There is no message button where I could find it.

I can give you some generic info:

It is happening right now for my camera overlooking the pool ( I use it to see that none of my cats fall in). - 2020-01-08 7:16 am est.

I use the alexa integration and try to watch it on my new echo show 5. But other echo shows behave the same.

I have the same issue on my black camera (but not on my white camera). It keeps buffering over and over. Sometimes it sticks and sometimes I get an “Unstable Network” error message. It is on a 4 foot long table with a router on one end and the camera on the other end. I am looking at it on my iPhone 7. No problems at all with the white camera. I am in the eastern time zone.

All three of you were pretty new to the community so I raised your permission levels. You should be able to message me now after you click on my name. :slight_smile:

1 Like

When I ask Alexa to show me a camera on my Fire TV it generally works pretty well.

There might be a reason for that.

My Fire TV is hardwired to an Ethernet cable. So the camera is communicating with the router via wifi, but the Fire TV is not. Only one part is going over the air, not two parts.


I gave up on using my Google Home Hub and bought a Echo Show Gen 1. It for the most part works very well with my four cameras except that I can only figure that the buffering is coming from the connection between the camera and the router. My Echo Show is about ten to twelve feet from the router. Funny thing is, the one camera Wyze Cam Pan is about three feet from the router so maybe my theory is wrong. I still have but do not use the Google Home Hub and probably will sell it. Alexa is working fine for me.

Same issue on my Wyze cameras using Google Home. I installed an Eufy doorbell yesterday and Google Home streamed to all of my screen devices without a problem.

Unfortunately I will now replace my Wyze cameras and will not attempt any further integration of other Wyze products into my Google Home.

Everything worked fine last week. But in the past few days I have also encountered this. I only get3-4 seconds of video before it starts “Buffering” again. Makes trying to watch or listen to the stream impossible.

I ask Google hub, to display cameras, get buffering, and then if it displays the cameras ,it plays for maybe 3-4 minutes, then starts flashing a picture from the camera for approximately 2-4 seconds. Then screen goes black, saying playing smart home camera… ``