Possible solution for lost person detection announcements in alexa

I wonder if your ability to watch Wyze vids longer than 10 minutes was due to the same glitch, or a similar one. I had always heard that 10 minutes was the limit (well, outside of using something like TinyCam to stream through the FireTV), so was surprised you were able to go for hours. Perhaps it’s a trade off…allow PD triggers but lose long term streaming, or lose long term streaming but gain PD triggers. Have you confirmed/tried “fixing/breaking” it back to allow you to have long term streaming again?

Where’d you get that idea? :slight_smile:

Are you talking to yourself again? :blush:

1 Like

Yep, Yep, Smart @Customer with an interesting idea. It could also just be some rogue bug in the Wyze programming that will either transfer over to the production app, or is something inherently only in the code specific to the Wyze Beta app in general that never get transferred to the production app (there are theoretically many subroutines that are only ever in the beta app).

But it could be something weird on the Alexa Side too, like you mentioned. The more info, the closer everyone can narrow down the cause.

I tried going back to no PD in Alexa by renaming the camera with the beta app.
PD went away but the time limit remained. :blush:
I may try setting up the camera like a new one but it’s not one that’s easy to get at.

1 Like

We have a couple of bugs that we are currently addressing around Alexa and Person Detection. Notably, we have been advertising Person Detection in Alexa for all cameras all the time.
Alexa team complained that it is setting a false expectation that person detection is working all the time even when the camera is not enrolled in Person Detection on the Wyze side.
We are working on making the advertisement in the Alexa synchronized with the actual ability of the device (ie. no PD in Wyze app means no PD in Alexa and the other way around).
The engineers are working on that very topic right now. It’s a top priority for us to get that resolved because one of the certification is at stake and we could get in trouble for having the WWA logo on the v3 box.
The support for PD should not have disappeared during that process and I’m not sure why it did. I have actually filed a specific bug about that about 1 week ago. Engineering told me they are looking into it.

For the timeout, one of the thing that we have not talked about is WebRTC. We have silently started to deploy it to selected cameras ((ok 150K of them so far). WebRTC does not have time limitations because it is peer to peer. This means no round trip to the cloud when you are looking at a camera in your house on a TV or Echo Show device. It means also that there is (almost) no delay between the camera and the display (sub 1s instead of about 3 to 5s with previous RTSP solution).


Thanks much, @Frederik, it is always great to have real information.

I wonder if that little Take Photo snapshot discrepancy (JPGs instead of PNGs) is attributable to a change to WebRTC.

This doesn’t seem explain what I am seeing.
I had at least one V2 thst would display in Alexa for >3 hours but did not have PD in Alexa.
The camera has PD enabled in Wyze.
Changing this camera name, and 4 others, using a non-beta Wyze app enabled PD in Alexa but the camera would not display for more than 10 minutes.
I removed the camera from Alexa and scanned for new devices. The camera was discovered again. It, and the other 4, no longer have PD in Alexa.

Did this camera have and then lose WebRTC just because I renamed it?

1 Like

That’s what I assumed when I read it, but after thinking it through, I am not so sure.

That’s interesting about the WebRTC basically allowing purely local communication to Alexa (and probably Google). I love that, because I technically have a metered bandwidth (1TB/mo). I wonder if that also means that with WebRTC we would be able to connect locally in general, like to Home Assistant, or if it would be limited to just the Smart Displays. From a quick search, sounds like the same API could used to allow basically anything to have access. like straight to our phones, etc too. I mean, possibly even instantaneous notifications from cams and sensors and stuff if we’re on the same WiFi (well, cams still need some stuff to go through the AI…but if they ever give the local/Edge PD on the V3’s like they said they’re working on, that could make initial analysis faster).

I do wonder how they can

silently started to deploy it to selected cameras ((ok 150K of them so far).

and do that for some cams, but not all cams with the same firmware. I’d think it was a special beta firmware, but he just said they did it silently, so people don’t really know…interesting…like they tell the firmware to only allow it for cams in a certain IP address range, or with a certain mac address range or something. How else do you do that for different cams with the same firmware?

Regardless, that is really exciting stuff about WebRTC.

It is too bad that people are getting confused about the Person Detection capabilities through Alexa. You’d think it would be obvious that it would only work if you activate the correct service through Wyze first, but lots of people don’t know how all the details work when they first buy. Still, what we are talking about here is when we have PD capabilities active and working with Wyze, but it still doesn’t show up on Amazon. Hopefully that gets resolved while they’re working on this issue in general.

I can’t see how that would happen without flashing firmware.

PD IS enabled in Alexa on the three cameras that DON"T have PD enabled in the Wyze app. These are the only three that stay consistant. I don’t know if it actually works but the routine ability is there.

It’s been happening for months. In my case, I don’t know if it ever worked right.

I am dealing with a similar issue. All cams in the Wyze app have been enabled for PD but only one of them is showing that option in the Alexa app. I also changed the name of one of the cams and lost that option in Alexa.
Any idea if this is going to be fixed?

I finally got around to testing this today on my 3 cams that weren’t working right in Alexa (3 that weren’t allowing PD triggers). angus.black is quite right: I also just went into a production version of the Wyze app using my daughter’s old phone, selected the camera in question, then settings, name, save (without even changing a single thing at all), and went back to alexa, refreshed the screen and it was totally fixed just like that. PD trigger and PD announcements were suddenly available and working as intended. It was really, really simple to fix. I really appreciate you sharing this work around @kjay Hopefully Wyze will fix this issue in the Beta app.


I tried this about a month ago and it didn’t work. I tried it tonight after seeing this post and it works! Thanks!

1 Like

Did it keep working?

I have 3 of 8 cameras that work in Alexa. The others will work if I save the name in the Wyze app but only for short time.
I don’t know yet what makes them drop from Alexa.
There’s no common attributes withe the 3 cameras that some of the 8 don’t have.
It’s just ridiculous that Wyze can’t tell us what is going on here.

You’re right, the 3 of mine that were “fixed” in Alexa by doing this trick on 01/04/21, dropped the Person Detection trigger ability again sometime between then and when I checked again today 01/17/21.

Did anyone in here get their cams to stay “fixed” in Alexa for at least 2 weeks?

That is weird. You’d think this should help make it more obvious to Wyze/Amazon how to fix the problem when saving the name suddenly fixes the issue temporarily…why does it suddenly recur through?

Nope, it stopped working after about a day. The weird thing is, I kept getting announcements even when the option was no longer there to turn them on or off. The option reappears everytime I save the camera name. I don’t know what makes them drop from Alexa either. I only have 1 of 7 that works all day everyday.

The rename thing only works in the production version of the Wyze app, not in the beta.
I wrongly assumed that using the beta app was causing to not see the cameras.
I dropped out of the beta program and installed the production app on my main device. It made no difference.

1 Like

Interesting. Though it is possible that the beta app still caused the problem since you used to have the beta app and those cameras could’ve been corrupted by it somehow before you dropped out.

If you drop out of beta, roll the camera firmware back to an earlier version (so it’s not still beta either), then delete the camera from the app, then reinstall the camera in the production app, and never add beta again, I bet it would stay working (I’m not very willing to try this, at least not long term, because I love beta-testing). I could be wrong, but I bet that would resolve it. If you try it, it would be interesting to hear if that works.

It has never worked for me. However I am using the Beta version of the app.



Moderator Note: Personal information has been manually removed from this post. Such information often gets included inadvertently in an email signature block when replying by email. The forum software attempts to automatically remove email signatures but it is not always successful. When replying to the forum by email, it is best to remove the signature block yourself before sending.

@SolarGoat are you using the beta app or firmware?