Playback does not work from the event view

I agree with your assessment but only to a degree. It does appear to be a code bug. However, my experience tells me that often times there are bugs that are simply not an easy fix. I’m not sure when Wyze changed their firmware show popups in the application to upsell (or other changes), but it is possible those changes coincide with this issue. That opens the possibility they’ve run out of room to add the fix back into the ASIC.

That said, there is also the slight possibility WYZE has made a hardware change in which case it’s too costly to retrofit all the bad cameras that already shipped. This would explain a lot with respect to why some builds work while others do not.

We may never know. **WHAT SAY YOU, WYZE? :sleeping: :sleeping: :sleeping:

This isn’t a firmware bug at all. This is a bug in the mobile app. And it isn’t because they are running out of room. I already stated that they have a working code in another part of the mobile app; they just need to call that section.

I was asked to review a recent purchase by WYZE. It was a combo of two cam v3 cameras and four light controller sockets. In the review I mentioned this issue and stated I wouldn’t recommend it. WYZE replied in a email stating my review didn’t meet their community standards but didn’t say which part. The email had a link to edit my review but when I clicked on it it said that I had already reviewed the product and it didn’t let me edit it. When I tried to respond to the email it bounced as a no reply address. I’m not accusing them of anything but it didn’t seem like they were open to a review edit after all. It seems this issue is a sore spot for them. I will continue to honestly review WYZE products when requested, I must state that the majority of products that I have purchased from WYZE have been very good and I would complement them as well.


I have same problem with one of my V2 today. I can see old recordings when clicked “View Playback” in live stream. However, I got “MicroSD Card Not Found” when I clicked Playback from the recorded events. I rebooted the camera and reformatted the microSD in camera. Problem still exists.

I am using latest firmware and app.

iOS app version: 2.50.7 (10)

1 Like

I too am having the same issue and everything worked just fine up until 6/11/2024 now I just get the spinning circle of death when trying to view from events tab only works if I go to live feed and then scroll back to a specific event. Submitted a log but from all the comments I’ve read and the fact this has been going on for quite some time doesn’t seem like they’re ever going to fix it. Log id: 1439170


Glad to know you have a service ticket logged with Wyze, countrygirl. I was planning to ask if anyone on this thread had ever opened one. Too bad no one from Wyze will step in here and show SOME signs of life. They sure tout their customer care and service on the website. But so far I’ve seen none of that!

I have one logged too. And I know at least three others do too.

Submitting a log doesn’t do anything unless you open a ticket with tech support. Only then will they take a look at the log.

With all the logs they have I can’t imagine that they can’t isolate the issue.

All 3 of Wyze developers are hard at work on those bugs.

I would send my V3 back for them to examine if they paid the shipping. Since I can playback the SD from live view I’ll just keep using it.

FYI: The issue is not being able to access the SD from the Events menu, not the Live menu.

Vote to have this fix in the June Fix-It-Friday

1 Like

I know the issue is No Playback of the SD from the events page but it does playback from live view. I voted to get it fixed in April, May and June. :upside_down_face:

Same issue here. V3 purchased May 2024. Playback from Events was working a few days ago but not today (says no sd card). Also a bunch of events will only display a static image. No problem with older V3.

1 Like

I have done both. Thanks.

So I have tried everything before… deleted the camera from the app, clear cache files in app, factory/hard reset the camera, re-setup camera, verified sdcard works on PC, format sdcard on PC and in camera. Nothing worked.

Today, I moved the camplus subscription from another camera to this troubled camera. And bammed, it worked!!! When I removed the camplus subscription and put camplus lite back on it, it’s broken again. W#$&F!??? What/How subscription has to do with playback from sdcard?

This feature worked for years without issue until recently. Seems like Wyze deliberately broke it so people have to pay camplus subscription.

1 Like

I have Cam Plus and still have that no SD card bug. Besides Cam Plus has nothing to do at all with SD cards.

Nope. I have cam unlimited and one V3 out of 6 will not playback the SD from the events page but it will playback from Live View. The Cam was activated 12 March 2024 and I’ve had Cam Plus Unlimited (Cam unlimited) since October 2023.

Mine is a V2. Not sure if it that makes any difference.