Person Detection update not working

How do I get the old firmware back? The new one has people walking right in front of the Camera and no detection is recorded by the new firmware. It defeats the purpose of having the Cam if it can’t detect people or motion right in front of it. The old firmware detected every little thing and that was annoying but at least it worked.

Do you have today’s version of the app? (v2.4.65 for iOS, v2.4.82 for Android) To see the most recent version in the iOS app store, pull down to refresh the list of apps to be updated.

And then of course you still need to set it up:

Are you sure the firmware is the problem or are your settings not correct? I suggest reading the support page first. However, if you would still like to revert to the old firmware, see the post below for v2 cameras.

1 Like

Thanks for the info.
I have already read support pages and have
changed all my settings or attempted too at least before I posted this.
Everything was working fine until the recent firmware update. I even disabled the Person detection service after it failed to perform properly but now one of my cams doesn’t even recognize that a SD card is installed. When i try and enable zone tracking it says it’s not available on my device. The other Cam works fine however.
I will likely have to remove it and then reinstall.
For the price I can’t complain as you get what you pay for. I just wish they would stop over promising and stick to getting the basics working properly before releasing new firmware.
Keep it in Beta Testing where it belongs . I could have had people stealing packages at my front door and the Cam missed it totally. I reviewed the SD card and sure enough seen the people walking up to my door as well as me going out to retrieve the packages but the software flagged and recorded no events.


It should go without saying that I downloaded the latest version of the Android App today and updated the Cam firmware or I would not have the new Person Tracking option.

some people have found an issue where all their settings are correct, but for some reason person detection does not actually work until they reboot the camera. not sure on the root cause of this. I can’t promise it will work, but its a simple test that might work.


I’m in the same boat. Just did the firmware updates on a v2 and a Pan and now neither camera is sending notifications regardless of my notification settings.
I tried setting them up to only send notifications if a person was detected. That didn’t work.
I tried setting them up to notify me if any movement or sound was detected. Still nothing.
Additionally, the v2 is now making clicking noises about once every two minutes and both the v2 and the Pan do not connect in the app as reliably as they did 30 minutes ago, before I updated the firmware.
Anyone have any ideas?
Yes… I did power cycle the cameras by turning them off and back on and then later by physically unplugging the power cables.
Yes… I am running the latest app. Just downloaded it before doing the firmware updates.
Thanks in advance for any help.

1 Like

Person detection is not working as expected for me either. Yesterday, I walked right in the detection zone. A Motion event was recorded, not a Person event. Same thing happened today. My camera is looking at my front porch through the window with a screen. Could that be throwing the AI off? I am on Wyze app v2.4.82 and firmware

Yes, although interestingly I can identify people thru my blinds. I’ll paste some some quick tips below. One of the don’ts is viewing thru a screen.

I also want to make sure no one thinks a smart alert (sensor-driven) is capable of identifying people. Has to be a standard camera pixel motion alert, which of course is also subject to the 5-minute cool down.

If I read your problem correctly, it sounds like the same that I had, except I was getting absolutely no notifications for any movement, although I was before the update. I messed with settings and reseted settings, restarted phone, checked phone settings, checked phone security settings…I checked all that I could think of and then today I just deleted all the cameras from the app and deleted the app. I then reinstalled the app and the cameras. Now I get notifications again and as well as person notifications.

I have a Samsung 8 with all phone and app updates.

After the App and firmware update one Cam would not recognize the micro sd card was installed. The cam kept making clicking sounds as well and felt hotter than normal.
I had to remove the Cam from my account and then set it up as new and it fixed my issue with sd card and clicking sounds.

Just checked my app. The detection and recording of people works. It just doesn’t notify you but it’s there under the bottom tab "event recording " then “person” tab. Its all there. Would be nice to get the notifications but at least it’s recorded should you have an issue and need to go back to the recording. Hope this helps.

I had to enable all motion detection notifications first, waited an hour until I received both types of notifications and then turned off all notifications except for person detection… works perfectly now.

Hopefully this works for others and it wasn’t just a coincidence.

1 Like

Had the same problem, tried everything. Then I changed the height of the camera. Had it about 2.5 feet above ground then raised it to about five. Everything works great now.

yeah mine still doesnt work i’ve gone thru all the troubleshooting and still nothing

I assume mine is working but when I look at events I see that my camera is detecting my miniature dachshund as a person. I don’t know how this algorithm works but it appears that it just looks for objects moving smoothly across the screen as a person (or dachshund) would when walking across the field. I wouldn’t call this person detection. What about a person remaining stationary?
I think it’s just a gimmick. I turned it off.

I have done all the updates and toggled all the settings. Still no person detection. I call BS.

Are you getting any motion alerts, person detection depends on motion detection

1 Like

Nope, nothing at all. I bumped sensitivity to 100 as well.