Person Detection trigger not working

I recently noticed that Person Detection is an available trigger.
I set up my driveway camera to turn on notifications if it sees a person.
The camera is detecting people (randomly) but not running the commands.

Android app v2.10.71
V2 Camera firmware

1 Like

An available trigger for what?

A trigger for Rules.

Ah, I thought you might have been talking about an IFTTT or Alexa trigger.

Edit: Confirmed with the engineers that it should be working on beta and release versions. If you’re seeing trouble with Person Detection triggering events, please submit logs for us and tag me with the log number so we can investigate.

Sorry for the confusion on this, everyone, but thank you for letting us know about the behavior so we can sort it out on our end!

Then why leave it as a usable choice in the rules?
That just leads to situations like mine. There is no reason for users to think it wouldn’t work. I just spoke with the engineers working on this and apologize for the miscommunication. Person Detection triggers should be working on beta versions. If you’re running on beta and this isn’t working for you, please submit a log and let me know the number it generates so we can investigate.

Edit the edit:
Person Detection should be able to trigger all rules in beta and official release version of the app. I’ll amend the previous post as well.

Thank you for submitting the log, I’ll share this with @WyzeShawn and his team!

Ticket ID: 10715



My beta version will not trigger based on person detection either. It never has my ticket is 10747

1 Like

Thank you! I notified the devs so they can take a look!

My rules trigger on a person detection event doesn’t work either. I am running the latest versions of the firmware based on the firmware update function in the app.

Can you please submit logs for us and let me know the number it generates?


1 Like

Rules trigger on person detection still doesn’t work.

@NumberOne. This remains true for me as well

Same here. I am getting Camera Person Detection Notifications but they are not triggering the rules I have, such as turn on a plug. Rule never shows up as having run even though a person detect is captured as an event. I also changed the rule to trigger on camera motion (not person detect) and it does work. I have rules setup using the motion sensor that work. Is this something they are looking for to help debug?

1 Like

Checking with the devs on this – there should have been a cloud fix to correct the Rules not triggering based on Person Detection. Please send us logs and let me know the assigned numbers so I can relay this to the dev team!

Ticket 21319 with the log

Ticket 21320. Kyle I appreciate the fact that you keep attempting to move this along but to be honest we’ve heard month after month after month that it’s supposed to work and they have never worked why don’t we do this why don’t we allow wyze to tell us when it’s functional so that we can look for it then.

Because they think it’s functional now. I can only assume they use a different brand of cameras. :slightly_smiling_face: