Old Gas Furnace with Wall Adapter for C Wire

I’m attempting to install the Wyze thermostat with a fairly old gas furnace. The current Honeywell thermostat has the following wiring:
W - White wire
G - Green wire
Rc - Red wire. Jumpered with R
Y - Empty
C - Empty

There is no Rh spot on the existing thermostat.

I purchased a plug-in 24v wall adapter to supplement since there is no C-Wire. Based on this video - How To Install A Common (C) Wire: The Easy Way - YouTube - and the Wyze setup I’m using the following connections to the Wyze board:

24v Adapter - into C and Rc (it has two wires)
Red - Rh
Green - G
White - W1

I attempted leaving the red unconnected and that did not work. I’ve tried switching the Red and one of the 24v wires (the Rc and Rh) and no luck either. In its current configuration the Wyze thermostat screen displays ‘Wyze’ but the app says the G wire is missing. Unfortunately, the board in the thermostat was bypassed and the Red/Green/White wires are straight wired into the furnace.

Any thoughts, advice, or references would be appreciated!


You could use an isolation relay on the furnace side to switch the fan separately, or you could just connect the G and W wires together and have the fan always run when the furnace is running. It’s not ideal, but it would work. You should have a fan control if you do this though.

1 Like

That is very helpful, thank you! Do I need to ‘fake out’ the Wyze app to make it function properly? It really only asks about the existing thermostat configuration (which doesn’t have the C wire). Should I tell the app I have W, G, C, and Rc wires (despite my existing not having a C). Then I’d hook it up accordingly and leave the furnace’s Rc wire not connected?
Thanks again

Tell it you have Rc, C, Rh, and W wires.
Connect the external transformer to Rc and C, the R wire from the furnace to Rh, and the G and W1 wires from the furnace to W1 - You will want a short piece of jumper wire for this, rather than trying to fit 2 wires into the wyze connector.

The app is still very angry with that configuration. It’s saying every wire that we didn’t specify in the original config is “missing”. I’ve cycled power a few times and attempted a fresh install in the app.

I just checked the wires in the furnace and the G wire is not connected to anything. The red wire goes to the power and the white connects near the pilot light.

If you didn’t want to have to use the C transformer, you could reset the thermostat, and connect the green wire to the same transformer terminal that the black wire is on. Then tell the wyze that you have Rc (red), C (green), and W (white) wires.

It is disconcerting to see that some of the safeties have been bypassed on that furnace, and the pilot light is poorly tuned. Make sure you have at least one CO detector on each floor of the house as well as a working fire alarm in all bedrooms and the basement. A tech that worked on this system would likely condemn it until the safeties were reinstalled.

When we moved I installed new Co2 detectors on every level.

I’m not attached to the plug in adapter, just figured it was a means to an end. To bypass it and use the existing furnace hardware I’d connect the green wire to the opposite side of the terminal where the Red wire is in the furnace?

Thanks Speadie for all of the help and insight!

Connect the green wire to the transformer, along with the black wire opposite from the red wire. Also make sure you have the other end of the green wire (at the thermostat) attached to C or nothing first, so you don’t short the transformer out.

That worked! It’s wired up and running well, thanks again!