My Wyze app says WyzeBeta

I have never signed up for beta but my iOS app after an App Store update now says WyzeBeta.
How do I go back to the normal app?
I have tried deleting the app and reinstalling it again from the App Store but that did not help either.

iOS and Android are different on how you get the Beta or not. iOS uses Test Flight, Android gets installed if you sign-up. you have indicate that you have not signed-up. However, to be 100% sure, go to the Beta Sign-up site: Become a Beta Tester – Wyze and if you have been signed up, you can elect to be removed from the Beta Test. Make sure you follow the directions for the Device you have.

Also note, there is no beta app for Android and I believe iOS at this time. so you may only need to remove the app and download it again.

Thanks for your quick reply. I am iOS. I don’t have TestFlight app installed and I never have and I have never signed up with Wyze beta. I clicked the link but it doesn’t work because I don’t have TestFlight app installed.
I have tried deleting the app and installing again and this did not help either.
I tried on a different iOS device and same result.
It only happened after an App Store update.
I am version 2.19.22. Not sure if this is a beta version or not.
If in the app I got to wyze about…beta program. It comes up with Get Started which also indicates I am not signed up to beta testing.

Known issue.


This may be part of the known issue that @Customer posted. To confirm, the latest production app version is 2.19.22 (April 8, 2021). You can go to the app, then “account”, then scroll down to “about” to find the app version.
Edit: it looks like this was happening with an older version. @Beihrle can you make sure your app is updated?


Yes looks like the same issue. I upgraded to 2.19.22 but I still have this issue.

I have the same problem Also my notifications are 1 hour behind but when I check them in events the time is correct.It’s happening on all my iOS devices I can’t get rid of this Beta app ,tried everything but no joy .

I also have the same 1 hour problem as you

I also have the same 1 hour problem as you.

Today my notifications are now showing 12hours behind

Now back to 1Hour :see_no_evil:

@Beihrle @Tyne1 – On the “WyzeBeta” naming, just to confirm you both now have app 2.19.24 installed (Account tab > About), correct?

What iOS versions are you using?

Yes V2.19.24

Yes correct. iOS 14.4.2

I’ve escalated this.

I don’t see it on iOS 12 or 13 (using an old game that keeps me from going to 14).