My account is messed up and nobody will help me,V2 lost person detection and Alexa/Google on same day 5 months ago!

Yes both ,I just get no person detection in the Wyze app or Alexa for that one camera and no voice assistant intergration with Alexa or Google
Alexa said " I am having trouble reaching null" for like 3 months now it just says the camera is unavailable or something , null is javascript error

1 Like

Definitley not that I have since added devices and I even added another V2 the other day that I had bought a long time ago that I never got to set up and it works fine it is just the one camera not working with person detection or either voice assistant.

Yes that is my next step.
I added another (V2) camera already and it works.
I will set up another one and replace the one that is not working
but this camera has been where it is since 2018
and working with Alexa and Google and person detection since those features were introduced , though sometimes there were outages but it always came back to working with those features
this time nothing works and I have removed and readded the device a million times and reset the camera and tried flashing different FW’s wihthe SD card
I am certain that the problem is up in the Wyze cloud, the camera seems to be somehow disassociated with something on the server end
if only there was a way to change the MAC address on the camera I bet it would solve the problem ,I think it is the MAC address of the camera that is associated or not associated with something on the server side.
If I could remove the camera and change the MAC address to a new on and re-set it up I bet it would work , since I added a new V2 and it works and my other old V2’s all work.

Not sure then, definitely seems somethings messed up in the cloud maybe, although I think when you delete it from the app it’s MAC address (or whatever they use to identify it) is removed from the database. @WyzeJimmy may be able to help you, but the only option is probably just get a replacement.

Also null is pretty much anything computer related, not limited to js :slight_smile:

MAC address is embedded in the device itself
it’s like an electronic serial number that identifies the device

Yea, it’s built into the networking chip. Would be weird if Wyze kept it in the database even after deleting it though…

Dunno , can’t say how it is supposed to work but I have deleted and readded the camera a bunch of times but I usually re add the cam right after removing it
maybe it needs to be deleted and then stay deleted for a given length of time before it gets deleted on their end,
like remove it ,wait a a few hours? , a day, a week? and then add it back

1 Like

Yes and no… Wyze uses the boot process to assign a MAC to the cameras via software. At one point there was an issue that caused that process to fail and the camera connected to the network with the “burned-in” MAC which was totally different. Not sure if it is still a problem.


Try removing it, delete the app cache, logout, login, add the camera. What firmware version is currently on the camera and what is the app version?

I tried with the RTSP that I was using then I updated manually to stock FW then I updated that a couple times , I have tried removing and readding it on all of those FW’s the results is always the same
I think it is definitely something on the cloud end because of the different error messages I got from Alexa , especially the one that was saying “I’m having trouble reaching null”
then it stopped saying that after I made no changes but it was saying that for like a month then stopped and it also was not saying that when the camera first stopped working
that and that fact that no mater what I do I can no longer see Google listed under account> smart intergrations
I used to see both Google and Alexa in there , but now no matter how many times I unlink and relinking it never shows up in there any more, not sure if anyone else has this issue or not
but despite it not showing in the Wyz app it does show up in Google home , and everything work with Google except that one camera, all other V2’s and wyze smart plugs work
everything show up including the non working camera and even weirder still

I can get my google home mini to stream that camera to my new CC , but it doesn’t work from my Google home hub and never has since the problem started.
With Alexa it will not work from my echo show 8 or from my echo dot 3rd gens paired to 4k fire TV sticks

I had this issue and it drove me crazy for about a month. Finally resolved by going into the page and logging into my account and going to services then CamPlus. You may see your two licenses listed separately. If you purchased both licenses from wyze directly and not through the phone app, that is your problem. Licenses purchased from wyze directly are listed in one entry. Apparently an update to the service made this change without accounting for users who had multiple licenses purchased directly from wyze. This is my assumption, but I don’t know for sure what the root cause is, I just know what fixed it for me.

Go to the license that is working and click edit and add a second license. Then go to the phone app and enter the account section then click service and CamPlus. You should see your two cameras. Click on the camera that is not working and uncheck the box to remove the old license. Go back to your account on the wyze website and cancel the license that isn’t working. At this point you may have to force close the phone app and restart it. It should show only two licenses available for CamPlus, the old working one and the new one which is unassigned. Assign that new license to the camera that was not working, restart the camera and all should be good.

That is what resolved my problem. I hope it works for you.


I only have cam plus lite , well now I have a trial
still doesn’t work after adding a new cam and getting a free trail but
it still would not explain the broken voice assistant integration because you don’t need a subscription for that
, was your problem just limited to no person detection or was voice assistant integration affected too?

My problem was with AI notifications. I didn’t try using the integration features.

1 Like

Just to add to the mystery, I have a single V3 with CamPlus Lite (just like my other 12 or 14 cameras, a mix of V2s and Pans) and it isn’t doing any person detection. It’s running the RTSP firmware It has been working fine and suddenly stopped doing Person tagging or notification. I turned off all detection and let it sit for a day or so then turned it back on. Worked correctly for a day or so but now has stopped Person detection again.

Something flaky on the Wyze servers.

I’m having this same problem, just started couple days ago on 8 out of my 24 cameras. “Hm, I’m having trouble reach null…” or An error has occurred. Please tr…" with a red dot shows on 2 of the cameras when manually selecting smart home, & looking at the cameras… while going thru the step on my alexa to type in here, I just noticed a couple of my non-wyze devices thermostat & a plug, are now displaying “An error has occurred” next to the thermostat, & “device in unresponsive” next to the plug…however the plug turned off & back on when I told Alexa to do so.
I have Pan 1 & 2, Cam 2 & 3. 4 different networks…I’m a computer tech.
I removed a camera yesterday, & won’t do that again as I am unable to get it back even with having Alexa scan for new devices. ALL Cameras show up fine on my google show! So I believe the problem is with Alexa.
I’ll continue to troubleshoot & see if I can figure it out. I’m thinking the camera is not connecting to the cloud server.

1 Like

The Wyze Gremlins in Server room did it again.

You need to submit lots of logs and post it in Fux it Friday.

1 Like

This morning I re-evaluated my cameras that were not connecting in Alexa & getting the “having trouble reaching null” message to Alexa & noticed a pattern. It was only my Cam V3’s that weren’t connecting. Yesterday I recieved 2 new V3 cameras, so after activating 1 of them, I decided to update the firmware on it. Used it instead of 1 I already had as always feared of updates breaking cameras. I had to upgrade from to (as you can’t skip this update), & then updated to the current ver Each step I made sure the camera was still working (giving time for the camera to finish rebooting), & after ea camera updated to the current version, I checked on my Alexa show that that camera showed up. Now all my cameras are working\showing in Alexa. All my V2 & Pans were already connecting, so not sure I’ll update those, always feared of bricking & those are no longer under warranty.
Now I just have to figure out how to get back the 1 V3 camera that I had deleted from Alexa back as doing a “discover my devices” doesn’t show it.
Hope this info helps someone.

Try renaming it in the Wyze app, to a temp name. (The one missing from Alexa. ) I’d give it a name starting with a number or A-C, so its easy to recognize in a different place in the list of Device in Alexa app. Then, if it doesn’t show up immediately give it a couple of hours.

Has worked for me.


Thanks for responding Sam Bam. I had tried that as well to no avail. Last nite b4 I went to sleep, I was scrolling thru All Devices under device settings & to my sprise, I saw in the list of devices “office” & there was a green dot next to it. So I immediately tapped on it (feared it would disappear if I didn’t act fast lol) & the screen popped into Office Settings. So I told Alexa to show that camera, & she said OK & immediately displayed the camera. Now all cameras are showing & communicating properly with Alexa & she’s announcing person detection notifications.
BTW, I did update ALL of my Wyze Cams last nite, checking that each 1 worked b4 doing the next, & thankfully had no problems.

1 Like

:slight_smile: Its called Magic