Issues Syncing Wyze Band Data to Google Fit

I had no problem adding the Google Fit integration to my Wyze Band. Google Fit clearly shows that it is connected to Wyze Band for Heart Rate data and Sleep Data, but it doesn’t sync regularly or sync all info over consistently. When I open up Google Fit, it may sync data from yesterday, but the previous 4 days have no data, then maybe it has data from one day 5 days ago, but not the 7 days prior to that.

My Wyze Band is worn every day all day and in the Wyze Band app, I can see my heart rate, sleep rate, and steps for every day - this info just isn’t getting synced over to Google Fit. I am on the latest version of the app, the latest firmware for the band, and I have completely unauthorized the app with Google Fit, uninstalled the app, re-installed the app, and re-authorized with Google Fit and still have the same issue.

In comparison, I have a smart scale from Eros that has Google Fit integration with their app, and every time I weight myself and record it in the app, it immediately syncs the data over to Google Fit. When I go to Google Fit it has all the data from every day I weighed myself. So this clearly seems to be a programming issue with the Wyze App and the way it syncs with Google Fit. Hoping it can get fixed because I like being able to see all my fitness data in the Google Fit app.


Yep. Hit or miss data update in the Google fit interesting. I am finding the band is not reliabily providing data as well



1 Like

I just got the Wyze Band and I’m having the same issue. Has anyone found a solution?


Not yet from me. Hit or miss transfer of data to Google fit.
Sometimes partial, like steps missing from bands display, being transferred to fit.
Sleep and heart rate are usually spot on.
But I find I have to sync the band first thing when I get up to make sure heart rate and sleep actually get transferred.


As of March 15, 2021, also having this issue. Tried reconnecting Google Fit and issue resolved for one day. Now Google Fit is saying I haven’t moved at all when everything gets synchronized.


Same issue here. Really frustrating. At first, manually syncing once a day would keep it up to date. Even tried to write a Tasker automation that would do it for me while I’m sleeping, but I’m not smart enough to figure that out :slight_smile:

Now, it skips entire days. Hopefully I’ll see better data tomorrow since I re-authed today.

I’m having the same issue

1 Like

I submitted a ticket to wyze the other day as I noticed last Wednesday there was an update for Fit and ever since that update steps and sleep do not come in at all from wyze… But heart rate does!
Go figure…


DItto. Even after re-auth and manually synching several times, I get heart data but no sleep data since March 8


I really wanted to make this band my go-to, but lack of accurate sync to google fit ultimately led me back to fitbit. I get that it’s an inexpensive band, but it should be able to synchronize steps and workout at the very least. That’s all I need.


I have never had the sleep data sync over to Google fit


Same issue for me as of 05/21/20 hoping for an update on this. That and Amazon music control on my phone.

No matter what I do I can not get Wyze band and Google fit to connect so I can get a better break down on sleep or even see sleep data. Half the time the Wyze band doesn’t show any data.

1 Like

Finally Support got back to me and asked me to delete my band from the app and reconnect…
I did so…
tried syncing this morning, steps were passed over, but again not the total count only some of them, and the heart rate went into Fit…
No sign of Sleep data still…

1 Like

Any new ideas about thing. I called support but they told me because it was in integration, they will continue researching.

For me it happens with Wyze Band and Wyze Watch 47. Wyze scale data still moves over.

I’m having very spotty Google Fit integration with Wyze Watch 47 also. I’ve read people are having better luck using the WyzeBeta app but when I tried it my watch had a harder time syncing with my phone. After going back to stable app I can get data (partial) to sync when I unauthorized and reauthorized Google Fit integration in the Wyze app. Only the BPM data synced though, we when on a 5 mile bike ride and none of that is showing in Google Fit, step count in Wyze is ove 15,000 buy Google Fit shows 3,600, which is about halfway through my day at work.

1 Like

It synced some data for me my first two days, It took 12hrs for it to sync today. Not sure what is going on. I did not try the Beta app because everything except sleep data was going over. I was going to try to reauthorize it, but I could not find where to do it.

I think just go to the mine tab under the watch and click Google Fit and unauthorize it. You my also need to disconnect it through the Fit app as well. That was the only way I could consistently get any data over.

Sleep tracking only seems to sync if you’re using the beta version of the app.

Had the same problem this morning. Reauthorizing the app worked. Less than ideal. Odd that it worked the first two days without issue.

I am not pleased with the accuracy of the sleep monitoring. When I get up, I sit and read my news feed for about 30 minutes before I start my work out. It includes that time as sleep time. As everyone has pointed out, the sleep data is not being synced in Google Fit.