iOS App V1.5.59 released to Beta testing!

Hi folks,

We released iOS app 1.5.59 to beta testing.
The changes include:

  • Fixed live stream crashes with 12-hour format
  • Added that photos are saved on SD card besides device album

I have IOS app v.1.5.52

My testflight is not showing the 1.5.59

Can you resend it to me?


Dismiss my previous post. I found the Testflight. It was in a different email folder.

However, the app version is 1.5.28



The firmware upgrade bricked a v2. The firmware took forever compared to prior upgrades and the device is bricked. Solid yellow only. I tried with and without the sd card same result. The setup button doesn’t work either. I will try to reflash it tomorrow with a prior firmware

Firmware upgrade bricked 3 out of 5 v2 cameras. Same thing extremely slow upgrade of the firmware. Like 10 minutes each.

After the 2nd camera bricked I thought it might be a problem with the app on my iPhone so I flashed the others with my iPad.

Same problem. Bricked the 3rd and messed up the 4th. The 4th out of 5 night vision is not working and it’s extremely dark with the normal view. Completely unusable now you can barely see anything

I’m going to try to manually reflash the 4 tomorrow .



I have all 4 that messed up working now but it took hours.

Because the newest firmware is not on this sight yet after I manually flashed each camera with the newest firmware I could download each camera had to update to the newest firmware over the air.

3 updated fine including the camera that was very dark and the night vision not working.

The 4th bricked 3 times in a row. I tried reformatting the SD card and then using a new SD card. But finally after the fourth time it worked.

I have been in the beta along time and have v2 and pancam cameras and have never had any problem updating the firmware before.

Same thing happened here. It bricked two of my cameras. Going to try restoring them now.

Same problem, I bricked 3 v2 cameras with this update. Hoping to restore them tomorrow, but I have them mounted up high and will need to get a ladder out to reach them!

There also seems to be issues with video playback. The videos are constantly not loading, and I have to force quit my app, and re-open it’s before the video will play. Anyone else having this issue?

After reading all of these comments I am thankful that the Testflight that I received and used did not install 1.5.59. Instead it installed a new app with 1.5.28. I am not even going to try to download the 1.5.59. I will wait for the next update.