How to add steps to rules?

I am sure this is me, not Wyze, but I went to rewrite my shortcuts to include the new features and I can add one command, but I can’t figure out how to add the second step? Or edit existing shortcuts to add commands.

I know this will be a “stupid user” moment, so please help me out and put me out of my misery.

Thanks. :slight_smile:

UPDATE: Both adding a shortcut and adding a device trigger allow for multiple actions to be added. But schedule which is what I use most, does not.

I am thinking this is a bug.


I have the same annoyance. I had several “routines” that ran throughout the day that involved multiple actions on my various devices (such as a bedtime routine). Interestingly several of these seem to have converted to rules with the multiple actions intact. I stupidly deleted one because it didn’t seem to be working correctly (which I’ve since discovered wasn’t an issue with the rule but rather a setting in one of my cameras) and now I seem to be stuck creating 7 distinct rules to replace it. This update was supposed to improve quality of life… not introduce additional complexity. Am I doing something wrong or is this the way the new update was designed?

1 Like

The new “Rules” needs more work atm and still has a few bugs to be worked out.

1 Like

Same problem here. I really miss the way schedules used to work and hope they fix this soon.

1 Like

I’d settle for the new rules actually just triggering at this point.

Ouch. Mine are still working when I actually remember to set them because there is no way I’m creating dozens of separate rules to get schedules back up and running again. This last update is so terrible.

1 Like

I know there is currently an issue where in the history it will say failed even though they worked. Are they actually failing every time.

In most cases they are actually failing for me. Most of the rules are for cameras. Turning off motion tracking and alerts during certain times. But I get alerts 24/7. My lights tend to work most days but severalbtime I have found them on past their off time. Or the rule will work but only for 1 light in the group.

@Keith-S, I just found this issue yesterday when I tried to make a change to an old “shortcut” that was converted to a “schedule”. It performed 2 actions at 11 pm every night. I had added another bulb to the room and created a second group. When I tried to change the single bulb to the new group, the second action just vanished. And as you pointed out, there is no option to add another action to a schedule.

So, this is either a bug or a routine design flaw (subtle difference). In my former life as a programmer, I saw this a lot when a program was split between multiple design teams.

In any case, this really need to be addressed! Yes, I can (and have) made multiple schedules to deal with it for now. But, I really shouldn’t have to.
@WyzeGwendolyn and @mike.s, could one of you confirm that this bug will be resolved in a future app release? (Hopefully the next one!) Or should I submit a formal support ticket?

I would not consider this a wishlist item. The option is already available in 2 of the 3 rules options. It just makes sense for them all to have the same functionality.


1 Like

I’m still amazed this issue hasn’t been fixed. I stopped using my Wyze cams and won’t be purchasing anymore till this is resolved. Manually having to set all these individually is just to much especially when it was so easy to do before.

Thanks for the feedback! We are working on a solution to the problem, but we want to be careful about how we implement to ensure it doesn’t create any new bugs or constrain future designs.


Completely agree! The current implementation (12/4/2019) is a bloody mess.