Help - One camera not working

3 cameras V2 beta, firmware, App version 1.4.31. All working fine yesterday, today had great difficulty getting the app to open at all. Now, I can finally see notifications and live view on two cameras. The third one, and of course the one I’d most like to see, won’t connect at all. I’m not crazy about the idea of taking this little rascal down.

I’m not a computer/tech novice - but I’m not a whiz either, so any ideas/help/assistance would be appreciated.

Thanks in advance.

Delete and reinstall the Wyze app.

Tried that - took FOREVER to log in, but didn’t change anything with the one camera.

Here’s a picture of how the camera is mounted - not that I would think that would have any bearing on the problem.




Okay, so now the problem is with the one camera only?

How long is the cable run from the power supply?. If too long with an inferior quality cable, you could be getting too much voltage drop.

I would try taking down the camera and connect to the cable and power supply of one of the working cameras and see if that fixes it. If not, do a factory reset (click the support link at the top of this page and search).

The other two cameras have worked all time. The two that work are on a 16’ power cords, the one that’s the problem is on a 25’ - but it’s worked fine up to now. Bought the cords on Amazon when I first got the cameras. Also, bought 32GB cards for all of them on Amazon. this was before Wyze started offering the sd card and cords.

I don’t really want to take it down, took an act of congress to put it up (I’m not a spring chicken and did it myself), but if that’s my only solution, I’ll try it. I could probably move it closer to the plug, but I like the range I get from this angle and couldn’t figure out how to mount it on vinyl siding. It takes the longer cord to reach the plug. Not an electrician but would plugging into a regular extension cord help with the power?

I’m at work now - will tackle this project when I get home this afternoon and update.

The voltage drop problem relates to the length and quality of the USB cable from the power supply to the camera. If you using an extension cord lets you get the power supply closer to the camera so you can use a shorter USB cable, that might help. IF that’s the problem. Or a factory reset might fix it. Or it might be a bad camera that needs to be replaced. Only way to tell is to try these things.

As an alternative to taking it down, try connecting it to the included Wyze power cable (or a known good one from another camera), along with a known good Wyze power supply, and then plug that into a long extension cord temporarily. This will rule out the 25 foot USB cable and/or power supply as being the issue, as RickO was suggesting.

(Edit - RickO beat me to replying before I hit submit!)


The good news is the camera is working great with the original cord that came with it, or with a REALLY heavy duty extension and the original cord.

The bad news is I can’t put it back in the same place with those options. The extension cord is a bright orange and heavy, which pulls the camera around when it hangs, as the place it was hanging doesn’t allow the original cord to reach the floor. I tried a couple of other extension cords that ‘looked’ heavy, but the super heavy one that came out of my late husband’s shop was the only one that would work.

My other 2 cameras are plugged into 16’ cords that I also purchased on Amazon, but aren’t long enough for this situation.

Not sure what my solution is going to be. The camera is currently sitting in my living room - not really helping me at my front door :frowning: but it IS WORKING. Seems strange that it worked for over a month with the longer cord. It will NOT go back into the little bird house. I thought I was going to tear the camera apart trying to get it out :frowning:

I’m working on solution ideas as I’d like to have it back in the same place. Do you think it would work if I purchased the wyzecam mounting kit that gives an extra 5’ just used the little magnetic mounting and this heavy outdoor extension cord

Thank you so much for the help. I do love my wyze cameras and appreciate the forum so much. It’s my only source of how-to info and ya’ll are my heros

The heaviness of the 120v extension cord doesn’t matter. Any such cord will work. It’s the gauge and length of the USB cable that matters, and possibly the little USB power supply.

Here’s a site that will let you estimate voltage drop:

But a lot of cable providers don’t list the wire gauge.

People have reported success with these cables:

Not sure if one of those is what you already have.

The first link is the 25’ one I had the camera hooked to. <sigh>

As Rick said, the important part is the USB cable or possibly the Wyze power adapter.

Since the cable and power supply used to work, and because it is outside, it is possible the USB connections may have become a bit corroded, and are causing more voltage drop. Perhaps something as simple as unplugging and plugging the USB connector back into the camera will be enough to get it working again. If it is a bad connection from the wire to the USB connector in the cable itself, that isn’t going to be something that will be easy to fix.

If the original cable is still in place, the first thing I would try is to reconnect and see if it works after the contacts have rubbed off the layer of corrosion just by unplugging and plugging back in. If that doesn’t work, then try swapping power adapters with another camera. It is possible one of your other power supplies has a slightly higher voltage to begin with.

If that doesn’t work, then getting 110VAC (normal extension cord) to close the the camera is the most likely to work. Then you would be able to use the original USB cable with the camera. You should be able to use a cheap two prong extension cord with molded plastic ends, but you probably won’t be able to find one that long. Since there will be very little current (AMPs) going through the extension cord (0.25 AMP MAX), just about any extension cord will work as long as it has good connectors and the wall outlet isn’t worn out and the power adapter or extension cord doesn’t have a snug fit. The Wyze power adapter will accept voltage as low as 100VAC and still produce 5VDC out (it is a switching power supply). See

I don’t understand why your other house current extension cords didn’t work with the Wyze power supply. Did you try plugging something else into them to verify that they had good working connections?