Having trouble with RTSP firmware

Here are my settings.

on the General tab:

  • Source Type = Ffmeg
    on the Source tab:
  • Source Path = rtsp://un:pw@

Running ZM v1.32.3 on Linux Mint 19.1

That’s it!


Just installed RTSP firmware and I can’t connect to any RTSP player with it. I have tried ISpy, VLC, and tinyCamPro. Getting connection timeout errors. Do you guys have any suggestions?


Most folks around here haven’t had any trouble making their initial connections to the cams. Check your procedure again. If you are familiar with ping, make sure you can ping the camera from the computer you are trying to use.

Thanks MMediaman! I wasn’t able to ping it but it was showing on my router. Power cycled my router and was able to ping and now connects over RTSP without issue.

I’m running demos_V2_rtsp_4.19.4.48 with Blue Iris. Everything works for a few hours then the RTSP stream stops working. Connecting to the camera using the iOS app, toggling RTSP off then back on resolves the issue for 4-6 more hours. I need to resolve this to make this a usable option. Ideas?

I had the same issue. I found an old 8GB card, formatted it, and it flashed the firmware no issues. 16, 32+ wouldn’t work

I just went through this with trying to upgrade a V2
After tries with formatted Wyze 32GB card the camera would just sit there flashing yellow. After unplugging and replugging it still would not connect.
So I tried the procedure outlined

Booted fine, rebooted fine, now shows version and has the RTSP option under Advanced Settings.

Thanks for the tip. I can’t be completely sure, but I think I chucked it out a while back. If I still have it though, I will try this and report back.

I’m having issues with RTSP. I can never get a stream to continuously stream with macroblocking or the stream completely dying. Today i cant not watch the stream for more than 5 seconds before it crashes completely. I’m trying view the streams via VLC and Shinobi both struggle

What information can i provide to help this situation get resolved?

I’m having trouble reverting to the “normal” firmware on one of my v2, when I hold the setup button
starting the camera the led never turn blue to signify the flashing of the firmware. The other cam did fine with the same SD card and firmware… anybody seen something like that ? is there any way to flash another firmware from the app ?

Your wording is a little bit confusing to me. Are you trying to use the same card and the same demo.bin file a second term to flash the second camera?
If so try putting a new demo.bin file on a new card or even replacing it on your existing card and try flashing that on the second camera.
Good luck!

An update to the Wyze Cam RTSP article specifying that a microSD card below x size is required for the firmware upgrade would be a good idea. I had a 128GB microSD card working fine with the normal firmware, but had to dig out a smaller/older card to install the latest demo.

Hello @kap and welcome to the community

They probably overlooked this since 32GB card is the highest supported by WYZE even though some have had luck with larger.

1 Like

Yeah, that’s my thought as well. As stated I was using a bigger card with the normal firmware (and an upgrade) and it worked fine, so it was a surprise to me when the demo RTSP firmware didn’t work. Mentioning as much on the page that explains how to install it would’ve saved me an hour.


I need help with blue iris as well, can’t connect the rstp feed from wyze pan cam…I do pull down from https to rstp, then put in user:password@

Then I hit find/inspect it always shows no cameras found

For BI, all you need to do is select “rtsp://” in the dropdown field, then xxx.xxx.xxx.xx/live, your username and password in the appropriate fields. Leave all else on the Network IP Camera Configuration page defaults.

I had the same issue – I was able to get it to work by deleting the cam from the app and starting the regular cam setup over again (like you did when you first added the instance to the app–scanning the QR code etc)

The one most thing that has improved things (but not solved them) is to get better wireless signal to the camera(s).

Wyze problem is that the firmware will show the signal out of 3 bars in the Device Info, you can have those bars 3 out of 3 with a large signal difference; the only way to check that is with your access point if it shows the info for the camera connected.

Get better signal to the camera, which means get the AP close to the camera. STILL, even with this, the RTSP stream is unstable, BUT recovers much quicker, has shorter freezing episodes, etc.

This is what it is, and it won’t get any better, unless you put on 3rd party firmware. Now that I’ve moved better signal to the cameras, they rarely freeze totally; also with BI, you can set alerts based on how long the program can’t connect to the camera so if it’s really important you will get an email and address it (reset RTSP stream, etc).

With all that said, even when the RTSP stream freezes, the stream to the Wyze app is fine, so just points to a less than great RTSP implementation in the software.