Events playback reverts to beginning of recordings timeline every time I return to main "page"

I hope this will make sense:

I’m on my Events main page that shows 6 cameras with recorded timelines.
I choose first camera at 7.00 AM watch that video/event and go back to main page.
Choose next camera event, 6.50 AM. go back.
Camera events 3, 4, 5 etc. Same scenario, back to main page.
Now I’m at the point where I’ve moved back in time quite a while (3.00 A.M) and when I go back to events main page, I wind up at the 1st Event at 7.00 AM again where I initially started viewing. Now I have to scroll my pages every time past all the events I’ve already seen to get to the older ones I haven’t seen. It’s like having to fast forward a movie every time to get where you left off.
I can’t find a setting and wonder if am missing something.
I’d like to return to the point I left off when viewing the camera events.

1 Like

Hello @isa and welcome to the community.

It does make sense but my app is not doing that. Could you tell me what app version you are using and on what device you are using it on?

Hi Jason,

Thank you so much for your quick response. I am using the WYZE app which I downloaded from Google play store on my phone. Version I am also using Bluestacks on my HP Laptop PC. Both do the same thing. I just tried it again on my Samsung AE10 phone and same scenario. However I admit that on rare occasions it has gone back to where I left off (on both pc and phone). But that is very rare. I try to remember what I did different when it works but can’t seem to nail it. I’ve tried pushing esc, the back button, the back arrow, and can’t seem to pinpoint it. If on your phone, How do you go back to “original page”?

Thank you so much!


When I am going back I use the phones back button.

Hi. Has this been resolved? I’m having the same issue. Thanks

I’m having the same issue! I have to double scroll 25+ times to review footage from 7am on the day of choice, and if I actually view an event, when I’m done, I now (as of the last 2 weeks) get booted back to the top 11pm footage and have to double scroll another 25+ times to get back to 7am… it’d be nice if I could just go directly to whatever time of day I’m trying to get to, which is usually 7am for me.

Seems to be fixed in IOS App 2.44.5.x but not the Android version yet.

1 Like

Thanks. Looking forward to this being fixed

You could try an older version of the App before this bug started.

I am having this same issue? Any update from wyze team when this will be fixed?

I am having this same issue after recent app update, Is this going to be fixed anytime soon or should I just downgrade the app?

Also, I am not able to install older version. It says package is invalid.

We are still looking for the root cause of the issue on Android, the fix we made prior only fixed the issue on iOS.

1 Like

Same problem with my Pixel 4xl

1 Like

I have been experiencing this issue for some time now. It is getting very annoying.

Can you please fix? Happens on both android and IOS


Can you tell me the app versions you are running? We fixed it on iOS a while back and we are working on the fix for Android.

1 Like

I stand corrected. It looks like this issue is just recently working as it should in IOS.

It continues to be an issue with Android and has been for many months. When can we expect a fix?


We have found the root cause for the issue in Android and are currently working it into an app update so it should be coming soon, I do not have an exact ETA however.

It may be of interest to know the TimeLine behaves correctly and revert back to the last viewed area in Android version 2.45.0 (342) and IOS version 2.45.1 (1).


We pushed a hotfix out today that fixes the issue in Android.