[Discussion] Face Recognition problem updates and feedback

Hi all,

As we are rolling out face recognition to more of you, we are also seeing some problems of the system. So I’m creating this thread to discuss and give updates on the fixes.

[Update 09/09]
Issue 1: We’ve identified a problem when turning on the face recognition, the face collection is failed to initialize. This happends mostly to Android app with Cam v3 and doorbell devices. Right now we are investigating the root cause and working on the fixing.

[Update 09/10]
Issue 2: We’ve identified the pagination problem when trying to load more faces in the edit page. We are investigating the cause of it right now.

If you have any face recognition related problems, please leave the comments below. I’ll also look into the discussion in other threads. Will keep updating the status in this.

[Update 09/28]
Issue 1: this issue is fixed in the latest 2.25 beta app. If you have the problem, please help test with the latest 2.25 beta app. Once you download the app and turn off and turn on the Face Recognition again to see if it works for you!

If you have any face recognition related problem, please leave the comments below. I’ll also look into the discussion in other threads. Will keep updating the statud in this.


Does this include the App discrepancies between iOS and Android as it relates to the Manage Faces area in Account? Or are you looking for where AI fails to recognize or Recognizes incorrectly?

discrepancies like the following when going to the Account Page:

The menu for faces is “Facial Recognition” and it is not indented

The menu for faces is “Manage Faces” and is indented

BTW: Thanks for the info, this explains why mine is working since I set it up in iOS. I was having the issue with v3 and VDB as I set it all up with my Android Device.


Did you actually mean “IS indented”
He fixed it, so this post does not relate…

1 Like

Yes, Will correct…

Thanks for catching that, copy / paste got me. :slight_smile:

Scrolling issue in iOS when selecting multiple faces for removal from a group or deletion. Android works fine. Here is a post I added in the past, issue still exists in the latest app release:

1 Like

This is great news. I am so glad the submissions you received were helpful, and your followup is very appreciated. Let us know if there is any way we can help test things as it moves forward.


@WyzeShawn , rather than transferring information to this location or you needing to find it, here is a link to what I reported and tracked to deduce what the issue is. I provided the starting point if you would like to peruse the the Topic.


are u saying you initially setup facial AI via Android app & it was not working but after setting up via IOS you are now getting face detection on V3 & DB?

Yes, using iOS to setup all of the Facial is working now.

If you go to link above you will see the history

1 Like

Using a iPhone, I followed your steps, unassigning cam+ on all v3s & DB, then reassigned cam+ to all & enabling facial recognition. Tested all all cams, 2 of the v3s did recognize me as shown in the event list, another detected a face but not mine specifically. the others just detected a person. I’ll have to do more testing.


I stood in front of the V3’s to allow it to capture my face and start the recognition. After I did that, I then made sure I went to Account, Face Management and assigned a name to what it saw. Then went outside stood in front to see if it reported me.

I will retest it today and see. Have not tried since the latest Updates to the App.


Ok did my testing here and am still getting notifications based on who it is. (Garage is the only V2 Camera and Front Door is the VDB).

The only way this started working is when I removed the Cam+ via an iPhone and then added it all back in and selected Facial Recognition for each camera in the AI area.

I also used the iPhone to associate the Face to a Name. But I have to use the Android to edit a Name Group as it scrolls correctly in that environment.

Maybe I was just lucky


Yes, the UI bug is being fixing right now


Yes, we filed a bug for this as well. Added to the thread. Thanks!

1 Like

Hello, I’ve read thru this thread multiple times, but am still unclear as to whether or not I can fix the issue, when operating on an Android device. I have 12 V3 cameras, 9 with CamPlus. I can toggle Person Detection to on, but only on some cameras. However, Face Recognition (Pilot) cannot be toggled on any cameras. Instead, I receive the following error message: “Face Recognition Open Failed:{“message”:“Bad Request”,“response”:“The specified collection id is invalid and/or does not exist for the


1 Like

Do you have another device to try the same settings and see if it is happening on it?

Also, have you tried restarting the phone and then see if you can set the Face Recognition?

Hello. I have restarted the device, as well as the camera & the app. However, I have not tried on a different device. I have an iPhone for work that I can try (I’m very hopeful I’ll be able to utilize my personal phone, though.)

Yea, it should work and does with some issues on and Android Device. I had added information of testing I did. i have an iPhone and an Android which I test from, I found that using the iPhone and removing the camera’s from CamPlus, backing out of the app and going back in and then adding the Cameras back to CamPlus (again, from my iPhone), then setting Face Recognition as one of my AI preferences, seemed to do the trick. After that, I can use the Android Device, but I don’t touch the AI preferences from it.

You can also try clearing Cache:

Go to the Account Menu, bottom Right, then App Settings, then tap on the Clear link to the right of the Cache File line - position one in the list.

To ensure all cache is cleared, you could shut the app down, long press on the Wyze app, tap on App Info, Tap on Force Stop, the go to Storage and Cache and tap in Clear Cache. Then Restart the phone.

Note: On the Home Screen you will see all of your Thumbnails will be missing for your devices. These will come back once you live stream the camera.

I’m on Android, am a Beta tester, and I have Facial Recognition enabled but it still doesn’t recognize anyone’s faces. At least a few times a week I will stand in front of my v3 and stare at it so it can get a good look at my face and still nothing.

1 Like