Climate sensors show no past data, only actual

All of my 3 climate sensors have stopped showing past data on the main page for 24 hours. They show only current data. When I go into graph historical view there is data for the past few days but last 24 hours are missed/empty.
Any idea what is wrong ?

1 Like

Something similar happened to me. I ended up replacing the battery and it started working again.

For all three ?

Mine happened on one device and it is on my porch to measure outdoor temps. In my case, I think the cold drained the battery.

However, you can try one device first to see if it helps.

The devices have been purchased 4 months ago but this does not tell so much about the condition of the batteries. Only one of them have possibly been about freeze point today morning but the other two have been certainly above. There is about 1800km between me and the sensors so I tried almost everything to make them work.
I forced the Wyze app to close wait a few sec/min and restart. Probably this has solved the problem. The data has been lost certainly as all three sensors show a flat line for temperature and humidity as well but hopefully it will record again starting from now.

Did not realize how far you were from them.

If restarted your app seems to have worked, I would simply monitor it then.

Got the same on all of my 12 climate sensors since yesterday.
No idea why.

Update: looks like it’s back to normal now (24h later). :man_shrugging:

Hmm… interesting. This seems like a global system fault instead of local issues. So probably neither the battery replacement nor the app restart was necessary :slight_smile:

1 Like

Yes, I had doubts that all my sensors got out of battery at the same time.

Normally I would report it to the vendor because I guessed that this is suspicious but since the quality of support at Wyze is under my expectations I did not want to waste my time with that so I throwed up the question here in the forum.

I just checked all my Climate Sensors thru the Android app. All returned both Temperature and Humidity data graphs for today on the landing page and Day \ Week graphs on the extended data page.

Scrolling backwards thru the days to the end at March 22nd, all days prior show an accurate graph line EXCEPT for yesterday. Yesterday shows the Low, Average, and High numerical data, however the graph shows a solid straight line that is not accurate. The Humidity daily graphs reveals the same data loss yesterday as well as for March 24th.

The weekly temperature graphs show banding for every day back to March 22, EXCEPT for yesterday. And again, the weekly Humidity graphs lack banding for yesterday and March 24th.

I would suspect that there were server outages or issues in receiving the data on these days though it does appear to be working now.