Cameras asking for location

It asked to access your contacts and camera?

If you never plan on using the two-way voice, then sure it doesn’t need microphone.

It’s never asked for camera, contacts or phone permissions, and they’re not currently enabled.

Same here.

I don’t recall what was actively requested, but that is the list of requested permissions in the settings.

This is what I get when trying to add another camera. That is with location on app and phone turn off. Also tried it with my VPN turn off. My concern is someone knowing where I am located and just if someone hacks me and sees something they like in my home they know where I am at. I know VPN is suppose to encrypted data, but that doesnt mean they can’t hack. Yes, a little paranoid, but isn’t that why we all have cameras. There are to many out that want to make other people miserable.
Why hasn’t WYZE chimed in on this.
Have a great day.

So that is when it is asking for location, at camera setup. I am not sure why it does need it at setup, I do know if you turn it back off it works fine.

Probably because this mainly a user driven forum but I can tag @WyzeGwendolyn to see if they can find out. I am betting they are busy due to the issues earlier

1 Like

Thanks for the tag, Jason21271!

Android bundles permission settings together. We don’t need location but its permissions are tied to something else we do need so it’s enabled as well. Sorry for the trouble!

Not really sure what you are saying in that answer.

Stated another way, the Location permission is paired with something else that they need, and that they don’t have control over that pairing.

Just accept it as it is when you add the camera. Then when completed, go to

Settings → Apps → (select WYZE app) → Select Permissions then remove “Location”

Problem solved.

Or return the product.

Your choice.

After you get the camera setup, turn off the “location” in your app permission settings. Problem solved. :wink:


1 Like

Thought this had been done away with. Just tried to download a Time Lapse, I got asked for location again.
Android, 2.6.42
don’t like giving it out. Tempted to drive 50 miles away, turn it on, turn it off.

Is it asking for the location of the phone or the camera?

Not sure, but it might be saving the location as part of the video metadata.

Should be optional though.

If you have a VPN, you won’t have to drive to another location, assuming it’s asking for the phone’s location.

My assumption is that it is asking for access to the phones location. I know that Android bundles some of their permissions but I am unsure why it is asking on that to download a time-lapse.

I’ve been running the app on this Samsung Tab A since late Nov. Took a long time to ask

I have only run into it recently also, but I have only had it ask upon installing a new product, I know you can install the product the deny location access again, but I did not know it would ask again for a time lapse.

Edit: This is the answer I got a few months ago when I first started checking it:

1 Like

I don’t know why Android is asking, but I may be able to explain the concept of “We don’t need location but its permissions are tied to something else we do need so it’s enabled as well” – at least as it applies to Apple products. Maybe @WyzeGwendolyn can further clarify for Android.

Apple says SSIDs (network names) can be used to track your location. So in iOS 13 they made a requirement that only apps with permission to see your networks are allowed to see them. Because this is now considered a location-related permission by Apple, they are doing that using the specific app’s location permission setting. So if your location permission for the Wyze app was off, you would not be able to see local network names from the app.

When you do absolutely need that permission turned on, like with Plugs and Bulb setup, you can turn the permission off again as soon as the device is set up (System Settings > Wyze app in iOS).

So for iOS 13 with Apple at least, access to networks names equals allowing location info access by the app. That’s one possible explanation for “We don’t need location, but its permissions are tied to something else.”


Yes and from as far as I had noticed you could turn location off after setting up a product and everything worked fine, however the asking for location to download a time lapse is a new behavior to me.


I was going to test this but my internet just went down. Comcast says routine maintenance, I keep telling then this is when im always on, do it in the evenings when I’m at work, but it seems they feel they would get more complaints doing it that way lol.


Well I tried it again -
With location off did a time lapse, went to download, had to turn location back on again. App v2.6.42.
I’ll try to back up and upgrade.
/edit - nope via playstore upgraded to beta 2.7.14 - still wants location.