Anyone else's thermostat lock not working?

We have locked the thermostat remotely, but guests at our rental are still able to change the temperature using the physical wheel on the thermostat. We’ve also sent two device logs to tech support, and performed a factory reset of the device at tech support’s request. Same behavior.

Has anyone else seen this bug?

1 Like


Locked the T-stat from the app. Went to the T-stat head and tried to change temp. It told me that it was locked and would not adjust.

Scrolled wheel to Settings
Scrolled wheel to Lock
Able to unlock at the head.

Lock from the app does not hold lockout. The head has the ability to lock and unlock independent of the app.

Log 657581
FW 1.2.1

OMG thanks! What’s the point of the lock if it doesn’t lock? Sheesh :expressionless:

Time for yet another wishlist item, and…posted, waiting for approval.

Indeed. I am going to search around and see if this was found elsewhere. Also added it to my Fix it Friday list because I think it’s a bug. Will do some stumping to get support.

I’m an experienced software dev. I’ve upvoted the wishlist request to provide an SDK so that users/third party devs can submit features, but that looks like it’s not being worked on, much like many wishlist items.

At this point, I’m ready to dive into hacking the devices to make them work like I need them to. New post about that coming…

1 Like

Look what I just found from a year ago:


1 Like

Has this still not been addressed ?

What’s the point of a lock , if everyone has the key?

We need to bring this up to Wyze

No new updates from Wyze.

You are in invited to post in the Wishlist thread posted above.

You can also submit it during a Fix-It Friday call-out. However, since this is a feature enhancement and not a firmware bug (design flaw - yes, bug - no), it won’t meet the prerequisite to be picked up as a bug to be fixed for Fix-It Friday.

Beyond that, it is working as [poorly] designed.


Both the thermostat insights graph not showing for most users and the lock feature being able to be disabled manually through the display.

Poor design from Wyze

It’s now been years, and still no solution to the lock problem–a lock function that anyone can unlock! This is a huge design flaw as it renders the device unusable, especially in business or public settings.