Wyze Watch 44 no Display

I have had my Wyze Watch 44 for two days now and the Watch stopped displaying anything on the screen. I initially thought the battery was down, however, after letting the watch charge for 2 hrs the watch still will not display any information. The Wyze app does show it is at 100% battery and the app connects and syncs.

Welcome to the Wyze community @questto!
Have you tried holding the side button down to restart the watch? If that doesn’t work try deleting the watch and adding it back to the app. If the watch’s display still does not function, you may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT
Or online: Wyze.com/support
phone support is typically faster however this isn’t always true due to fluctuation in the amount of calls.

1 Like

Thanks, Holding the side button worked. I guess no did not hold it down long enough.

Moderator Note: Personal information has been manually removed from this post. Such information often gets included inadvertently in an email signature block when replying by email. The forum software attempts to automatically remove email signatures but it is not always successful. When replying to the forum by email, it is best to remove the signature block yourself before sending.

1 Like