Wyze Robot Vacuum single room scheduled cleaning

If you schedule a single room, it cleans the whole house…

1 Like

Welcome @mrjackson!
This may be related to the other issue with rooms you posted about.

Manually starting a single room works correctly though, seems like it’s in the schedule that breaks it.

Scheduling has major issues.

The vacuum seems to ignore the current room schedule if you pause cleaning and empty the bin. It will clean the whole house after you continue.

Also, the wrong rooms get cleaned sometime. Today schedule says clean room 5, but it cleaned room 4.

want to add my experience about the loss of ability to setup rooms. No longer shows anything about rooms

The room option when scheduling a cleaning is grayed-out and can’t be selected. Is this a feature that no longer exists?

HI, I find the schedule doe snot work for individual rooms.
Will only clean the whole house on the schedule, no matter which rooms you schedule.

Thanks, but it doesn’t even give me the option to schedule rooms. The option shows on the app, but it’s grayed out and can’t be accessed.

Just a general comment on these issues…I just had big problems with trying to clean rooms that previously had worked without problem. Finally realized that I had updated app but not FW..
When I made sure both were matching everything worked well!!
Just FYI - hope it helps.

Got mine yesterday. got the app and updated firmware. did the initial clean/map. scheduled a room to be cleaned at 10am today. it did start at 10am but started cleaning the wrong room. its the room where the charger is. i had to stop it because its my work area.

just an update. firmware reupdated 1.6.97. it acted up initially. had to remove the device from wyze app and re add

Our app and firmware are all up-to-date. Scheduled a single room to clean today and it did that fine but continued on to do the rest of the house.

1 Like

Had the same issue. if the Vac is scheduled to clean the kitchen ( original room 1, before dividing into 3 rooms) it will finish that room, then start the next, then the next, cleaning the entire floor. Anyone find a fix?

I used to have that issue but after the last firmware update it went away.

I did clear out my schedules and recreate them. As I was trying something out.

Try deleting and recreating the schedules to see if that fixes the issue for you as well

1 Like

I had a one off issue with cleaning one room - manually started. I was testing the Virtual Walls and sent the Vacuum to clean the master bedroom, which it did correctly earlier. I adjusted the Virtual Wall and then sent it to clean again, all of a sudden it started to act like it was mapping the room again, but positioned it 90 degrees from what it should have been. It actually looks as if it was in my front yard. :). When it indicated it was finished, it was trying to head back to where the base was but could not find the exit door. I had to hit the power button on the vacuum to stop it, picked it up, put it in my hallway then hit the power button again, which seemed to trigger a cleaning. I then used the app and stopped the cleaning, it then was able to get to the base and all was good. Below are 2 pictures - one of a successful run, followed by the one when it went awry. Curious if anyone else has noticed this. All in all, I am quite pleased with the Vacuum.

Good Run

Bad Run

After a full cleaning yesterday, I got a print that there was some map updates to accept. I did so, then today’s single room schedule decided to do the whole house…

After updating the map, it may have lost your room assignments and this caused the whole house to be cleaned.
I’ve found any changes to the map can effect the schedules


When does it map update? I wish I could get mine straight up and down so it cleaned perpendicular and parallel instead of a slightly off angle.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.