Wyze Devices + Google Home + Google Display - How To?

I’ve been trying to setup my google display so I can route any of my cameras’feeds directly to such display but to no avail. Anyone tried this successfully?

1 Like

A quick search of the Support Pages yielded this. There is a lot of good information on them. :slight_smile:

1 Like

Thank You. I’ll try that (again) and see where that leads :slight_smile:

1 Like

I got my Google Hub to say it was going to display the camera stream, but it just goes black and loads forever. I’ve never actually gotten a Wyze stream to appear on the Hub.

1 Like

Likewise. When I try to look at it on Chromecast, I only ever get a black screen. I haven’t dug deep into this, but from a quick look on the forums, it seems like the Google support is a bit spotty for video. Apparently it’s a bit more reliable with Amazon video devices (Echo Show/FireTV) devices, but I’ve only got the Echo Dot, so I can’t really test it out.

I have same issue - black screen and loading forever

I tried it again, and mine did finally load, but it took more than 2 minutes to load the camera, and then the stream only lasted about 90 seconds before it stopped again. ¯\_(ツ)_/¯ So I guess it does work, but only kinda. Haha

1 Like

On the same boat, never load on Chromecast or the Google Home Hub.

After clicking on the above link take a look at the first note highlighted in blue. I think that says it all.

Im not outside the US and when I ask the google assistant to show the camera on any of my chromecasts or google displays it never loads, all I get is a black screen with the video trying to load and it never does.

I edited my post. You have to click on the link and read what was posted there.

When Alexa integration was new, stuff like this happened too. Eventually, they shook it out.

Still doesn’t work. I’m in the US, and trying to stream on a Google Home Hub. Screen just flashes. When it does work, it works for 5-10 seconds before going black again. One of the big reasons I got this camera and considered buying several was because of this promoted feature. Seems like a lot of people are having this problem meaning its a known issue that needs to be fixed. Or take it off of your promotion and the Google site as being compatible.

1 Like

Per the linked support page:

You can also stream your Wyze Cams through your Google Home Hub, Smart device with built-in Chromecast, or even a standard screen with a Chromecast dongle.

This does not work at all for me, and was one of the main advertised features I purchased this device for. All I get is a black screen with a randomly counting down timer that never loads.

I’ve tried on two generations of Chromecast sticks and a google home display device (JBL Link View 300).

Hello @Phalkon30 and welcome to the community.

I am sorry this has not worked for you, it is a known issue being researched by WYZE. You may look in the thread I linked below to see a post from WYZEFrederick (an employee of WYZE) as to the issues they are having.


Thanks for the response and linked thread…it’s nice to see honest and transparent info from the developers. I was impressed with that during the latest data leak as well. I’ll definitely be following that discussion!

I hadn’t come across that thread, for the time being I’m satisfied they’re at least looking into it. I mean, for $25 that’s more support than I expect :slight_smile:

They are great at support and transparency. That is one of the things I love about this company.

1 Like

Yeah unfortunately I’m streaming through my Home Hub and it will play for about 5 seconds then it stops and acts like it’s buffering… then it’ll play for 1 second then buffering. I’ve tried 2.4Ghz, 5Ghz, different access points, etc and no good. No problem streaming via Wyze app on iPhone/iPad or even RTSP. I know you’re working on this and I appreciate it. Did it ever work or is this just something new going on?

Streaming from any of my 6 v2 cams via Google Assistant to Chromecast dongle (plugged into Sony TV) worked perfectly until about 2-3 months ago. Now it connects (after about 30 secs) and streams perfectly for about a minute or two, then the stream freezes and the buffering starts. Stays that way until I terminate the stream by saying/typing “Ok Google, stop”. So I can only assume that something changed on either the Wyze or Google side about 2-3 months ago that broke streaming.

1 Like