Wyze Cam v3 Pro firmware - Released 11/1/2023

I was not able to successfully flash the firmware on the cam that doesn’t require a 20 foot ladder to reach. I’m unwilling to climb around and attempt to reach the rest to get the same result.

They pop online for about 4 hours a day at this point.

If Wyze simply released the previous working version as a required update, which they can do at any time, I would be able to patch both of my cams back to working in the window of time they do actually work without spending hours on a ladder hoping for success with sd card flashing attempts that have, thus far, not been successful.

To review: Wyze forced an update on v3 pro cams. It clearly wasn’t tested well, if at all. They want me to climb around and attempt to troubleshoot and fix their update mess they created and forced into place so they can tell other people how to fix it. And they’d like me to accept a 15 dollar gift card as compensation since I didn’t keep receipts for cameras currently on my account that I’m currently paying for additional services on.

This is how you destroy confidence and loyalty from a customer base.

All they have to do to make this go away is re-release the last working firmware in the update channel. Then we all shut up and go away. Then they can redevelop firmware that fixes the security issues AND doesn’t prevent the cameras from doing the only job a camera is supposed to do.

It’s insulting and pathetic to treat customers this way.


With the assumption of lost WiFi connectivity your above quote is not feasible. Flashing is the only solution. It’s easier and faster than replacing with new. I spent many many hours distilling down what works. See my detailed topic with step by step instructions that finally worked. That is, downloading the previous working firmware and physically flashing it via a spare SD card.

Absolutely! :100:% and more! Your sentiments are shared by many here who have experienced the same on other cams in the past.

Security Updates are useless if that update makes the cam useless.

I am certainly hoping that your cams will be online enough when the next OTA update comes out to get the update. However, I would be willing to bet a dollar :dollar: against a bag of donuts :doughnut: that it will not be a reversion but an update trying to fix the update. I have yet to experience Wyze pushing out an OTA reversion update.

1 Like

I have 3 V3 pros down, attempted to flash one that I can reach, the other 2 are too high up. I also have a v3 pan cam and that was also updated the same time as the v3 pro and it too is having problems.

I can’t flash the v3 pro I can reach. I formatted the microsd loaded the recovery file from the previous firmware into it and plugged it in while holding Setup but all it keeps saying is ready to connect. No solid purple colour to indicate it flashed. This is honestly annoying.

First you need to do a factory reset. That was the puzzle piece that got me going. See my detailed topic on this.

I did that though. I took out the microsd, held down the setup button and it just goes to ready to connect.

I just made some edits for even more clarity. Read the following Google Doc…

I am not allowed to edit my original topic.

My edits…

@markrunryder Didn’t work for me. I spent about 3 hours today trying differing versions of firmware. Combos of factory resets, then flashes, etc.

All of my cams pop on randomly and reliably for about 4 hours a day. They act normally once they pop back in until they inevitably disconnect again for the vast majority of the day. I’d have plenty of time to update them (unless whatever happened fried that ability as well).

In any event, Wyze and I have a contract that I paid for. They are not upholding their end of that contract because of actions they took. I expect them to fix that.

Or compensate me to fix that which would be to refund my camera price or provide me with a working camera for each one that no longer functions. Again, I’d prefer they just fix and push working firmware.

I’m not being paid to test alpha firmware patches for wyze. This isn’t acceptable.

1 Like


I hear you. Though, I don’t care if it’s a reversion or a subversion to the update, that fixes the issue.

My cams work for 4ish hours a day. So they can be made to work again as normal with tested, correctly built code pushed.

The only obstacle to that is Wyze getting it done. They know there’s a problem. The radio silence is pretty deafening.

1 Like

Flashing back to a previous version worked for me so far. Annoying to have to get the ladder, but so far they have been back up for 5 hours.

My V3 Pro has been working after I did a power cycle when it went off line after the update on 11-1-2023 . I just powered cycled it again today and now it won’t connect. Time for the stepladder. :grin:
Done Back in business using firmware .4679 since I had an SD card with the firmware at the ready since 11-2-23. :upside_down_face:


Today’s update: If this wasn’t fun enough…after offering to replace my cameras (which mind you, I don’t want) and me digging up the proof of purchase Wyze wanted by restoring mailbox backups from July of last year, they decided they didn’t really mean to offer me working replacement cameras in the email they sent that offered me replacement cameras.

So now for anyone counting, I cannot successfully flash my cams back to working firmware. And I cannot get them replaced with working cams. And Wyze is breaking yet another agreement and offer I have in writing in an email.

1 Like

Thanks the release notes just state

Security improvements

Does this firmware update for the v3 pro cameras have a fix to allow the cameras to work on wifi networks that are not password protected (meaning now WPA. no WPA2, no WEP, etc.) on my wifi as in a open wifi (as my v3 cameras can operate on)? Thanks. I ask b/c I have an open network and purchased two v3 pros that I cannot use.

I would say no. WYZE is adding “Security improvements” to almost all their products but have not said what it does and probably won’t give details. Step 8 of the directions for the V3 Pro set up say network and password and the directions for all my other cameras have the same requirement in the set up directions for a password.

If you can’t connect the camera to the network, it’s very secure.


1 Like

At least my WCO cams and Base didn’t get knocked off-line like my V3 Pro that I had to flash back to revive. :upside_down_face:

1 Like

Has there been any updates on this? All 5 of my V3 Pro’s have gone offlline and I’ve spent hours taking them down to delete them from the app and re-add them only for them to say “cannot find the specific network name”. This is so damn frustrating.

Why are you deleting them from the app and trying to add them again if you have not flashed to a previous version of firmware? My V3 Pro went off line when I updated it on 11-1-23 but a power cycle got it back. Another power cycle I did took the cam off-line and it stayed that way. I installed an older version of firmware and it was back on line in 5 minutes. Did you change your firmware back to ?

1 Like

Update my V3 Cam Pro with the latest firmware and now the camera won’t connect to my router. Support sent me a new firmware to install and now it’ll only connect within a few feet from the router. It worked fine in my kitchen window until I updated the camera’s firmware. This isn’t nothing but a public beta program. I’m just about done with Wyze.


This firmware bricked my entire house full of V3 pros. Can you imagine wasting all this time Factory reseting and Flashing? No one has time for that. Good thing amazon has such a great return policy. Do Better Wyze. Your software and support are severely lacking

[Mod Note]: Your post was moved from a Cam v3 topic to a Cam v3 Pro topic for better visibility.