Workaround for Thermostat compatibility?

I’ve been eagerly awaiting the arrival of my new Wyze Thermostat. It finally arrived today – I was completely stoked!

I carefully unboxed and followed the instructions in the online install guide. I was profoundly disappointed when the compatibility checker reported that Wyze Thermostat is not compatible with my system.

I have a two stage gas furnace… no cooling needed here in Washington! It’s currently wired with 3 wires though the control board has the option of being wired for 4. The existing Honeywell thermostat is wired with White, Green, and Red. I have LOTS of unused wires in the cable.

Is there a workaround for this? I’m electrically savvy and have done repair work on my furnace in the past… have a pretty comfortable knowledge base of how it’s meant to work.

It would make me sad if I can’t make my new toy work!

Thanks in advance for your insights!


Where do your wires connect to your t-stat? Did you check the webpage checker and compare it to what the app says?

I only ask because my app said it wasn’t compatible and it definitely is.

Your system IS compatible. You mentioned you have 2 Stage heat, but only using 3 wires.

W - Heat
R - Power
G - Fan

Typically, 2 Stage Heat requires an extra wire going to the W2 terminal. Are you using the C-Wire Adapter included with the thermostat?

1 Like

Hi Brian, Thanks for responding! Apparently I’ve had a two stage furnace running on a single stage thermostat. I’ve now tried connecting the W, R, G, W2, Y, and C connections that exist on the furnace control board to the Wyze Thermostat. So far, no luck. Also tried using the C-Wire Adapter, still no response from the Wyze.

Any thoughts?


1 Like

Hi David,
Thanks for your reply.

I did run the compatibility checker in the phone app as well as on the webpage. Both indicate that a three wire system won’t work. The existing old Honeywell thermostat has White, Red, and Green wires connected. The control board in the furnace includes many more terminals and I do have available conductors to connect them. So far, nothing I’ve tried has worked. :slightly_frowning_face:


Hey Tom,

Can you share pictures of your wiring to the Wyze thermostat!

If you did not have a c wire connected that’s your main issue.

Also what wires are tucked behind your thermostat that’s not In use? When you trace all the wires to the boiler/system, what wires are connected? Pictures?

I can help if you have available wires not being used to your thermostat.


Hi Maluman,
Thanks for your response and willingness to help!

There was no C wire connected to my old thermostat, but I did connect it, (black insulated conductor in cable), at the furnace control board and Wyze thermostat. Also connected the W2 according to the schematic for the furnace.

I measure 27 volts AC between R and C on the control board. I’m tempted to try measuring at the thermostat backplate by using a couple of pins to access the voltage there.

At no time have I ever seen any display, lights, or activity from the Wyze thermostat. I’m beginning to wonder if it was faulty from the factory… :slightly_frowning_face:

Any thoughts or tips about what else to check?


Hey Tom,

The Wyze tutorial must have showed you the following picture…

Rh → RC and the wiring video showed you that too.

The Wyze thermostat requires your RH to be put onto RC.

As long as your RC and C reads 24 volts then it will power on once you switch the wires.


Hi Maluman,
Thanks for so gently pointing out my, (idiotic!), error! I’m a bit embarrassed that I missed that, not just once, but after looking at it several times. (facepalm)

Thermostat is now working. I don’t seem to have fire in the stage two mode, but suspect that’s a configuration on the control board dip switches.

Thanks so much for your help… and sparing me embarrassing myself with the support folks at Wyze!



Hey Tom,

No need for apology. I made this same exact issue as well. Mine was not powering on. Then I stepped away and came back and was like… oops.

I am so happy that your thermostat is working now!!

Enjoy it!

But funny thing is I still have an issue my thermostat is restarting when heat is called. But that’s my problem lol. Need to figure out what’s going on.


I was experiencing the same issue with Main Blower Fan immediately turning on during the heating cycle.
I found that my Furnace control board has (G) and (GH) terminals. (G) terminals control the main blower fan, not the smaller draft inducer fan. I searched my furnace model found that the (GH) terminal is for heat only systems. Which is what I have.

After connecting to (GH) and testing, the furnace is now operating the same as the old thermostat.
The burner lights first and once the heat exchanger comes to temp the main blower then turns on. Once temp is reached the burner shuts off and the main blower runs until the the heat exchanger cools.

I am no longer getting the immediate blast of cold air when the thermostat triggers a heating cycle.