Why is this camera reporting to China?

I’m not seeing other threads on this, can you post a link?

That could be the hardware address change bug. Manufacturers are identified by their hardware address. So if it changes, the manufacturer will appear to change. If you can identify the cam that has this new address and then see if that address matches the bottom plate on the mount, then should be able to see if this is what happened.

One of my cams changed the address. Not a concern to me, so I haven’t tried to get it to resort back.

This is the most recent one I noticed. Please continue the China-connection discussion there. Feel free to continue the manufacturer name hardware address discussion here.

I think we (myself definitely included) are way over thinking and over worried about where these things report to… as I’m typing this out on my phone I’m thinking of how my phone listens to me and my conversations (proven multiple times already) all day, every day. For that matter it tracks my every move as well… who knows maybe it’s watching me watch it’s screen too!! Just food for thought…

1 Like

Just to clarify a little bit…

No one thinks that Wyze is fabricating the wifi chips on US soil, everyone knows that WyzeCams are a product made in china, using a few common parts.

As far as i can track, all the hardware is provided by Xiaomi or the same integrator that makes the Xiaomi Mijia Dafang / Xiaofang.

And this means that the wifi module is a shelf part. One part of the cost of any radio enabled product is all the testing made from FCC. Using standard modules that are already tested and validated can accelerate and lower this cost for everyone. It is standard practice to use pre validated modules for wifi.

That being said, every product need to have a valid and unique MAC address, allowing routing and switching without analyzing every package.

So, Wizecams use the wifi module from Nova Electronics Shanghai.

During the boot, these modules have a pre-written MAC address from Nova Electronics Shanghai. This is the C8028F MACs that you are looking. The firmware takes over and then change to the WYZE MAC (4ADA22).

The bug that you encountered is that the firmware didn’t took over and changed the MAC. One (or two) hard reboot (remove the cable for one minute) should resolve this.

Doing this way, the same camera can it be sold as Xiaomi, Wizecam, NEOS Cam, or any other name, and the only real difference will it be on the firmware/software side. Integrators can use the same suppliers, the same assembly lines, the same raw materials, thus lowering the price for everyone (economy of scale)

The camera CAN it be reporting to China. BUT the mac address here is not the evidence about this.

Living on a connected world can have a lot of this confusions. sometimes it is cheaper to put your servers on China, India, etc… and this can mean that your camera will have to connect to a server there. This not necessarily mean that your data (mainly your video) is going to the Chinese government. it can be a heartbeat, a login credential, a firmware server…

All that being said, it is good to see that many users are concerned about your own privacy.


Well spoken, it is a complex process… networking makes my head hurt daily and causes me lost sleep at night… part of my daily job unfortunately so it’s a necessary evil of our modern, connected world.

China, Schmina. I consider it so unlikely that anyone in China cares how I’ dressed (or not) that the problem fades from my view.

If the Chinese (as a group) want to know what I’m doing then they lead a very sad and boring existence.


This is what I am experiencing. But I’d note that the nova MAC suddenly appeared after my camera has been connected for nearly a year. I know this because my network automatically blocked it when it suddenly appeared the other day since it was an unknown device.

After a few boots, the Nova address has stopped trying to join my network. Camera was working fine the whole time despite the Nova address being blocked.

You can run Wireshark on your network and see every packet and it’s origin/destination if you’re concerned or to dumb it down into plug and pay use Firewalla and you’ll see every device that’s attached to your network and what it’s doing (and you can control what it can and can’t do) My CCTV cameras from 2 different Chinese manufacturers tried to call home as soon as I attached them to my network - always to Chinese ip’s and across multiple ports - Firewalla is configured to block that and control what every device on the network can do. So monitoring 4 Wyze cams for months, I can honestly say I’ve never seen them try and connect to China. AWS’s infrastructure mostly in the US but occasionally Canada. Either id’d As “Wyze or ieee registration…”


While I don’t think this is going on in this case, the issue people have with devices “reporting to China” is that many iOT devices have been compromised by Chinese companies/people in the past so that they can be used to attack other computers and servers. More info on that can be found HERE

Just noticed one of my cams had a Nova MAC when it usually doesn’t. Hard reboot got it back to its regular Wyze MAC.

  • Is this one of the reasons hard reboot is recommended?
  • Can this mis-ID cause connectivity problems?
  • What is the relationship between MAC address and P2P?

Hey, folks!

This is the vendor MAC address of the WiFi chip resurfacing. Usually, it should be covered by the Wyze Cam MAC after it is set up. Sounds like something went a bit funky here. Could anyone running into this please fill out this form explaining the problem and let me know what support ticket numbers you receive? We’d like to look into it.

Submit a request – Wyze

1 Like

As many members pointed out already, having a MAC device registered under a Chinese company is different than the device is reporting to China. A device’s MAC registration is agnostic to how it communicates to the world.

Wyze cameras are manufactured in China. Most of the camera parts are purchased from China too. Nova is one of the suppliers for out manufacturer. When our camera boots up, it has an original MAC like c8028f. Wyze purchased our own MAC range which register under our company name, they start wit A4DA, 2CAA, and may be others in future. During our device boot time, our program will ‘overwrite’ the device MAC to be a uniquely assigned Wyze MAC. We have see occasional report of device showing as c8028f MAC. It is rare and not none. This is very likely to be the ‘overwrite’ failed for some reason. We are chasing the issue but it hasn’t been resolved yet. No matter what MAC the device uses your device should be functioning fine (unless you have one MAC address blocked through your network).

For the question of Wyze devices talking to oversea servers, it is a totally different topic. We have explained a few times about the history and how we addressed the issue. We have a page released at https://support.wyzecam.com/hc/en-us/articles/360027279571-ThroughTek-User-Privacy. Thanks!


Could you (or someone) put that in the FAQ under Security & Privacy please? (maybe a little wordsmithing)


Related thread:

1 Like

Aren’t MAC addresses hardcoded into the device?

Yes - they are hard coded on the transceiver chip. The firmware that sits on top of the stack will translate it to reflect a the product company name [Wyze]. As many others have stated, just because you see a Chinese MAC address (cause they kind of make zillions of transceiver chips and soc’s) doesn’t meet your device is trying to connect to China. I’m running a sniffer and I see every device, where it tries to connect to, which port, etc. Wyze seems to like Oregon where AWS has significant edge routing/POP capabilities. Then again, I’m running a rotating VPN so I have no idea where I’m located :man_shrugging: Maybe I’m in Oregon :scream:


Have you tried refreshing the router page that’s showing the WYZE device? Sometimes it will still have the last set of up/Mac data for connected clients unless you refresh the page. It’s a quirk in the internal web server in a chip that may not auto-refresh when there’s a dataset change. If is still in conflict, re-boot the cam and then the router page.

1 Like

Like the hair

1 Like

Agreed. We are working on it.