Watch 44 Notifications Not Working

I put in a support ticket, but they went quiet.

I just got my watch 3 days ago. Setup was easy, paired to a Galaxy S9 with all updates done. The watch took a f/w update right after I paired it. I can change faces and see the data on my phone. But notifications are not working.

I have the Wyze app running all the time (in background). Notifications are all on and working with my phone, just not on the watch. And, I do not use the DND on my phone. I set the Wyze app notifications for the watch to on, but it turns itself off.

Totally miffed and not happy. Any ideas?

TIA, Murph

I had this issue too, but I found this (also made a post about it in tips and tricks):


Your settings are different, maybe a different Version? I’m on 10. I do have apps–> wyze enabled for background services and the notifications for wyze are “allowed”. The wyze app is where the issue seems to be. I go to settings → Notifications, and toggle on allow notifications and it turns itself off. The stretch reminder also doesn’t stick in the on position.


I have a Pixel 4XL running Android 11 and using Android “Messages” for texting. I had turned on “Text Messages” on the “Notifications” page in the Wyse app but couldn’t get texts. I finally noticed “Other Applications” at the bottom of that “Notifications” page, tapped it, scrolled down, and found that “Messages” wasn’t enabled for notifications. Enabled it and text messages started coming through. Not sure why flipping the slider for “Text Messages” didn’t enable the phone’s default text messaing app, but you might check that and see if that is your problem.

NOTE: On my Watch 47, when a text message comes in, the watch vibrates and the text message appears on the screen. On my wife’s Watch 44 the text message does NOT pop up on the screen automatically. You have to wake the watch and then swipe down from the top of the screen to see the text message. Hopefully they will fix that in a firmware update sometime soon.

I’m on Android 11, but I remember seeing the special app access when I was on 10.

Try going to settings>notifications>advanced>special access>notifications

Or if you can search for special access in the settings search bar you might be able to find it that way. It is definitely a buried setting and Wyze did not put any warning or disclaimer about it. I only found it after searching online and I think I saw it mentioned in a reddit forum somewhere?

Galaxy S9 running Android 10 is:

Settings > Apps > 3 vertical dots in upper right corner > Special Access > Notification Access > make sure both Wyze and WyzeBand are toggled on

1 Like

Yup, that’s where it was hiding. That alone didn’t change anything. The notification setting in the Wyze app still would not stick. I even restarted my phone and the watch to no avail. What I did figure out is in that same little menu is an option called Permission Manager. I went in to it for the heck of it and found a setting for SMS with apps allowed to access it. Wyze was listed under denied. I moved it to Allowed, restarted the phone and watch, and finally I could activate notifications in the Wyze app. And, all the options of what to notify on showed up. Now the issue I am having is the watch isn’t getting ANY notifications. I turned it on for email, SMS, and a couple other items and it’s getting nothing.

Getting closer…

Thanks, Murph


The Wyze watch is Work in Progress. We are all Beta testers…We all would like this watch to perform like a Apple or Samsung yet we paid 1/3 for the product.

Ummmm… how about it just works as advertised?

1 Like

OK, getting even closer. I got my first email notification this morning!

But, I am finding out that there are hidden settings in Android keeping other notifications from being used. I need a road map to find them. :wink: For instance, if I turn on Calendar and back out of the screen below, the Calendar setting turns itself off. This was happening on Gmail but I must have found the setting by accident because it does stick. What would be helpful from Wyze is for them to publish what keeps these notifications from sticking on. The basic troubleshooting is fine - DND is off, notifications on under settings-app, background is turned on for the app under app-background… What else is there?

Anyone else having any luck enabling the different notifications?


1 Like

Murph: You may be running into the same thing that happened to me. In the Wyze app, I found that if you try to “slide” the slider (to enable a notification), it won’t stick. But if you “tap” the slider rather than trying to slide it, it sticks.


OK, that is the issue and your suggestion worked! Kudos!!


1 Like

Is there anybody else out there that is having their 44 disconnect from their phones? My notifications work, some of the time. I have yet to be able to use the find my phone feature because it’s always disconnected, even when I’m 2’ away from it. Seems like when my phone is active, the watch will connect just fine though and I’ll get notifications. And yes, I’ve gone through ALL troubleshooting (support has not been helpful) and I think I’ve toggled every phone setting imaginable. At this point, just trying to figure out if the problem is with phone (OnePlus 8 Pro on Android 11) or with the watch.

I missed that in the manual.
I must have tried 50 times to get that to stick!!
Watch 47, Samsung A20 w/ Android 10. Still not getting notifications.

It’s the watch. My watch 44 disconnects from my iPhone a lot, even when it’s right beside it. I have to manually reconnect, which is a hassle. Hopefully, the update that is being beta tested fixes this issue.

Absolutely normal behavior for this product. It disconnects from my android constantly. This product is not Beta it is Alpha. I have reported the same thing 10s of times since April and there has been 1 update that did not address it.
Over promise under deliver.

Sadly, I know it’s an issue with watch 44 and I still have the issue even after the last (and only) firmware update. I lost count how many times I’ve reported it. I’m sitting beside my iPhone and it’s still not connected after leaving the room and coming back. I’ve stopped manually connecting it because I shouldn’t have to. Disappointed! I’m seriously considering an Apple watch if I can get a good deal on Black Friday.