View On PC/Browser (Windows / Mac / Chromebook)


The other thread on the Web view i see is closed.

Last I posted, Dec 2021 that the live streaming of the cams does NOT work, just spinning circle.
Only the Event videos work.

Still is the case 5 months later.
See no change whatsoever in the Wyze webview.


They have made their bucks!

Today was the first time I used Webview and it appears to be working perfect for me. One of my cameras wasnt available, said it didnt have cam plus. I went into my wyze app on my phone saw that it wasnt applied to the camera (for some reason) I added it to the camp pan v2, went back to the computer, refreshed the page and there it was, available to view. seems like i have to use my phone to pan the camera but the live view updates on the webview. (view pans as i pan the camera with my phone).
Not sure why others are having issues, Most likely a PEBKAC error. (Problem Exists Between Keyboard And Chair)
works using chrome on iMac MacOS 12.3.1
also works on chrome Windows 10 Pro 21H1 19043.1706


Works on my Pixelbook as well. There are occasions where the feed doesn’t load, but if I refresh, it is ok.

It;s most likely something blocking it on your computer, firewall or virus software etc. my guess is that this isnt the only problem you have with your computer. [Mod Edit]

MOD NOTE: Post edited to conform to the Community Guidelines.

1 Like

Nope. It does it on any computer i try, even at others locations and internet providers.
many others posted it won’t work for them either.
Don’t seem to matter what browser either.
Even on a clean MacOS install, or Linux Live boot, with nothing like firewall, AV etc installed.

And your mod edited post, is why i do not frequent this community…mods have to edit alot of users posts her it seems.

Many of us have been using the Webview for a long time without issue which would indicate there is something else between your connections that is causing an issue. I can tell you are a smart person and you know every system is different in many ways and it is your job to figure that out. Wyze is working on and providing new products to sell them which keeps them in business and keeps costs down for those that can use their systems, and those folks don’t get on the forum to complain. Honestly, I think the Webview offering was an added feature, not a selling feature and it is free. Their cameras work well for me, I have them in Florida and in California and they all work seamlessly. Now that said I do have other manufactured cameras for reasons that Wyse cameras don’t work for but I understand those deficiencies and have chosen to use both for their respective purposes and BTW Wyze has provided an economical solution. Lastly, I am on the forum to see what new features are introduced when but am tired of reading the same complaints from the same people all the time. So I am leaving the forum so don’t bother trying to justify your position as I won’t be reading it.

Wyze needs to take some time for project improvement and bug fixing before adding more products (and more issues) to their bucket.

I have to agree. When I got my first couple of Wyze cameras, I was so delighted with them (price, quality, smooth setup) that I wanted to invest in the company.

Almost a year later, I actually have the chance to invest and have decided not to.

Becuase it seems clear that they’ve over-extended themselves and software quality has suffered; a lot. They could (and I hope will) fix it by investing more in software quality and less in new products.

Not only is Web View flakey (it does work for me most of the time tho), but the camera view on Google Nest Max displays is flakey - sometimes it doesn’t work at all, other times it works for a while (minutes to hours) but then stops working. In hundreds of atempts, I’ve never yet see the camera feed stay up for more than 2 or 3 hours. And that’s a pretty stable platform - unlike PCs which vary all over the place (probably why Web View works for some people but not others - of course if Wyze software worked as it should, it would work for virtually everyone - Netflix and YouTube do it; it’s clearly possible!).

It’s too bad - I bought the Nest Max display specifically to get a 24x7 dedicated screen for my Wyze camera looking at my driveway. It doesn’t do that.

Wyze - please re-prioritize!

Some posts were removed or edited that did not follow the Community Guidelines. Please flag posts that violate the guidelines so the moderators can respond appropriately.

Key points from the guidelines to keep in mind:

  • Remember to criticize ideas, not people
  • Please avoid name-calling
  • Don’t divert a topic by changing it midstream
  • Keep posts relevant to Wyze

Important sections:

Always Be Civil

Sometimes We Disagree


A post was merged into an existing topic: Forum Feedback Thread!

Just like Murphy, karma is always there

After some through inspection of web elements code, packet sniffing with Wireshark, and looking at DNS query logs…

Seems the culprit is that the site uses DataDog Session Replay and monitoring…its requests are being blocked due to spying/privacy concerns with the built in browser settings default enhanced privacy settings that is recommended to use. (maybe this is why they pop up a dialog that states not compatible with FireFox…as they tend to enforce more strict private settings by default)
(spaces added to prevent hyperlink conversion)

session-replay . browser-intake-datadoghq . com
rum . browser-intake-datadoghq . com

Research this company and tech used,…direct from their own website here
“With Datadog RUM’s Session Replay feature, you can watch individual user sessions using a video-like interface. This allows you to view exactly how your users interact with your website, saving you time and guesswork recreating bugs and helping you understand patterns in your users’ behavior.”…"
" The Session Replay Recorder, which is part of the RUM Browser SDK, takes a snapshot of the DOM and CSS. It tails and records events happening on the web page (such as DOM modification, mouse move, clicks, and input events) along with their timestamps." here

So…basically, if you want to use Wyzes live view website, you are granting them full privilege to record your every interactions with it.

Funny, how ONLY the live streams cease to function with this tech blocked from connection to its servers. While the event videos do not seem to be tied to it.
Maybe cause it is “beta” they implore this. But then, again, why only live stream feeds?
Both live feed and event vids are streaming from AWS addresses.

Not saying that this is definitive proof that Wyze is spying on you and your live feeds when u use the site, just pointing out that it this monitoring backend connection is required and what it can be used for according to the company that makes it.

EDIT: After ensuring those URLS are open, the feeds do load, but, not always. Still not very reliable.
Further, there is no audio on the live feeds even though it is not muted and volume is max.
Audio plays fine for the event clips.

Odd that at other locations and computers, not using the same level of browser protections and transparency on the network level as I, the feeds still are not loading. Might be a ISP router setting or ISP blocking thing. Or their antivirus software, I did disable briefly the third party ones, did not affect the issues. Did not try to disable the built in Win Defender though. And that don’t explain as to why the MacOS and Linux computers I tried on did not load either. I will look into that further, perhaps…

1 Like

Wow, every browser should be blocking that. It’s an outrageous abuse of trust.

Right now, my primary issue is that the sharing feature is broken. I have the cameras shared with my wife, but when she logs in, it says she doesn’t have access because she doesn’t have CamPlus. I have it, and in the app, it works great, but not at all in the WebView.

Is the issue, with your wife, is only with viewing on the PC (WebView)? Can she stream in the app on a phone or tablet?

Why don’t you just use your account for the WebView on the PC or Browser? Just Curious

As I said, in the app, it works great.

Because we have separate accounts. It defeats the purpose of being able to “share” if it’s not going to work everywhere that the cameras can be accessed.

Thought you were saying it works great for you.

Since it works for her in the app and not in the Webview Beta App, why not logon to the Webview App as you so your wife can stream the cameras. This could be a solution until Wyze finalizes the app and includes fixes like this.

Hello Alejandro,

Yes, I’ve installed TinyCam Pro on a Galaxy Note 8 in the past… I used it for awhile, but went other directions (Blue Iris for awhile… and I have a QNAP NAS that comes with QVR Pro)… The Web Interface is a nice addition to the Wyze Eco System, but has a long way to go to be a viable go to app IMO. I rarely use it.

Today, I opened up, saw a coyote traverse my back yard, and then swapped over to my Amcrest Floodlight camera (ASH26-W) where it was much easier to search, watch, and zoom in on video footage.

I am aware that I’m comparing a professional level of a DVR software to the Wyze Web View, and that’s probably contributes to my frustration with the many shortcomings of Wyze Web View. (Using Blue Iris also instills that same frustration with using Wyze Web View)

That said, BI and QVR Pro take many more $$$'s and configuration than Wyze Web View,

I’m currently not running the RTSP software on my V3’s (and which it were available for my Pan Cam V2’s), but I’m considering putting RTSP back on the V3’s to bring those camera’s back into QVR Pro and/or Blue Iris.


Trying this for the first time and everything seems great except Im not getting any audio after unmuting the cam (using icon at the bottom of live view feed next to pause), any ideas? Browser did ask me for microphone permision first time i logged in but only that.