Thermostat display and auto switch problem

Hi there,

I have two problems with my thermostat; motion sensor (1) and Auto Switch (2)

  1. The display screen should come on whenever motion is detected. It doesn’t work. I can be standing in front of it and waving my hand or tapping on it and nothing happens. I have to physically push on the control dial to wake it. See it on the video -

  2. The Auto Switch in the Wyze app on your phone should detect if you’re home or not. Mine doesn’t. It always says that I’m away. The toggle switch in the settings doesn’t stay “ON” when set, it reverts to “OFF” right away, see it here -

The firmware version is 1.1.1

I’ve submitted a support request [Wyze Ticket 984846], but it was pretty much useless. All i’ve got is a generic automated message with a links to the installation video and troubleshooting list which doesn’t even list problems like mine.

You could try calling support tomorrow and see if you get a better response.

WYZE Support

Live support is available:


Monday - Friday 5 am - 6 pm PT

Saturday 8 am - 4 pm PT

1 Like

I had the motion detection problem also when I first installed the thermostat. I’m embarrassed to say that I had not removed the clear plastic protective covering yet. Once I peeled this off it started working perfectly!

The Auto Switch function only works if you have location services on your iPhone enabled. You will find this in Settings/Privacy/Location Services. I’m not sure if Tracking needs to be enabled of if Location Alerts/Show Map needs to be enabled either.

I just noticed that this is the android community. Sorry about that but maybe my iOS response will be a helpful clue for android too?!

Thank you. I will have to try it eventually …

Thank you, but that’s not the case here.

Now this was good tip. I was skeptical at first because I knew that I had the location services turned “on”. However, when I checked all the settings, I’ve noticed that in the “app permission” section it was checked to allow it “only while in use”. I switched it to “allowed all the time”, and now the toggle switch stays in the “on” position.

This solves my 2nd question. Many thanks