Thermostat (Cloud icon)

What is the cloud icon with the line through it mean?

I believe that it cannot be reached. I had to power off my thermostat and back on then it reappeared after restarting the app.

This means it’s offline. Try removing it from the bracket and placing it back on to power cycle it, then close and reopen the Wyze app.

Mine does this repeatedly. The cloud icon appeared and I sent a signal to turn on. It did as I asked, but the cloud remains. Doesn’t seem to affect function?

If only we had a user manual to answer questions like this.


I’m getting the same thing, anyone found a fix to make it connect? I’m noticing this after the most recent update to the app.

I am getting clouds left and right now. I have 3 units.

This maybe the wrong place, but what is the waterdrop with a % beside it?

The humidity level.


Ahh…that’s what I thought. Thank you. Sorry for the silly question.

The cloud icon keeps returning on my 2nd floor thermostat. This one is the closest the the router. I have rebooted 5-6 times. Very frustrating.

I have submitted multiple logs and have gotten ticket #s, Nobody has reached out.

Had same issue. Another person, too, and noted that even with the icon indicating no connection, it still is controlled by the phone.

I haven’t tried it from a remote location, but even with that icon I can change settings from home.

Personally, I considered 6 units for my business, but based on what your seeing with three and my experience, maybe I’ll wait for the Wyze folks to get this worked out first.

That is the thing. They seem to still “work”

My cloud icon comes and goes too. Yes, I would wait for some bugs to be worked out, also would wait until they have a proper operating manual.

Wyze release a manual? We should be so lucky.

The only disconnect I have seen is that it shows not connected when you view the Firmware Update list screen …

Everything else appears to work

Mine corrected itself for a few days but I just checked now and the cloud icon is there with a line through it again. Did a reset on it when it first happened, it helped for a little while and then it appeared again. It’s hit or miss. Frustrating because it worked fine for the first 2 months. The only thing Wyze will respond back with is telling me how to install the thermostat which is not the issue, or they offer to exchange the device. This appears to be a software upgrade that is needed, not a hardware issue.

I just installed my thermostat yesterday and woke this morning to notice the cloud thing. Has there been a fix for this yet?

Mine eventually went away. I never found an actual fix for it. Make sure the firmware is upgraded on your thermostat though, they may have patched it.

Still a mess. All 3 occur randomly.