Smarter, Better, Faster, Stronger: Wyze Robot Vacuum! 11/10/20

I downloaded the beta version of the app, which now includes the edit mode for rooms. Which is great and basically what I was looking for.
However, the edit function is still a little “imprecise”?
Some splits it doesn’t let me make. It appears I don’t exactly understand where I can place the split line and where not. Some points it will take/stick to and some it won’t and the endpoints of the split line then just randomly move somewhere.
Any ideas or instructions how to split rooms and why it sometimes doesn’t “accept” points. Although such points are clearly corner points from a wall.

Yes, Splitting Rooms currently does not give all the flexibility people need, as the split markers only attach themselves to real walls, not virtual walls, and then only to a corner at that. I believe they are working on this.

That’s what I had thought/assumed. But I was only trying to attach to real walls. And it was (some) corners where it did not work. On the other hand it worked on any points at other walls (not only the corner). I couldn’t see the consistent pattern.

@Newshound I’m in the beta program and I have app version 2.16.31 installed and the vacuum is on firmware version 1.6.75 but when I look at the map of my house I only see the square box icon to edit the virtual walls and NO pencil icon to edit the rooms. :frowning: What am I doing wrong?


That’s a good question. It has disappeared from my Beta app as well. Wonder if that routine is not actually part of the app, and they are loading it remotely?

I even have an Alpha app, and it’s not there either. So all 3 are missing the icon ATM on my device.

Well that’s not good. Hopefully it comes back soon, I was really looking forward to testing it.

On a different matter, I posted some requested improvements on another forum post and wondered if you know the best way to get those requests to the devs? Well, the ones they aren’t working on already.


In theory you have already done that by posting to the wishlist. :+1:

Nice! Thanks. I wasn’t sure if there might be a better, more direct method since I’m in the beta program also.

Just realized this too. That is pretty disappointing. Why would Wyze remove that feature from the beta app? Without that feature I find that app and the vacuum not very useful. Please, Wyze, put that feature back asap.

I pre-ordered the Wyze vac based on the features described on the web site. It is very disappointing that a number of advertised features appear to be either non-existent or non-functional. At this point, I am considering canceling and paying the extra $$ for a product that is more fleshed out than this one seems to be.

Wyze, this appears to be a trend. You’re releasing new products that have not been fully tested and integrated with the Wyze app. This is really not a sustainable business model. These things should be ironed out in the alpha or beta testing process, not after the retail product ships. I have a pair of Wyze Cam V2’s, and they’re great, but I’m honestly going to start looking at other brands. I want products I can rely on to work, not that I have to spend a ton of time troubleshooting or doing things over.

1 Like

First the vacuums were not supposed to ship until January, seeing how 15% have shipped early is a nice surprise. It wouldn’t surprise me if there will be software updates in January to add any features that may have been discussed on the forum.

Looking at the landing page though I don’t see any claims that the vacuum will not perform day 1. What features do you feel are missing? I think I read from an official Wyze source that multiple maps can be saved. I believe form first reviews this feature is currently missing. Other than that I don’t think I know of other missing features.

When a product is launched, there is always an implied statement that it is ready for market. Not necessarily perfect, because the manufacturer cannot test for every possibility. But reading this thread, there are issues with the units straight out of the box. There appear to be issues with mapping, saving maps, naming rooms, virtual walls, return-to-base, etc… That functionality is why I ordered the Wyze vac.

I suppose we can only hope they resolve the issues quickly, so the units will perform as advertised.

1 Like

I see what you are saying now. I misread your post originally. I do wonder what happened between the beta versions and the go-to-market versions as most of the beta testers I have seen have stated order this vacuum now as it is the best you will see at this price point.

I am one of the 15% with the vacuum expecting to arrive this week, so hopefully, mine will work as expected. :crossed_fingers:

This may be the most confusing company I have ever dealt with.:roll_eyes: I was sent a email notice telling me to choose my gift option with the recent purchase of my Wyze vacuum. I was told to enter my generated code, and then choose my gift. I chose the v3 camera. The site said that you may have to wait til February if you picked the v3 cam, and then directs you to a email notification page. Once you enter your email address it asks, “What is your question?” I typed, Please send me the v3 camera. No send option was shown on my android phone after competing my question. I hit the return button ( having nowhere else to go) immediately all information was wiped out. I decided to go to support…Big mistake, everything is a automatic generated response to your typed question.No help whatsoever. You need to have a human option. The only reason I am here in the community is out of frustration. Hopefully my camera will arrive someday…but I am doubtful at this time.

I had similar issues. It’s not your phone.


I’m getting the V3 cam also. Did the page tell you that they will be emailing you the code for the cam in a few days? That’s what it told me. The box for your email address on the V3 page is so you will be notified when the camera is back in stock. If you want the notification email sent to you then just go to the Wyze page and find where to buy the V3 camera. It will tell you it’s not available but there is a place on that page to enter your email address to be notified. That should be the same thing. So when we eventually get the “back in stock” email from Wyze THEN we can use the code that should have already been emailed to us to go on the Wyze page and place an order for the camera. Enter your code when checking out and it should be free.

As long as you clicked the “Choose your free item!” button on the email and entered your email address there and selected the V3 camera and submitted then you should be good to go. I tried to click on the button in the email again and it tells me that I have already taken the survey at the top of the page so you can’t accidentally submit it twice.

Good luck!

Yep…exactly as you wrote. Where the confusion set in for me…was getting “TWO” emails reminding me to order my gift before Jan 4th. This made me think that the first email where I sent in my code a week earlier didn’t take.

Got my Wyze Robot Vac on Tuesday and let me tell you I am very impressed!!! The Vac is well built, the Lidar works exceptionally well, and the cleaning pattern is very good. The app works great also and being able to watch the vac clean in real time on the map is really cool. Also being able to see when you would need to change out the brushes and filters is very helpful. The only things it is missing is a multiple floor map option which I think Wyze is working on already and a automatic dustbin which is not necessary but just helps me be even lazier lol

Yep I use mine and battery has not been a problem

I received my robot vac on Thursday as well. I’m not sure if this is the best place to post review/comments so let me know if I should move this. But here’s some initial findings. To preface, I have a Xiaomi Roborock S5 that has worked great, but that is my only reference point for robot vacuums.

Unboxing: Initial unboxing, I was impressed with the packaging (loved that it came with an extra brush and filter).

Setup and Charging: The setup was pretty straight forward, the first time I held down the two buttons to reset the wifi it turned off the machine instead but eventually I got it. I noticed the charging station is very light and trying to wrap the cord up inside the station is finicky and kind of a hassle. The first time I turned it on the vacuum started up and proceeded to knock over the charging station.

Initial Use: The first time it started cleaning it got stuck on a bathroom rug and proceeded to spin around for 5 minutes or so looking like it was trying to figure out how to exit the room. I have some footage of it here… IMG_0490.MOV - Google Drive

Then I noticed that there was a firmware update so I picked it up and repositioned it and tried pushing the button on the vacuum to return it to the charging station. It started going back into the bathroom and couldn’t figure out how to return to the station. So I just had to pick it up and put it back on the charger. (One note, my charging station was located in the hall on a side wall of the bathroom so the vacuum was actually behind the charging station on the other side of the wall, I wonder if that is what was causing the confusion?)

Once on the charger I tried to update the firmware but it kept giving me an error saying make sure that it is connected to wifi and on the charger. After several attempts I figured I would just let it charge to 100% overnight and try again in the morning.

In the middle of the night I heard the vacuum announce something like it was powering off to go into power saving mode, which was strange. In the morning I tried to update the firmware but it said it couldn’t connect to the vacuum, I soon found out that the prongs were not properly touching the charging station so I guess it had powered off at night because it wasn’t charging.

Once charged it let me update the firmware. Then I just hit clean and let it run to see if it could finish vacuuming the whole floor without getting stuck.

Getting Stuck: Overall, it only got stuck twice. Once it wedged itself between a chair and a table leg with just enough room to go in but couldn’t figure out how to get out. The other time it got fixated on my coffee table, all the legs are connected together as one metal bar so it looks like it could go inside clean but it could not get over the bar and it just kept circling the table trying to climb over making a lot of noise. Here’s what the coffee table legs look like for reference… IMG_0505.HEIC - Google Drive

Eating cabled and things: It ate a couple cords. The first was a phone charger which it dragged to another room before I saw it. Another was a plug for a handheld clothing steamer which was on the bathroom counter. It ate the cable and pulled the steamer off the counter and spilled the water out of the steamer. Luckily it didn’t do anything to the vacuum. It also ate a pet blanket that I forgot was on the floor.

Lidar and Pathway: The Lidar sensor seems on par with the xiaomi. If you haven’t ever used one, it maps the room pretty accurately. The pathway it takes was pretty thorough. It traced around a pretty large section of the floor and then zig zags inside the section, not missing any spots. One thing I noticed in the beginning was that the location of the vacuum did not match what was on the screen at times, which made me wonder if the vacuum itself thought it was in a different spot that it was actually in.

Collection bin: The overall dust/dirt it collected was a good amount even after having vacuumed previously with a normal vacuum. I don’t think emptying the bin is a painful process at all. Its a pretty good size and I think it would be able to clean several times at least before having to have it emptied. I also don’t think battery life is going to be an issue, unless you have massive square footage.

Overall: I think its a decent first vacuum for Wyze that hopefully will improve with software adjustments overtime. I do think you need to pick up everything off the floor that it could potentially eat before you start it up. This may be a dealbreaker for some who want to just set a schedule time for it to always run. I don’t have kids but I imagine small toys would definitely be eaten up as well.

The Xiaomi is superior at not eating cables or getting itself unstuck, but Wyze did a fairly decent job as well. I’m hoping there are ways to improve this in the software over time. Also this was its first running so it was also mapping out the floor, I will keep testing and see if the behavior improves.

V2 wishlist - a heavier charging station